LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Zenwalk (https://www.linuxquestions.org/questions/zenwalk-75/)
-   -   Removing icons from the desktop (https://www.linuxquestions.org/questions/zenwalk-75/removing-icons-from-the-desktop-483414/)

AtomicAmish 09-14-2006 08:07 AM

Removing icons from the desktop
 
The panel works well, and I like the look of a clean desktop.

How can all icons be removed from the desktop?

jstephens84 09-14-2006 01:45 PM

to remove the icons go to a terminal, then go to your home directory. Under your directory you Will see Desktop. This is where you will see your icons.

AtomicAmish 09-14-2006 04:37 PM

Quote:

Originally Posted by jstephens84
to remove the icons go to a terminal, then go to your home directory. Under your directory you Will see Desktop. This is where you will see your icons.

That's what seems strange. From the command line in my home directory, that is, /home/myname/Desktop, ls -l gives me "total 0."

In the file manager, going to /home/myname/Desktop shows me only a .directory file.

Yet, on my desktop I still have three icons. File System, Home, and Trash, and none of these can be deleted in the GUI.

jstephens84 09-14-2006 04:51 PM

Quote:

Originally Posted by AtomicAmish
That's what seems strange. From the command line in my home directory, that is, /home/myname/Desktop, ls -l gives me "total 0."

In the file manager, going to /home/myname/Desktop shows me only a .directory file.

Yet, on my desktop I still have three icons. File System, Home, and Trash, and none of these can be deleted in the GUI.


use midnight commander and see if that helps. if you don't have it installed use netpkg to install it. I believe it is mc.

AtomicAmish 09-14-2006 09:39 PM

Mc
 
Quote:

Originally Posted by jstephens84
use midnight commander and see if that helps..

Yes, thanks, it was mc in the repositories. Still no luck, though. MC lists the same .directory file shown in thunar, and that's all it shows.

vonski 09-23-2006 12:15 AM

If you wish you can remove icons from desktop completely - choose settings -> desktop setting, on second tab you can disable icons on desktop. If you want to have icons on desktop but not default ones (as I understand) it's currently impossible.
I tried to paste link to xfce-dev mailing list but linuxquestions said I'm not allowed :). So if you want read why you have to look for this thread yourself ;)

AtomicAmish 09-23-2006 11:50 AM

Great first post
 
Quote:

Originally Posted by vonski
If you wish you can remove icons from desktop completely .. ;)

Aha! I knew there must be a way.

Very nice, vonski. Much appreciated.

stinkinrich88 03-06-2007 10:41 AM

using "System Tools" --> "Configuration Editor" goto

/apps/nautilus/desktop/

you can then get rid of just the system icons

guth 03-06-2007 03:26 PM

not on ZW ;) no nautilus :)

mrcheeks 03-13-2007 02:55 PM

I think it is in a hidden folder. Look in the .cache or .config directory, you will see entries for this desktop files. Sorry not to give more details, I am not running ZenWalk right now.

guth 03-13-2007 05:43 PM

those 3 icons (trash, home, filesystem) can't be deleted from desktop, they come from xfce itself.

The only way to "hide" it is to hide ALL icons on desktop in xfce options.

infiniphunk 04-01-2007 07:25 PM

Settings > Desktop Settings, select the Behaviour tab. Halfway down there is a menu box, just select 'None'.

Nemesis1963 05-04-2007 05:30 AM

To remove filesystem, home and trash icons from your xfce4 desktop, edit (or create) the file
~/.config/xfce4/desktop/xfdesktoprc like this:

[file-icons]
show-filesystem=false
show-home=false
show-trash=false

Now restart xfdesktop and enjoy the new settings :)

Source: can't post it because it's my first post here :(

Nemesis1963 05-04-2007 05:31 AM

http://www.mail-archive.com/thunar-d.../msg03260.html

fuzzyfroboy 07-30-2009 12:52 PM

Remove the icons from thunar
 
Does anybody know how to remove those same icons from the side pane on Thunar? I don't want filesystems to be there..


All times are GMT -5. The time now is 08:13 PM.