LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk
User Name
Password
Zenwalk This forum is for the discussion of Zenwalk Linux.

Notices


Reply
  Search this Thread
Old 01-16-2022, 01:02 PM   #1
Noblets12
LQ Newbie
 
Registered: Jan 2022
Location: BU 28410 France
Posts: 6

Rep: Reputation: 0
Netpkg et hplip


Hello. I just installed Zenwalk 15.0 "near landing" on my PC. In the system menu I don't have the "netpkg" selection. Netpkg works from the command line. When I try to use Hp-setup I get the message "No module named 'PyQt5.QtWidgets'. What am I missing
 
Old 01-18-2022, 01:26 AM   #2
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 7,569
Blog Entries: 19

Rep: Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451Reputation: 4451
PyQt5 is a set of Python bindings for Qt, which is the library underlying KDE. You could try reinstalling that package
 
Old 02-13-2022, 01:28 PM   #3
H1p8r10n
Member
 
Registered: Feb 2016
Location: on the border of milky way
Distribution: Slackware
Posts: 159

Rep: Reputation: Disabled
Hi,

Hp Setup is normally not needed : cups can handle installing printers without it.

Since printers are becoming very rarely used these days : Zenwalk comes without it, but t takes a few seconds to install it with Netpkg.

You will also need hplip and qpdf (a very weird dep).

Type "netpkg cups hplip qpdf" in the CLI, and you're done

JP
 
Old 02-15-2022, 09:26 AM   #4
Noblets12
LQ Newbie
 
Registered: Jan 2022
Location: BU 28410 France
Posts: 6

Original Poster
Rep: Reputation: 0
Hello. After installing cups hplip and qpdf, my HPPhotosmart5510 printer prints fine. This printer also has a scanner function. I installed Xsane but Xsane does not recognize the scanner. The error message asked to install libgimp. After installing Libgimp Xsane works fine. I have another problem. Zenwalk freezes after a period of inactivity. This happens with or without xscreensaver. The keyboard or the mouse are without action. Should I open a new post?
Thanks to Hazel and H1p8r10n for their help.
 
Old 02-15-2022, 02:41 PM   #5
H1p8r10n
Member
 
Registered: Feb 2016
Location: on the border of milky way
Distribution: Slackware
Posts: 159

Rep: Reputation: Disabled
It can happen that the Linux kernel doesn't handle suspending specific devices. Check that the xfce power manager is started and try to figure out what is causing the freeze : suspend? hibernation? or just some weird opengl screensaver.

Anyway this is likely not a Zenwalk specific issue, so posting to general Slackware thread can be of some help.

Jp
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slack and netpkg shag Slackware 12 07-02-2020 07:05 AM
Installing HPLIP-GUI on HPLIP 3.17.11 Linux Mint 17.3 laptop anon298 Linux - Software 1 02-26-2018 08:22 PM
[SOLVED] Upgrade hplip-3.9.4b to hplip-3.9.12 (32-bit and 64-bit) tronayne Slackware 8 02-27-2011 11:12 PM
HPlip woes on --current ; Sharing printer gets broken if the hplip gui is launched Old_Fogie Slackware 2 10-28-2010 10:23 AM
Netpkg adds dependency checking jpgu Linux - News 0 12-24-2005 06:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk

All times are GMT -5. The time now is 12:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration