-   Zenwalk (
-   -   Lilo wont install (

jasonpeinko 11-06-2006 11:12 PM

Lilo wont install
Im trying to install zenwalk 3 but lilo wont install so i cant boot.

blackhole54 11-07-2006 06:16 AM

Can you give a little more information please?

jasonpeinko 11-07-2006 09:42 AM

well after I install all the packages from the CD then it would you like to install lilo and i say simple yes. Then i hit next and it says lilo could not be installed. After that I reboot without the CD. then it just prints a bunch of 99's to the screen

blackhole54 11-07-2006 10:46 AM

Try following the directions in this link for "repairing lilo." At this point don't worry about editing lilo.conf. And when you mount the partition, instead of using "-w" as stated, I would suggest "-o rw,dev" to make sure the partition is not mounted nodev (that would guaranty failure). If this doesn't work, report back any error messages you get.

jasonpeinko 11-08-2006 12:24 AM

Well lilo wont even install.... Here is the exact error:
Sorry, but the attempt to install LILO has returned an error, so LILO has not been correctly installed. You'll have to use a bootdisk to start your machine instead. It should still be possible to get LILO working by edditing the /etc/lilo.conf and reinstalling LILO manulaly. See the LILO man page and documentation in /usr/doc/lilo/ for more help

blackhole54 11-08-2006 01:01 AM

The instructions I gave you in post #4 are to be carried out after you have completed the installation, including its failure to install LILO. Those instructions are the attempt to reinstall LILO manually (using the install disk or a live CD) that the message you quoted is talking about. If this attempt to install LILO fails, we should have different (and hopefully more informative) error messages to guide our repair attempt.

I know the attempt to install LILO during installation failed. Please try to follow those instructions from post #4 and the link included in it and report back any errors you get. Or who knows? Maybe it will actually work. :)

bullinchinashop 11-08-2006 06:24 AM

I had that happen when I tried to use extended partitions. I tried Both Zenwalk and Slackware had a fit when I tried to install lilo on an extended partition. When I gave up and went back to primary extensions lilo installed fine.

jasonpeinko 11-08-2006 06:03 PM

how do i do this part:
>mount -w /dev/hdXY(hda6 for me) /mnt/linux

my swap is hdb1
and linux is hdb2

i get:
-w: No such file or directory

jasonpeinko 11-08-2006 06:43 PM

figured it out i got to the lilo -v part

and it says warning: '/proc/partitions' does not exist, disk scan bypassed
Warning: /dev/hdb2 is not on the first disk
fatal: filesystem would be destoryed by LILO boot sector: /dev/hdb2

blackhole54 11-09-2006 02:13 AM

OK, good.

I need to make sure I know how you want the machine to behave at boot. I am guessing you must have a different OS on hda? Do you want the LILO you are trying to install to be the bootloader that executes when you first turn the machine on?

In any case, I think your LILO configuration file might be messed up. With the partition mounted as /mnt/linux (like you did above), the file should be /mnt/linux/etc/lilo.conf. Could you post its contents please? (I don't know what tools the CD you're booting from has available, but if it has them, you can use tools like cat, more, less, vi, or your favorite editor to examine the file.)

Just to give you a jump start on where this might be going, if you want LILO to be the bootloader that executes at powerup, and lilo.conf has a line that reads:

boot = /dev/hdb2

try changing it to

boot = /dev/hda

and run lilo -v again.

WARNING: Doing what I just said will wipe out any existing bootloader that currently executes at powerup.

jasonpeinko 11-09-2006 09:35 AM

ill try it when i get home

matheuslbarros 11-10-2006 12:33 PM

i now, how to install the lilo.. o/
in my instalation .. have the problem too
you have to install manualy.. select the partition.. and go to menu.. -configure linux- think is this... and in instalation .. /dev/hd** put /usr/local =D
but.. when go to start...

Starting up x11... ocurred one error.. and not initialize
if have someone who now how i initialize in text mode ..


All times are GMT -5. The time now is 07:19 PM.