-   Zenwalk (
-   -   connecting with ndiswrapper (

Duster 10-20-2006 03:05 AM

connecting with ndiswrapper
Hi, Zenwalk on my old laptop is alot faster than opensuse 10.1. My first issue right now is getting ndiswrapper; wlan0 to start.

I have my card present, and detecting my network with iwlist wlan0 scan.
My problem is I can not get it to gather an IP number besides home ( The card is set to managed and to autodetect dns.

the Network config tool will only see eth0, which is useless to me as I am only able to connect wirelessly. I know the driver I used works, worked great on Suse, and iwlist finds all the wireless networks in my locale.


Could someone please help me with Zenwalk 3.0 to load ndiswrapper on setup and connect, and for Network configuration to find my wlan0 card?
I have already set the essid with iwconfig - and it accepted it.
I have also done ifconfig wlan0 up, down, up, etc . . .
Some reason why - I just can not on Zenwalk 3.0 get it to connect.
Just in case it is like suse, yes eth0 is down, and disabled.
also lspci finds the pcmcia Broadcom card right away.
Hope this info may give a good starting point for a solution . . .?

Thank you, I hope to get Zenwalk online over the weekend.

Duster 10-20-2006 05:29 PM

I finially got NDIS wrapper working, I am on the laptop right now.

I had to write a shell script for now to get the wireless working once booted. details are below. *** Does anyone know of a way to automate this in Zenwalk without a shell script?? **

BUT for anyone else possibly having issues with Zenwalk Linux and NDIS wrapper, here is what I did

First I went to /etc/rc.d

second open rd.inet1.conf in your editor (bluefish is default)

third I disabled eth0

4th I added the lines at the bottom of this post

5th . . .
modprobe ndiswrapper
ifconfig wlan0 up (note ifup does not work)
iwconfig wlan0 essid <your network here>
dhcpcd wlan0
then in /etc/rc.d directory
rc.inet1 restart

You 'should' be connected

It took me a while - hopefully this may help someone who may stumble upon this post

** Shell Script
make a <yournetwork>.sh in /bin directory
in <yournetwork>.sh type

modprobe ndiswrapper
dhcpcd wlan0
ifconfig wlan0 up
iwconfig wlan0 essid <yournetwork>


then ls -al - <yournetwork>.sh

reboot (after the script below is put in to rc.inet1.conf)

then at the bash prompt type
bash <yournetwork>.sh
You should connect

# NDISWRAPPER WLAN0 for broadcom pcmcia card:

# end of wlan0 modifications to this script

All times are GMT -5. The time now is 03:46 AM.