-   Zenwalk (
-   -   can't enter run level 4 after updates with gslapt and can't - su; no terminal access (

slipstream5 03-23-2012 02:58 AM

can't enter run level 4 after updates with gslapt and can't - su; no terminal access
Since I am newish to Zenwalk (7.0) and also recently installed Salix OS, I made a big mistake of installing Gslapt and confusing it with xnetpkg as the method to safely update (with GUI) in Zenwalk with dependancies included. I should have suspected that something could go wrong since there were a large number of packages/applications selected for upgrade and I am using kernel recommended to work if using older Nvidia drivers.

I noticed that there were xorg server and related updates as well. After the updates I lost my right-click for Zenwalk short cuts and also Geany or mousepad wouldn't open. Then everything seemed to freeze and had to do a hard reboot.

When I try to boot into Zenwalk I get:


init: entering runlevel 4

 /etc/rc.d/rc.M: line12:/etc/shell-colours: no such file or directory
 /etc/rc.d/rc.M: line10:/etc/shell-colours: no such file or directory
 /etc/rc.d/rc.M: line14:/etc/shell-colours: no such file or directory
(and line 14 repeats 10 times)

    init: Id  "x1" respawning too fast: disabled for 5 minutes

but nothing happens and if I try

, I can't access

- su
cause it says that I'm not in the terminal so even if I knew what to do next, I can't even attempt to fix anything...

So I'm hoping, really hoping, that there is help and it can be fixed, and was updating with Gslapt in Zenwalk really not so bad?

slipstream5 03-24-2012 01:44 AM

I ended up re-installing Zenwalk 7. With this install I notice that some quirks I had previously are also gone! Also I was able to re-install Nvidia drivers so much quicker (since I got advice on that). I will only use netpkg to upgrade now (carefully) and I am using Zendo for pkg management as well.

The only little complaint is that Zenwalk still doesn't come with grub2 instead of lilo since I am having trouble with my multiboot (which I will solve another way...) and grub2 can probe other OS quite well. I know I can switch to grub 2 but I read that it comes with some risk and I've had enough re-installs to last a lifetime lol!

Note: I marked 2 posts as solved but the solution occured by re-installing but can't find a way to close the thread...

All times are GMT -5. The time now is 02:45 PM.