-   VectorLinux (
-   -   Sharing files question (

TroN-0074 07-02-2012 07:49 PM

Sharing files question
I am trying to mount some files from my desktop to my laptop running vector linux 7

I am issuing the command

# mount.cifs // /home/user1/Downloads -o domain=workgroup,rw,file_mode=0777,dir_mode=0777,uid="$USER"
Which replies

bash: mount.cifs: command not found
What am I doing wrong?
I havent modified anything after installation what files should I modify and how.
I will appreciate all advices. Thank you!

evo2 07-02-2012 08:20 PM


it looks like you don't have cifs-utils installed.


TroN-0074 07-02-2012 10:09 PM

Thank you for your reply. I did a search for the cifs-utils in the package manager and I couldnt find any. The search result only comes back with SAMBA which is already installed.

TobiSGD 07-02-2012 10:23 PM

In Slackware the mount.cifs command is part of the samba package, I assume that this is the same for Vector. Are you trying this as root?

TroN-0074 07-02-2012 10:34 PM

Yes, I am doing this as root. It is the same command I use in my slackware installation and works fine there.

I will appreciate all advice. Thank you!

evo2 07-02-2012 10:58 PM


sorry about the incorrect information about what package provides mount.cifs.

I think you should probably check to see if mount.cifs really exists and is in your path. Check to see where it is on your slackware installation:

which mount.cifs
then check to see if it is in the same place on your vector install.



TobiSGD 07-08-2012 06:10 PM

Out of curiosity I just installed Vector Light 7 into a VM and discovered that /sbin/mount.cifs does exist, but it is only a symlink to /usr/sbin/mount.cifs, which doesn't exist. So it seems to me that Vector Light is broken.
A web search has revealed nothing about this, which I find rather surprising. For many people mount.cifs is essential, I wonder how it can be unnoticed that this is broken, especially when one keeps in mind that the beta phase of Vector was not really short.

Anyways, I copied over mount.cifs from a machine with Slackware 13.37 and now it works. May at least be a workaround for you also, if needed drop me a message and I can send you mount.cifs per mail.

TroN-0074 07-08-2012 11:05 PM

Thank you for the tip. I transferred /usr/sbin/mount.cifs from SlackWare to Vector then I ran the command and I received a reply

bash: /sbin/mount.cifs: Permission denied
I am doing this as root so I dont know what to change in the file

However I haven't done anything to the /sbin/mount.cifs file

I will appreciate all advice

TobiSGD 07-08-2012 11:17 PM

Check if the file is marked executable.

All times are GMT -5. The time now is 09:21 PM.