-   VectorLinux (
-   -   curious problem (

wrat 05-16-2004 03:11 PM

curious problem
Ive got a presario 4770 that i scavenged its a p200 with 48 meg ram, some sort of s3trio onboard graphics, 4gig hd etc...Im locked out of the bios I tried adding more mem but itsa no go..... my question I installed vector 3.2 had a hell of time configuring x even tried copying the exact config I got from running damn small linux and no it all running and its DOG slow almost dsl running from the cd was fine..the machine is not on my net so I cant post config info....what should I check?? I dont think it is a lost cause , cause dsl from cd ran well...ideas??

chakkerz 05-16-2004 11:54 PM

define dog slow ... it's a p200 with jack all ram, running a GUI is going to be slow, especially KDE or Gnome.

Try IceWM if you must have a GUI, but i'd be inclined to say that a 200 ain't gonna do GUI. Maybe if you went for something old like SuSE 6.2 or RedHat 7.0 .... but anything recent is going to want something fast. Especially current GUI's

I had a 166 6.2 SuSE Pro ran fine, RedHat 7.0 was ok. 7.1 was bearable. 7.2 leaning towards painful, and after that i gave up. I did try debian 3.0r0 on it and that was torture, as was Slackware 9.0 ...

Megamieuwsel 05-17-2004 05:35 AM


but i'd be inclined to say that a 200 ain't gonna do GUI.
There's plenty of lightweight WMs , that'll run ok on a system like that.
IceWM and Fluxbox will be a relief after having tried KDE or Gnome.
If only for the lack of bloat....
What's more effective , is go through the list of servers , started automatically and disabling the ones you don't use anyway.
Replacing XFree with Xorg , will help some as well.
And re-compile the kernel for your architecture : Compiled for i586 works much better on such a system than the default i386.
These are just a few tips.
Use at your leisure.(and risk , maybe....)

wrat 05-17-2004 06:45 AM

dog slow is 30-30 seconds for a window to open...I wasnt running kde or gnome I wouldnt expect to be able to...however I know this machine can run dare I say fast because with dsl from the cd it you might say well just load dsl to the hd,however thats not what I wish to do...vector has speed I just need to know how to get it there...

Megamieuwsel 05-17-2004 07:03 AM

That's not a matter of tweaking ; That's a case of "Something Gone Awfully Wrong Somewhere"(tm)
I had Vector4.0 once running on a P120 laptop with 32MB of RAM and while not exactly a speed-demon , it still wasn't even remotely as slow as that.(didn't get pcmcia working , though...)

I'd advice : Do a clean re-install and monitor every step carefully. Keep pen & paper handy.(in case you get an error-message)
You might also try another formatting. I always use ext-3 and I'm pretty content with that.

Even a 486 shouldn't be that slow.

Chris H 05-17-2004 08:17 AM

I installed VL on P200 with 32Mb RAM. Used XFCE and worked OK. Not gonna set the world on fire, but ok.

chakkerz 05-17-2004 07:53 PM

well, fair enough, like i said IceWM might do it

But when i say "it ain't gonna do GUI" i don't mean it's not going to display it, i mean it's not going to be a breeze to use, like i said also, I've run Linux on a 166, and it worked great, but that was quite some time ago.

KDE 2 will do it, and Gnome 1 should also.

In addition Megamieuwsel is quite right (again :) ) Disabling non needed Deamons like ftp sendmail whatever could increse your performance ... maybe not dramatically, but definitely increase it.

Sorry, i did express myself poorly

wrat 05-18-2004 06:49 AM

yeah I guess Ill have to reinstall although that is the M$ way of doing thing that Im trying to get away from

Megamieuwsel 05-18-2004 05:27 PM

before you go wiping it all , check the output of "dmesg" , /var/log/messages , /var/log/debug and others that might give a clue.
There's an awfull lot of info in these logs.
(It's an awfull lot of reading too , btw.....)

wrat 05-19-2004 12:22 PM

fixed w/o reinstall it was using vesa driver..further editing of xf86....seemed to do it

chakkerz 05-20-2004 03:12 AM

yeah that'd do it. ... but didn't you say you'd checked that? :)

well good that it's all working either way

wrat 05-20-2004 06:42 AM

sort of ...what I did was get it to work using vesa because on install it didnt detect anything for sh*t and I manually added things to config x until I got a gui.. I had tried using the s3 driver but for some reason it didnt work then once I had the vesa driver I was able to switch to the s3 driver .. it was a cirular process no doubt

All times are GMT -5. The time now is 03:21 AM.