-   Ubuntu (
-   -   Xubuntu 6.06.1-alternate-i386 installation problems (

rm_-rf_windows 09-17-2007 08:47 PM

Xubuntu 6.06.1-alternate-i386 installation problems
I tried to install Xubuntu on my old laptop and encountered two main problems : INSTALLING GRUB and LOGGING IN

During installation, you get here:


You need to make the newly installed system bootable, by installing the GRUB boot loader on a bootable device. The usual way to do this is to install GRUB on the master boot record of your first hard drive. If you prefer, you can install GRUB elsewhere on the drive, or to another drive, or even to a "floppy."
This is followed by

The device can be specified using GRUB's "(hdn,m)" notation, or as a device in /dev. Below are some examples:
- "(hd0)" or "/dev/hda" will install GRUB to the master boot record of your first hard drive (IDE);
- "(hd0,1)" or "/dev/hda2" will use the second partition of your first IDE drive;
- "(hd2,4)" or "/dev/sdc5" will use the first extended partition of your third drive (SCSI here);
... CLEAR AS MUD!! I punched in /dev/hda on that line... When I finished installation, Windows did not appear on the list! This wouldn't necessarily have been a big problem, for I could have edited the /boot and grub configuration files, however...

I couldn't log in using the information I entered when I did the installation.
I tried everything, including logging in as su and sudo using that same password I entered when I installed Xubuntu. I even tried su without a password... (Of course, I did panick...)

Well, I then did a fixmbr using my Windows recovery disc and got nothing when rebooting!! I then used GParted and discovered that the Xubuntu partition was marked 'boot'. I changed the Windows partition to boot, unticked the 'boot' option on the ext3 partition and I got my Windows back!!

So, Ubuntu is 'installed', I can access my Windows partition... Is there an easy way to resolve the above problems? Is there a default su or sudo password?... How can I fix the boot problem at this point? Is there a way of logging in? I could erase the partition and start all over... However, I didn't find that grub installation page of the installation process very clear...

I would like to install GRUB on the main MBR and have it list the two OSs, obviously... If there's no way around the login process, I guess I'll just have to reinstall Xubuntu...

I couldn't find a good step-by-step guide for this version of Xubuntu... ("alternate" version).

Many thanks...

GrapefruiTgirl 09-17-2007 09:11 PM

I will try to help with one little part of your issue..

I only used Ubuntu for a very short time. I mostly use the LiveCD version of it now on occasion.
I found that using the LiveCD, there didn't seem to be a way for me to change to root or use su, because there was no password that I could figure out. SUDO did work however.. So,
What I ended up doing was entering a console and typing 'sudo nautilus' to get myself some power to do file manipulation, installing, or whatever. The same principle would likely work to start the user & password manager (I think Ubuntu has one? Like 'KUser' in KDE). If you can find the User & password manaager in the main menu, right click it or otherwise get its properties, particularly the application path, and then use 'sudo /path/to/user/manager' to start the thing up.

Now, to do this to your installed system, you will hafta be running the liveCD or another installed Linux system, and do 'sudo chroot /dev/hda3' to CHROOT into your installed Ubuntu's filesystem. (Change /dev/hda3 as necessary for your system) . Once you are chrooted into your installation, try the sudo-password-manager thing above, and set the root password (hopefully it won't ask you for the old password first :p that would suck). While you're there, may as well make yourself a user account, so atleast you can boot and log in as 'someone' and work on fixing the password issue.

A final point -- It has been written that an un-set root password on a freshly installed system is sometimes 'toor' (as in root backwards) but that didn't work on my Ubuntu.

Is this too convoluted, and/or have I missed the root of the issue?

P.S. - I love your username; funny stuff :)

IndyGunFreak 09-17-2007 09:16 PM

All I've ever used is the Alternate Install CD, and I don't recall ever seeing the messages you mention.

What version?


rm_-rf_windows 09-17-2007 11:12 PM


The version number (exact) is in the title of this thread... (lol)


Thanks for the response...

To all,

I've made some progress...
- I've been able to edit the menu.lst file using the installation CD
- I've been able to get "Windows" to appear on the grub boot list, however, I haven't been able to get Windows to boot properly. I have tried different classic entries for the Windows OS in the menu.lst file... No luck.
- I've figured out that the default user name is "oem"... and the password is the one entered when installing (I looked in the /home directory and saw an "oem" directory
- I can't figure out how to go into graphical mode. startx isn't recognized...
- When going into rescue mode using the CD, I am root. Is there a way of resetting the root password from there? I am also root in recovery mode (without CD)

Any additional help would be appreciated.

Many thanks.

P.S. - I get the following when trying to boot Windows XP:

Booting 'Windows XP'

root (hd,0)

Error 23: Error while parsing number

Press any key to continue..._

Note that the line in my menu.lst file is:

title  Windows XP
root (hd,0)
chainloader +1

rm_-rf_windows 09-17-2007 11:37 PM

Okay, more progress...

- Changed the root password, so I can log in as root or as a normal user


- I still can't get grub working properly
- I still can't go into graphical mode (xfce)
- The clock in Windows is two hours behind... Its settings are correct (Europe, etc.). This is surely due to a choice made during installation (Ubuntu)... How do I get it back to normal?

Gonna get some shut-eye...

Wim Sturkenboom 09-18-2007 01:12 AM

With regards to X, what error message do you get? What are the make and model of video card and monitor?

The clock: have you tried the date command to set it? Read man date, I see there is an option to use UTC (what you probably have selected during the install) so leave that out.

This does not help you, but I installed XUbuntu (dual boot with SLackware 10.2) on an AMDK6-III system with Matrox G400 videocard and a 2GB and a 80GB HD. I also don't recall seeing the information that you have mentioned regarding Grub.

rm_-rf_windows 09-18-2007 09:32 AM

It's an Amilo Fujitsu-Siemans (Series 2000 or 2S or something like that) with about 230MB of RAM.

The Xubuntu-...alternate-i386 installation is for servers and old machines. The regular Xubuntu CD didn't work. It's an "old-style" installation: The screen looks something like what other Linux installations looked like 3 or 4 years ago. Strangely enough, a lot of different Live versions don't work on this laptop, perhaps because there is less than 256MB or RAM.

Regarding the boot problem, I'm doing something wrong because when I tried to fix it, the ext3 partition became boot again and I wasn't able to boot (Windows was no longer a boot partition). I don't know what I'm doing wrong though.

I'm sure someone has encountered this very same problem...

budword 09-18-2007 10:20 AM

grub entry mistake...
Hey John, it's David. :)

Grub names hard drives and partitions with 2 numbers, not one. So that grub entry should be (0,0) for the first partition on the first hard drive. "root (hd0,0)" should be your windows partition. That's the reason for the error 23 bit.

The not starting in a gui is a little weird. Start gdm on the command line, log in via the gui, then once you get to a gui, there should be a setting to always start in the gui. I'll look it up latter today, if any of this works for you.....

I have to run, but I'll be back in a half an hour or an hour, and get the rest of the info needed here. How did the kubuntu install go ?


GrapefruiTgirl 09-18-2007 10:58 AM

Here's a tiny suggestion for starting X -- when logged in to the console as root, try either:

1) type 'locate gdm' to find out where the GDM binary is. Chances are good it will already be in your $PATH, but just incase it isn't. locate it and type '/path/to/gdm' and see if that starts X.


2) Not sure what runlevel your ?buntu is booting into, but try typing 'telinit 5' or failing that, 'telinit 4' to switch to the graphical run-level.

As another user mentioned above, consider what video device and driver you are using. It's possible that X did try to start, but was misconfigured, in which case you may get useful information from the log file(s) located in /var/log such as /var/log/xorg.0.log which is the X server error log file.

rm_-rf_windows 09-18-2007 01:50 PM

Thanks budword! Yeah, you were absolutely right about the (hd0,0) bit. Thanks!

To the rest of you...

Everything's working now, bootloader and all... Only one small problem... I tried to download the xubuntu-desktop from the command line (apt-get install xubuntu-desktop). I think it did download and install, however, I now get a blank screen when I log in... Can't even get a shell!!

Help !!!

Many thanks...

SilentSam 09-18-2007 02:41 PM

The blank screen without shell is usually a sign that your xorg.conf in /etc/X11 is incorrect. This could be due to a number is reasons: incorrect resolution, or incorrect drivers etc.

Are you using an nvidia or ATI driver? It would be helpful also if you posted your xorg.conf file here.

rm_-rf_windows 09-18-2007 02:57 PM


Got a few other elements to give you:

Video card: RADEON IGP 320
ATI U1/A3 Accelerated Graphics Port

There is no X11 file in /etc. There is a thing called "x11-commmon" in init.d

Sorry if these answers aren't useful to you. I don't know all that much about this stuff... I cannot cut and paste things into here because of the limitations of the other computer... But just let me know if you need any additional info...


Note: Since this thread is about general installation, I've started a second thread about this specific problem. Perhaps we could take it from here now:

GrapefruiTgirl 09-18-2007 05:32 PM

X11 should be a folder actually. The full path is usually /etc/X11/xorg.conf and that is the video config file.

I don't use ATI stuff, so I'll *guess* that the ATI driver you would want by default will be called 'radeon' but please check this or wait till someone with ATI stuff can verify that for us.

As for the blank console, try switching terminal windows using CTRL-ALT-Fn where Fn is a Function Key (F1. and see if you have any other terminal windows where you can log in and check into the xorg.conf file.

rm_-rf_windows 09-19-2007 03:02 PM


- The clock in Windows is two hours behind... Its settings are correct (Europe, etc.). This is surely due to a choice made during installation (Ubuntu)... How do I get it back to normal?
Wim Sturkenboom responded...

The clock: have you tried the date command to set it? Read man date, I see there is an option to use UTC (what you probably have selected during the install) so leave that out.
I've decided not to install Linux on the laptop because there are serious graphics problems when installing such a system on this model... Now, how do I get my clock back to normal via Windows?

SilentSam 09-19-2007 03:29 PM


Originally Posted by rm_-rf_windows (Post 2897120)

Wim Sturkenboom responded...

I've decided not to install Linux on the laptop because there are serious graphics problems when installing such a system on this model...

That's too bad. You could always try another distro though, you might get a much, much better result.


Now, how do I get my clock back to normal via Windows?
I'm pretty sure Windows reads the time off of the system clock. You can usually set it in the CMOS on boot, or just right click the clock in the system tray to set it.

All times are GMT -5. The time now is 01:42 PM.