LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   X restarts when i start a graphical application (https://www.linuxquestions.org/questions/ubuntu-63/x-restarts-when-i-start-a-graphical-application-547869/)

Kanesoban 04-21-2007 01:07 PM

X restarts when i start a graphical application
 
The title says it. When i start Beryl, or Total annihilation Spring (this is a open source 3D RTS game) X just retarts.
I have Edgy installed btw.
I dont know what version graphical drivers i have, if anybody asks. How can i find that out?

b0uncer 04-22-2007 08:03 AM

The problem is apparently that those programs (Beryl, 3d games, ...) need 3d rendering and your X doesn't work all right with it. It can (or cannot) be solved by installing appropriate drivers, if possible; I have a laptop where it's impossible to run Beryl (for example) because it does just that, and for the chipset I have there exists no Linux 3d drivers. The problem arises also if I try to run glxinfo to determine whether or not I have DRI enabled -- apparently it isn't :)

If you happen to own an ATI or nVidia video card, (on ATI preferably newer than 8500) you can try to get past this by installing either nvidia's or ATI's official drivers. You can see which driver your X is currently using with
Code:

less /etc/X11/xorg.conf
..and then scrolling down to the part where it says
Quote:

Section "Device"
Identifier "Your Video Card Name Or Something"
Driver "videocarddrivername"
...
EndSection
The Driver part says it: on nVidia card it can be "nv", on ATI it can be "radeon" for example or it can be just "vesa" for a generic (not-so-good-looking) stuff. For SiS chips it's usually "sis" and so on.

The installation of proprietary drivers depends on your distribution, but usually it's easy trough package manager. Note that it might not be unproblematic, so before proceeding read appropriate threads here at LQ.

Kanesoban 04-22-2007 08:53 AM

I have a NVIDIA card, and i installed it after i installed Kubuntu, and Beryl did work ! But for some reason Beryl makes X restart if i try to start it. I dont know how long it is like that, i dont use Beryl often, and i just installed Ta Spring recently.

Hm, maybe i reinstall the GFX driver.

Kanesoban 04-22-2007 05:19 PM

Ok, reinstalling the driver solved the problem. Thanks for help.


All times are GMT -5. The time now is 01:23 AM.