Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 01-10-2007, 06:46 AM   #1
LQ Newbie
Registered: Apr 2006
Posts: 23

Rep: Reputation: 15
X applications ignore UMASK settings

hi all,
i've tried setting the UMASK throught ~/.bash_profile and /etc/login.defs and even /etc/gdm/Xsession
but X applications completely ignore my modifications and make all files unreadable by all users in my group.

The problem is that all files i create under /var/www are not readable by apache and so i have to manualy chmod from a terminal every time i create a file.

Which file must i edit in order to have X applications use my UMASK setting ?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proper umask settings for /etc/fstab? stefanlasiewski Linux - General 6 06-05-2009 07:27 PM
GTK Applications Not Respecting Subpixel Settings tvynr Linux - Desktop 1 09-06-2006 07:42 PM
vsftpd umask settings fluffyvoidbunny Linux - Software 2 02-07-2006 04:06 PM
Umask - Settings XaViaR Linux - General 2 09-28-2005 07:24 PM > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 11:38 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration