-   Ubuntu (
-   -   Wireless NIC "disappears" after software update... (

eagle63 09-10-2006 10:12 PM

Wireless NIC "disappears" after software update...
So I've installed Ubuntu Dapper on a P3 1 gHz Dell box, 256 ram, 160GB drive. The sole purpose for this machine is to run Slimserver. (at least for now)

I installed Dapper via a CD, everything went fine. I have a new D-Link 802.11g NIC that seems to be supported by the kernel. Ubuntu recognizes it just fine, and I'm able to put in my WEP key and start surfing/emailing without issue.

So after my clean install and WEP-key setup, the next step is I update my /apt/sources.list file (via the GUI in Ubuntu) and check the LTS Updates and LTS Security Updates (both binary). I DON'T check any of the "universe" packages, only those that say "Officially Supported". After closing this window, it tells my software is out of date and I allow it to upgrade. It's about 190 meg download, so I come back an hour later and it said everything was upgraded successfully.

Now, after a reboot, I notice I have no internet connection. I go into System --> administration --> networking to discover that my Wireless NIC (ath1) is completely gone from the Connections tab! Only "Ethernet Connection" and "Modem Connection" remain. What the heck happened??

I tried rebooting, re-seating the NIC, etc, but nothing helps. I briefly looked through dmesg but I didn't see anything that jumped out at me. It's almost like the wireless NIC has been totally uninstalled/removed. If I type "ifconfig" from the command line it only lists eth1 (ethernet NIC) and the loopback. However, if I go into System --> administration --> device manager, it still shows the NIC in the list of devices.

After all of this happened, I ended up grabbing the Ubuntu install CD and blew-away my system and re-installed. I followed the same steps as before, and hit the SAME PROBLEM. After doing a big software update, the wireless card disappears.

So I guess one option is to not install any updates, but that's not a viable solution. Does anyone have any ideas or things to try troubleshooting? I'm hesitant to spend the time re-installing Ubuntu for the third time without first having some idea of what's going on.


mcmahonc 09-12-2006 01:42 PM

Wireless NIC "disappears" after software update...
I had the same problem after updating from Breezy to Dapper. Seems there's an ongoing issue. I'm using a linksys WPC54G wireless card and have to use ndiswrapper. I tried reloading ndiswrapper using the same files on the same usb stick but it wouldn't work until I used the original linksys CD.

fragos 09-12-2006 06:19 PM

You might try running wifi-radar. I've had good luck running it in a laptop with Broadcom chips that required ndiswrapper. I had strange problems after my first reboot when I was using gnome-network-manager. Ultimately after much trial and error I replaced gnome nm with wifi-radar and all works well now. The network monitor applet was helpful in seeing what was happening and I placed an icon for wifi-radar next to it in the applet bar.

ddibbz 09-25-2006 12:29 AM

I did the same thing and got the same problem... Whats the solution?

fragos 09-25-2006 03:31 AM

Check System-> Preferences-> Sessions-> Startup-Programs tab to see if you have "gnome-nm". If you do, disable it.

eagle63 09-25-2006 09:42 PM


Originally Posted by fragos
Check System-> Preferences-> Sessions-> Startup-Programs tab to see if you have "gnome-nm". If you do, disable it.

Is this something that would appear AFTER having allowed Ubuntu to update all of its packages? The reason I ask is because I don't see that in my startup programs tab, but after my most recent "fresh" install of Dapper I haven't allowed the package manager to download/update any software. (for fear of losing my NIC again)

ddibbz, did you try this and did it fix the problem for you?

Thanks everyone!

fragos 09-25-2006 10:15 PM

It might have been installed when you followed one of the many HOWTO's for getting WiFi to work. If it isn't there, all the better.

zvandiver 12-15-2006 04:05 PM

I am having a similar problem installing Edgy on a Gateway MX6447 laptop. After the basic OS installation, the wireless card (Broadcom) shows up in the network connections utility (KDE). After installing ndiswrapper and drivers, the card disappears.
Is there a configuration file somewhere that is preventing the wireless card from being detected after ndiswrapper is installed? Uninstalling it doesn't restore detection of the card.

fragos 12-15-2006 06:00 PM

There's more than one Broadcom chipset. lspci will tell you which chipset you have. I would have thought if you could see the wifi device the drivers were already installed. Perhaps in the ndiswrapper install sequence you created a blacklist entry for the Ubuntu driver which now needs to be removed.

XE1UFO 12-16-2006 12:37 AM


Originally Posted by fragos
You might try running wifi-radar. <snip>

Is there a 64-bit version of this somewhere?

Thanks in advance!!

fragos 12-16-2006 12:49 AM

I suggest to run Synaptic and insure that the universe and multiverse repositories are selected. Do a search in Synaptic for wifi-radar and install to see. A lot of 32 bit applications run with a 64 bit kernel, for example openoffice. Many 32 bit applications will inform you if they won't run properly on a 64 bit machine. I think it will work since its not kernel level code. If it doesn't, un-install and there should be nothing lost. I ran it on a 64 bit machine with a 32 bit kernel.

jschiwal 12-16-2006 01:43 AM

Ndiswrapper includes both the ndiswrapper command and an ndiswrapper kernel module.
If your kernel was updated, you might not have the ndiswrapper.ko module in the current kernel module tree. Take a look and see if you can find it.

You could make a new kernel module from the source. I keep the source around and generate a new one whenever I update the kernel.

ssgt 09-18-2008 01:24 PM

Same problem Different Twist
The problem I have had is that I installed ubuntu. wireless worked perfectly right off the bat. roomates mac didn't work. my xp and linux pcs did not have a problem with adding wpa to the wireless. I installed all the updates just fine. After a few days of running ubuntu the wireless disappears exactly the same as everyone else. No updates though. Even worse, I reinstalled ubuntu twice thinking it worked when I first installed it so a reinstall should fix it. I don't know what happened but not even a reinstall fixed it. I don't know if ubuntu took setting off the old install and applied them to the new but it seems kind of strange. The reinstall should have done the trick. This happened after I found out ubuntu doesn't support by mx 310 printer so my dreams of a printer server were dashed. Almost makes me want to forgo linux completely. It's certainly more stable, but stability is worthless absent usability.

All times are GMT -5. The time now is 05:09 PM.