LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 09-24-2006, 06:45 PM   #16
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Rep: Reputation: 157Reputation: 157

Hmmm,... there was a link to a nice tutorial here somewhere... I can't remember where it is on how to manually set the wpasupplicant.conf...

Once that is set, I've taken to a set of scripts to launch WPA support...

I can forward what I have, once I have my Debian Etch laptop re-connecting to the wireless router. I updated my kernel, and now my Madwifi drivers are SNAFU...

I have one script to take down ethernet, and up the wireless... another to launch wpa_supplicant, and still a third to launch wpa_gui... to monitor the process...

I'll be happy to forward them once I have removed the log from my own eye...
 
Old 09-25-2006, 12:21 AM   #17
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Ehm, you need to install wpa_supplicant. In Ubuntu try using Synaptic or try "apt-get install wpa_supplicant". I'm sure Ubuntu has the package in its repositories.

Try avoiding downloading seperate packages unless is absolutely necessary.

edit. This was meant as a reply to jaymoney

Last edited by Haiyadragon; 09-25-2006 at 12:22 AM.
 
Old 10-03-2006, 02:05 AM   #18
DodoTux
LQ Newbie
 
Registered: Mar 2006
Location: Nairobi, Kenya
Distribution: Zenwalk4.0
Posts: 27

Rep: Reputation: 15
Quote:
Originally Posted by Haiyadragon
So I tried wpasupplicant again. Cleaned out the config file to this:

Code:
update_config=1

ctrl_interface=/var/run/wpa_supplicant

ctrl_interface_group=0

eapol_version=1

ap_scan=1

fast_reauth=1

network={
	ssid="configuredssid"
	proto=WPA
	key_mgmt=WPA-PSK
	pairwise=TKIP
	group=TKIP
	psk="configuredpskpassword"
}
Run "wpa_supplicant -c /etc/wpa_supplicant.conf -i wlan0" (as root ofcourse). It spits out a whole lot of errors but it works anyway I think it has to run as a deamon, that means all the time.
Can you explain that config a little? I am also trying to set up WPA-PSK with wpa_supplicant, but i couldnt find a good how-to in the web. How do you set it up to run as a deamon? Thanks.
 
Old 10-03-2006, 08:57 AM   #19
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Rep: Reputation: 157Reputation: 157
There are some guides out on the net about how to set up a WPAconf file...

I just do't have the links at the moment...
 
Old 10-03-2006, 11:35 AM   #20
DodoTux
LQ Newbie
 
Registered: Mar 2006
Location: Nairobi, Kenya
Distribution: Zenwalk4.0
Posts: 27

Rep: Reputation: 15
All i ever see are "finished" WPA.confs but nobody has ever explained them to me.
 
Old 10-04-2006, 02:12 AM   #21
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Quote:
Originally Posted by DodoTux
Can you explain that config a little? I am also trying to set up WPA-PSK with wpa_supplicant, but i couldnt find a good how-to in the web. How do you set it up to run as a deamon? Thanks.
I only understand the network part. Maybe it works without the other stuff, I don't know. I just removed all comments and network profiles and this was the result.

ssid and ps are simply keys set on the router device, you need to match them to log in on it.

You can supply -B to run it as daemon. My only problem is that sometimes the network device is brought up before wpa_supplicant can do its stuff. So I need to restart the network device after boot. Don't know what to do about it.
 
Old 10-04-2006, 09:01 AM   #22
davemeadowcroft
LQ Newbie
 
Registered: Oct 2006
Distribution: Ubuntu Server
Posts: 3

Rep: Reputation: 0
I used knetworkmanager (if using KDE) last night. Worked a treat!
 
Old 10-04-2006, 11:31 AM   #23
DodoTux
LQ Newbie
 
Registered: Mar 2006
Location: Nairobi, Kenya
Distribution: Zenwalk4.0
Posts: 27

Rep: Reputation: 15
My prob is that i dont run Ubuntu. I found the thread through "search". I run ZEN WALK with XFCE. wpa_supplicant and that other app wpa_cli . now, what info do i need, how easyly can i get it and how do i "input" it into wpa_supplicant.
 
Old 10-16-2006, 04:22 PM   #24
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Rep: Reputation: 157Reputation: 157
Do a search for wpa_gui or wpagui or any other variations you can think of.
 
Old 10-16-2006, 06:14 PM   #25
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
Weird... I'm using network manager on my laptop and it supported WPA out of the box.
 
Old 10-17-2006, 07:41 AM   #26
rothchild
LQ Newbie
 
Registered: Dec 2005
Posts: 19

Rep: Reputation: 0
The easiest way around the PITA that is WPA_supplicant is to use the network manager package, handle wpa and wep keys and is quick and unobtrusive.

Gets my vote anyway

Child
 
Old 10-17-2006, 12:46 PM   #27
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Rep: Reputation: 157Reputation: 157
In Ubuntu or Kubuntu?!?!? In Kubuntu, I finally have networking set up in a nice clickable tray icon... enter my password twice... and I'm off to the races...

In Debian, I had to configure a set of scripts with ifup and ifdown to get wireless working right... and it inevitably took forever while polling potential IP addresses not in the range of the router's selected ones...

Kubuntu is much nicer...
 
Old 10-17-2006, 12:54 PM   #28
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
Try installing network manager: sudo apt-get install network-manager network-manager-gnome
You'll get an icon in your tray which easily handles all wi-fi/wired connections as long as they use DHCP.
 
Old 10-19-2006, 07:54 AM   #29
jaymoney
Member
 
Registered: Mar 2006
Location: Cincinnati, OH
Distribution: Ubuntu 8.10, Xubuntu 8.04, Fedora 10
Posts: 87

Original Poster
Rep: Reputation: 16
i installed both packages and im not sure where to go from here... i see the icon, but when i click it, it says no network devices have been found...

Last edited by jaymoney; 10-19-2006 at 11:32 AM.
 
Old 10-19-2006, 10:08 AM   #30
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 16
Quote:
Originally Posted by Samoth
But WEP is (relatively) easy to break into. You could of course turn on MAC address filtering to only allow certain MAC addresses to connect.
Then all I'd do is use a mac-changer. Tools like airsnort and aircrack are making it very hard to keep something secure.

The way I think, just password your local services (printers, file shares, etc) and then leave the rest of everything encrypted with only a public key. That way you don't have any dorks with wepattack and wireshark stealing your passwords all the time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network manager unable to connect to unsecured wireless - WPA networks fine :S phyre-x Ubuntu 8 05-16-2011 10:11 AM
wireless + wpa abu_the_armsdealer Linux - Hardware 5 03-07-2007 04:43 AM
Wireless network manager using WPA encryption dgranger Linux - Wireless Networking 14 09-20-2006 12:23 PM
WPA on wireless network The Patbon Mandriva 10 03-16-2005 10:55 PM
Configuring WPA-secured wireless network dori Slackware 1 10-07-2004 06:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 04:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration