LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   wireless network - WPA (https://www.linuxquestions.org/questions/ubuntu-63/wireless-network-wpa-482881/)

jaymoney 09-12-2006 05:25 PM

wireless network - WPA
 
Right now my wireless home network is set up with WPA Personal network authentication with TKIP encryption. I am running Dapper Drake, and i have and Intel Pro/Wireless 2200BG Network Adapter.

I am having problems connecting wirelessly while running Linux. I am able to choose my Wireless network. But there is no option to select WPA or WEP, it only is WEP. The only thing i can change is dhcp or static, and ascii or hex for the network key. Sorry this description is not better, I have to do this all off the top of my head, bc there is no way to post while in Linux.

I guess my question is does Linux only support WEP? Is there a way to connect to WPA? Ill use command line if necessary.

Thanks in advance

Jason

Samoth 09-12-2006 05:52 PM

You will need a package called "wpasupplicant". If you have "universe" repositories set up, you could try out "wpagui" too.

randell6564 09-12-2006 09:10 PM

Would it not be easier to just change from WPA to WEP? It's just a home network after all.

Samoth 09-13-2006 07:05 AM

But WEP is (relatively) easy to break into. You could of course turn on MAC address filtering to only allow certain MAC addresses to connect.

jaymoney 09-13-2006 07:28 AM

it is still easy to obtain a MAC address from a computer that is currently connected/allowed by a router.

anyways i would rather find a solution in Linux rather than just changing it to WEP, that just seems like the easy way out.

Samoth 09-13-2006 07:33 AM

it is, did you try wpasupplicant and wpagui out yet?

jaymoney 09-13-2006 10:45 AM

no i wont be able to try those out until i get back from work. thanks for the help by the way.

randell6564 09-13-2006 10:51 AM

Quote:

Originally Posted by jaymoney
it is still easy to obtain a MAC address from a computer that is currently connected/allowed by a router.

anyways i would rather find a solution in Linux rather than just changing it to WEP, that just seems like the easy way out.

You wanted to connect to the internet, I told you how you could.
You did not mention that it was really no big deal, that you just wanted a challenge.

Good luck!

Haiyadragon 09-13-2006 11:08 AM

Quote:

Originally Posted by randell6564
Would it not be easier to just change from WPA to WEP? It's just a home network after all.

A home network can't be abused? This logic is too hard for me.

Btw, wpasupplicant is insanely hard to setup. Any tips?

randell6564 09-13-2006 01:24 PM

Quote:

Originally Posted by Haiyadragon
A home network can't be abused? This logic is too hard for me.

Btw, wpasupplicant is insanely hard to setup. Any tips?

You're right, I was not making sense. But, I'm the kind of user that NEVER stores important information on my box.,ESPECIALLY if I'm wireless!

I use WEP, and I have never been compromised. My meaning was that even if someone did gain access to my box, or connection, big fricken deal! What are they gonna do.,browse my photo's? OMG!

Sure, they might be able to screw up configurations (if they tryed really, really hard!), but everything that is important to me, I backup anyway. If It became so neccessary, I would just wipe my drive and re-install! BUT.,this has NEVER been neccessary to date!

Haiyadragon 09-13-2006 02:17 PM

The chances are slim. But no asshole is gonna use my network :p

I just made it work btw. With wpasupplicant. I tried NetworkManager but with all its dependencies it still wouldn't run. And when I finally managed to fire it up it couldn't detect wlan0 :/

So I tried wpasupplicant again. Cleaned out the config file to this:

Code:

update_config=1

ctrl_interface=/var/run/wpa_supplicant

ctrl_interface_group=0

eapol_version=1

ap_scan=1

fast_reauth=1

network={
        ssid="configuredssid"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="configuredpskpassword"
}

Run "wpa_supplicant -c /etc/wpa_supplicant.conf -i wlan0" (as root ofcourse). It spits out a whole lot of errors but it works anyway ;) I think it has to run as a deamon, that means all the time.

And then I can use the usual ways to bring up a network device with dhcp (differs per distro, don't know for Ubuntu).

randell6564 09-13-2006 02:26 PM

Quote:

Originally Posted by Haiyadragon
The chances are slim. But no asshole is gonna use my network :p

LOL! BUT...
If you were in a situation where you lost your internet connection, but your Wireless picked up an un-secured network, would you use it?

Be honest! If yes, then YOU are an "asshole" :P lol!

Haiyadragon 09-14-2006 05:23 AM

Quote:

Originally Posted by randell6564
LOL! BUT...
If you were in a situation where you lost your internet connection, but your Wireless picked up an un-secured network, would you use it?

Be honest! If yes, then YOU are an "asshole" :P lol!

I would. But only because that guy didn't read my post to enable WPA ;)

randell6564 09-14-2006 09:09 AM

Quote:

Originally Posted by Haiyadragon
I would. But only because that guy didn't read my post to enable WPA ;)

LOL! ;) back at ya!:D

jaymoney 09-24-2006 04:37 PM

i dont have a wpasupplicant.conf file anywhere and im also not sure how to configure it. where should i create the the file? also i tried to run wpa_gui but the command was not found. i then downloaded wpagui_0.5.5-1_i386.deb then tried to run it and got the error Dependency is not satisfiable: libc6. any suggestions?


All times are GMT -5. The time now is 10:21 AM.