-   Ubuntu (
-   -   Wine crashing the X server after upgrade (

nitrousoxide82 01-10-2007 12:52 AM

X server crashing after upgrade (SOLVED)
After upgrading package xserver-xorg-core to the latest version (apt-get upgrade), Wine (0.9.28) is causing the X server to crash. Wasn't doing this before the upgrade. Upgraded package version is 1:1.1.1-0ubuntu12.1. Can I request a downgrade? What version number should I use for that?

[Edit]I just downgraded it to 1:1.1.1-0ubuntu12 and Wine still causes X to crash. I am positive that this system wasn't doing this like the day before yesterday. And I didn't switch versions of Wine or anything like that...

[Another Edit] Just grabbed Wine 0.9.29 from WineHQ's APT repository and still no go. Anyone getting the same problem?

[Yet Another Edit] I just found out that the problem isn't restricted to Wine. ZSNES, MAME and StepMania all crashed the X server and got me back to the login prompt. All of them used to work. I'm totally clueless as what the problem might be... any help is most appreciated.

[Enough already!!] I found the cause of the problem - it's OpenGL-related. All programs I mentioned use OpenGL (at the exception of Wine, at least I didn't know until now - it must be for DirectX emulation or something). MAME worked when setting its video output to software mode. Looking further...

[You just like editing, don't you?] Finally solved. I decided to edit and leave it here for future (and for other users', if need be) reference... I think the new X server didn't like something about NVIDIA's binary driver, so... I compiled a new kernel (2.6.19, straight from, installed the latest NVIDIA driver on it, and... after hours of configuring, compiling, setting boot options etc., the problem is gone!

corvus123 04-08-2007 12:16 AM

Thanks, you just saved me hours and hours of annoyance! FWIW I just reinstalled (recompiled) the NVIDIA driver and I was set.

valerie_tux 05-02-2007 12:59 AM

Thanks Nitrousoxide for the direction.. I was facing the same problem and was clueless as to what had caused it.
I am running Debian sid and it turns out that the xserver-xorg-core had over-written the in the xorg's modules. So nvidia crashed out whenever the glx drivers were called (which happened to be anytime wine started or glx related query was raised)
I fixed it by renaming the in /usr/lib/xorg/modules/extensions and then sym-linking the nvidia libglx file as

I think re-installing nvidia has the same effect and therefore it works.

Makes me wonder though. Why didnt apt give me an error before over-writing a file?
more details

nemozny 08-07-2007 08:56 AM

Thank you, I though it has to be nvidia drivers since noticed that direct rendering is off. As usually after xorg* upgrade.
If anyone would be so kind and posted his solution..

All times are GMT -5. The time now is 08:25 AM.