LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-29-2010, 02:15 PM   #1
unix1adm
Member
 
Registered: Oct 2008
Posts: 624

Rep: Reputation: 30
why does my usb drive mount read only mode


I use to be able to mount a usb and stick and copy over files to it. Now when I plug it in it mounts as read only and I cannot change it. I did not change anything on the system.

I have su access and really nothing is new on this laptop.

Any thoughts one what i can look at?

I need to write data to usb all the time.
I rebooted too. same issues.

Thanx
 
Old 11-29-2010, 02:31 PM   #2
reed9
Member
 
Registered: Jan 2009
Location: Boston, MA
Distribution: Arch Linux
Posts: 653

Rep: Reputation: 141Reputation: 141
Plug in the offending usb stick and post the output of
Code:
dmesg | tail
Unmount the device and run
Code:
dosfsck -a -v /dev/sda1
Replace /dev/sda1 with the appropriate entry for your drive. Post the output of
Code:
sudo fdisk -l
if you need help finding out the /dev entry for the usb stick.
 
Old 11-29-2010, 02:32 PM   #3
JoshyJ
Member
 
Registered: Nov 2003
Location: Sydney , Australia
Distribution: Fedora
Posts: 49

Rep: Reputation: 1
What file system type is your usb key?
 
Old 11-30-2010, 11:06 AM   #4
unix1adm
Member
 
Registered: Oct 2008
Posts: 624

Original Poster
Rep: Reputation: 30
thank you for the ideas. ill try that. I dont have the usb stick with me but when I get back to it Ill try those commands.

It was formatted as a fat32 and I have put data on this USB in Linux before.

I will try another device I have and see if that works. May be it is specific to this usb?
 
Old 11-27-2013, 03:39 AM   #5
nyk.mat
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Rep: Reputation: Disabled
Hi unix1adm,

I am facing the same problem, I tried to mount the usb on my board, but it mounted in read-only mode. lot of our usb went in read-only mode.
So did you get the way through this problem? If yes, then please help me through this.

Thanks in advance.
 
Old 11-29-2013, 02:39 AM   #6
redfox2807
Member
 
Registered: Jul 2012
Distribution: Kubuntu, Debian, Meego, Android
Posts: 116

Rep: Reputation: 16
Please post the output of
Code:
mount
command when the USB drive is mounted here. It can be done as a regular user.
 
Old 11-29-2013, 03:23 AM   #7
s.verma
Member
 
Registered: Oct 2013
Distribution: Gentoo, Arch, Debian
Posts: 133
Blog Entries: 2

Rep: Reputation: 21
Dear unix1adm,

try to use between the quotes:
"pmount /dev/sdx1" //where sdx1 is your pen drive.
if it says pmount command not found, then try to first install pmount package from your repository.

Also if problem not solved, then try to give your distro name and GUI (GNOME or KDE whatever you use).
 
Old 11-29-2013, 09:37 AM   #8
flshope
Member
 
Registered: Jul 2009
Location: Murfreesboro TN
Distribution: Ubuntu 12.04 LTS
Posts: 42
Blog Entries: 15

Rep: Reputation: 15
I had a similar problem some time ago with a USB flash drive on an new computer. I discovered that I had to reset the owner using the chown command to make me the new owner.
 
Old 11-29-2013, 11:57 PM   #9
nyk.mat
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Rep: Reputation: Disabled
Thanks redfox2807,

When i run mount command, it successfully mounted the usb with returning zero.
But USB is mounted in READ_ONLY mode.(I cant write/delete anything).
 
Old 11-29-2013, 11:58 PM   #10
nyk.mat
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Rep: Reputation: Disabled
Unhappy

yeah flshope, I already tried that but couln't help..
 
Old 11-30-2013, 03:35 PM   #11
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,169

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
Originally Posted by nyk.mat View Post
yeah flshope, I already tried that but couln't help..
This is a very interesting thread.

I thought, as did flshope, that chown would be the answer.

My sticks mount fat32 partitions on sticks as owned by user. So I attempted to change that ownership to root.
Code:
root@jessie:~# chown -R root:root /media/tom/WIN
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010352.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010353.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010358.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010360.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010362.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010363.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010369.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010370.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010371.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010372.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat/P1010373.JPG’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN/Fat’: Operation not permitted
chown: changing ownership of ‘/media/tom/WIN’: Operation not permitted
note that in that attempt I was operating as "true" root rather than the "root" you get with the simple su command;
Code:
root@jessie:~# chown -R root:root /media/tom/WIN
Which returned the same not permitted results.

VERY interesting.

So the only thing I can suggest is that you either run, as root;
Code:
apt-cache search fat32
or run the search for fat32 in Synaptic.

Check to see which of the results are installed. I am not at all sure what Ubuntu is offering or if the package names are exactly what Debian uses so I will not confuse the issue by listing what I get.

I have all of them installed though. This may make the difference.

This is, of coarse, a rather sloppy shotgun attempt at a solution. You might want to install the packages you do not already have installed one at a time and see if they cure it that way. Would be much more instructional and save installing unneeded packages. I have them all installed for system data recovery purposes and feel I need all those packages.

As those procedures are done as root the permissions are not a problem, I just need the functionality of the packages.

As a side note, having one small partition on a 32 gig stick formatted to fat32 doesn't help if I try to share a file with someone running a Windows system. Thing can't find a partition readable by Windows. This is in spite of the fact, or perhaps because of the fact that the first partition is a Live Session which will boot on the same Windows box. Beats me but Windows is just appears to be less flexible than I was giving it credit for.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Usb flash drive error: Unable to read mount point hewjr1000 Linux - Newbie 4 11-18-2010 05:59 PM
Fedora will only mount my USB drive as read-only santiagosilva Linux - Hardware 6 02-17-2010 03:51 PM
How to mount NTFS in read/write mode in SuSE Enterprise 11 kushanxp Linux - Enterprise 1 12-17-2009 03:56 AM
Cannot mount a USB drive as read/write. icheyne MEPIS 2 06-28-2005 01:48 AM
Can't mount NTFS in read-write mode Tyco Linux - Hardware 4 06-08-2003 11:52 AM


All times are GMT -5. The time now is 08:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration