-   Ubuntu (
-   -   web browsers crash (

whitshade 09-02-2010 08:41 PM

web browsers crash
I'm using Ubuntu 10.04 and after a recent software update, I found that my web browsers crash constantly. Firefox stays open for a few seconds and then dies and won't restart. Google Chrome keeps giving me the "Aw, Snap!" screen. Seamonkey and Epiphany run for a while and then crash. After some research, I uninstalled Flash, but that didn't change anything. On a possibly related note, I've been informed of disk errors during boot and prompted to fix them twice in the same two week period. Any comments or suggestions would be appreciated. Thanks.

ultimate_linux 09-02-2010 08:46 PM

firefox -safe-mode.

whitshade 09-02-2010 09:00 PM

Thanks for the response, ultimate linux. That was just what I needed to get Firefox up so I can attempt to determine the cause of the crashes and to make sure the backups of my bookmarks are up-to-date. When I deduce the cause, I'll post it here. Thanks again.

tommcd 09-02-2010 09:24 PM

You could also try starting Firefox with a new profile:

firefox -P
This will serve to rule out a bad profile. It will also rule out your Firefox addons as a possible source of the problem.

whitshade 09-03-2010 03:12 PM

Thanks for the reply, tommcd. I gave it a shot and it seemed to work at first but then crashed. I guess it's back to plug-in hunting.

tommcd 09-03-2010 08:40 PM

It certainly seems odd that all web browsers would crash on you.
Perhaps try running firefox (with or without a new profile) or epiphany from the terminal. When they crash they will (hopefully) report some error message that may point to a solution for the problem.
I would leave flash uninstalled until you get to the bottom of this.
Is it just certain web sites that cause the browsers to crash? Or is it more random, and happening on any web site?

whitshade 09-04-2010 08:14 AM

I first noticed the prblem on facebook, playing mafia wars. Now the problem seems to be universal. Right now, I am running Firefox in safe mode, waiting for it to crash, so I can post the error message. Yesterday, I was looking at the plug-ins page and decided to print it out. The print window opened, but both it and firefox crashed when I clicked Print. The system as a whole has been running a little choppy lately and has run fsck at boot three times in the past two weeks. Thanks again for the input, tommcd. I will be in touch.

whitshade 09-04-2010 08:32 AM

Okay. Firefox crashed. Here's the message xterm gave me:

GLib-ERROR /build/buildd/glib2.0-2.241/glib/gmem.c: 176: failed to allocate 8 bytes



What do you think?

whitshade 09-04-2010 08:32 AM

Thunderbird also just crashed. I'll try the same thing.

whitshade 09-04-2010 09:00 AM

Thunderbird just crashed. The cause was a segmentation fault.

whitshade 09-04-2010 09:03 AM

Update: Nautilus keeps crashing after a certain period of time. When launched from the terminal, no error message is provided.

whitshade 09-04-2010 09:07 AM

I installed a RAM upgrade last week. Could this have something to do with the crashes?

tommcd 09-04-2010 04:55 PM


Originally Posted by whitshade (Post 4087902)
The system as a whole has been running a little choppy lately and has run fsck at boot three times in the past two weeks. ...

I installed a RAM upgrade last week. Could this have something to do with the crashes?

So all web browsers crash, and thunderbird and nautilus also crash. The system also has been running "choppy" and it needed to fsck the drive 3 times in 2 weeks.
This is obviously more than just a web browser problem.
I suppose if the memory is bad it could be corrupting data. That may explain what is going on.
Boot up the Ubuntu live CD and run memtest. Let memtest run for at least a few hours and see if it reports errors.

whitshade 09-04-2010 05:21 PM

I ran memtest, but stopped it during the eighth round of tests as no errors were detected. This was obviously premature. I'll run memtest until it finishes and see what the results are. Thanks.

whitshade 09-05-2010 07:10 AM

I ran memtest for 2+ hours last night and the new RAM module came up clean. I booted the PC using an Ubuntu 10.04 CD and ran sudo e2fsck -p on the Linux native partition and that came up clean as well. My guess is that some of the libraries and possibly other system files have become corrupted. I'm verifying that my back-ups are current and then I'll go with a fresh install. Thanks again to both of you for your assistance.

All times are GMT -5. The time now is 01:26 PM.