-   Ubuntu (
-   -   volume resets to mute on restart (

sumeet inani 09-09-2009 06:36 AM

volume resets to mute on restart
Hi,I am using updated ubuntu 8.04.I just unselected mute from panel then rebooted to find mute.What can be the problem?

kbp 09-09-2009 08:58 AM

I've had issues before with alsa being disabled by default, I had to run 'alsactl init' to make the sound card behave


RaptorX 09-09-2009 09:02 AM

actually what you should try is to

1. unmute
2. go out of alsamixer (if thats what you are using)
3. type alsaclt store in the command line

That should save your settings and next boot everything is going to be as you left it (including the volume that you set)

sumeet inani 09-11-2009 08:02 AM

To RaptorX,
can you clarify after unmuting do I have to right click on volume applet
(1)change from preferences
(2)choose volume control & change device from file menu
because alsa mixer is present in both.

RaptorX 09-11-2009 01:26 PM

I am sorry actually I thought you were using the command line.

In there you type alsamixer. Thats what i use for volume control in general.

You can try to unmute in the GUI. Then open the command line and type alsaclt store, check if that works.

sumeet inani 09-16-2009 04:15 AM

To raptorX,
Did not work any other suggestion?

RaptorX 09-17-2009 12:37 AM

not sure, the thing is that when alsa mixer does not "remember" the last state of the card you can manually use the "alsactl store" command to save it. Make sure you are running that command as root.

Now comes the question, do you have more than 1 card? or do you have a sound card integrated on the motherboard besides your card? because in that case you will have to specify "alsactl store -c0" or "alsactl store -c1"... I would do both just in case.

also take a look at this thread, maybe there is the answer:

All times are GMT -5. The time now is 05:14 PM.