LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   /usr/bin/ld: cannot find -lGLU (https://www.linuxquestions.org/questions/ubuntu-63/usr-bin-ld-cannot-find-lglu-823068/)

jayantak 07-30-2010 11:34 AM

/usr/bin/ld: cannot find -lGLU
 
Hello,
I am a new user on Ubuntu. Can anyone help me on the following problem?
Thanks a lot in advance.
-Jayanta
**************************************************************************
make[1]: Entering directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/common'
make[1]: Leaving directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/common'
make[1]: Entering directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/common'
make[1]: Leaving directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/common'
make[1]: Entering directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/common'
make[1]: Leaving directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/common'
make[1]: Entering directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/shared'
make[1]: Leaving directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/shared'
make -C src/SobelFilter/
make[1]: Entering directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/src/SobelFilter'
/usr/bin/ld: cannot find -lGLU
collect2: ld returned 1 exit status
make[1]: *** [../../bin/linux/release/SobelFilter] Error 1
make[1]: Leaving directory `/home/jayanta/NVIDIA_GPU_Computing_SDK/C/src/SobelFilter'
make: *** [src/SobelFilter/Makefile.ph_build] Error 2

knudfl 07-30-2010 01:44 PM

Welcome to LQ. .. .. :)

sudo apt-get install libglu1-mesa-dev

.. will provide 'lGLU', which means 'libGLU.so'.
..

Nguyen Thanh Cong 08-13-2014 11:23 AM

Quote:

Originally Posted by knudfl (Post 4050329)
Welcome to LQ. .. .. :)

sudo apt-get install libglu1-mesa-dev

.. will provide 'lGLU', which means 'libGLU.so'.
..

I did sudo apt-get install libglu1-mesa-dev
but I get:
libglu1-mesa-dev : Depends: libglu1-mesa (= 8.0.4-0ubuntu0.7) but 9.0.0-0ubuntu1~precise1 is to be installed

so what can I do to solve?
Thank you,

knudfl 08-14-2014 01:37 AM

# 3 .
Quote:

I did sudo apt-get install libglu1-mesa-dev
The right command is :

$ sudo apt-get update && sudo apt-get install libglu1-mesa-dev


All times are GMT -5. The time now is 06:23 AM.