-   Ubuntu (
-   -   Using creative player in amarok and mtpfs (

sourceopener 08-06-2009 11:34 AM

Using creative player in amarok and mtpfs
I am using ubuntu hardy (8.04)and have a creative zen player. I read in some website that a package called "mtpfs" would mount the player as a file system. i installed that but it isnt working. Moreover the player syncs with "gnomad2" but not with amarok. Inform me about using it in Amarok and mtpfs

scott_audio 08-07-2009 08:31 PM

i'd make sure you have the latest version of libusb, at least 0.1.12, anything before that is unreliable for what you're doing.

check to see if libmtp can see your device:


if that spits out your device info, then amarok should be able to see it

for mine, i created a directory /media/zen


mtpfs -o allow_other /media/zen
I got mine to work, but it was always buggy, so i gave up and bought an Archos, but maybe that will help you in some way hopefully

good luck

scott_audio 08-07-2009 08:37 PM

i also found this from

Speaks of MTP permissions, etc., that you might find helpful

scott_audio 08-07-2009 09:05 PM

other LQ posts

might also help

sourceopener 08-18-2009 09:10 AM

thanks scottaudio! I was able to mount it with mtpfs. but still not working in amarok need more help on this

scott_audio 08-18-2009 11:16 PM

Hopefully someone can step in and give you better help - I don't know enough to offer any more assistance. I could never get my zen to sync consistently with amarok - was buggy at best. The only way I could get my files to my zen was to rsync them (or direct cp) as root. I could not get the allow_other option to consistently work with mtpfs... and the only way I could get it to work 'sometimes' was with libmtp7 and libusb 0.1.12, zero success with any other versions of those two packages. It's a shame, too, because the zen is awesome. I hope you can find a solution, sorry I wasn't able to help more.

All times are GMT -5. The time now is 05:57 PM.