LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 06-17-2018, 06:57 AM   #1
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,194

Rep: Reputation: 50
Urxvt transparency not working in Ubuntu 18.04 on HP G50 laptop


Greetings, LQ. Since upgrading from 16.04LTS to 18.04 I am having a strange issue with transparency with Urxvt. The same problem occurred in Mrxvt and aterm, but those two are now removed. I plan to add mrxvt again after solving this problem.

I am using the 18.04 with Gnome and both gnome terminal and Eterm have transparency/shading working properly. When I open Urxvt with transparency the shading value has an unusual effect. When shading is 100 the background is transparent with no shading effect. When <100 the background is solid gray, and when >100 it is solid white. I also have Fluxbox on this laptop and the same thing happens there.

The computer is a HP G50 series laptop with Intel 4500M graphics Rev.07, using the i915 driver according to lspci -v. I also have a HP mini 110 series laptop running Xubuntu. After upgrading to 18.04 the mini does not have the same problem.
 
Old 06-17-2018, 09:01 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 8,745
Blog Entries: 5

Rep: Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141
urxvt can use both real and fake transparency.
i never use it, but it might have something to do with what you're experiencing.
i'm sure gnome is using real transparency, so maybe try to eradicate all fake transparency URxvt settings.
 
1 members found this post helpful.
Old 06-17-2018, 05:40 PM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,194

Original Poster
Rep: Reputation: 50
Thanks, ondoho. The tip about Gnome using real transparency pointed me in the right direction. I found that my .Xresources included settings for both real and fake. According to the man page, when both settings exist the fake is used. As you suggested, I removed the fake transparency settings and problem solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Fedora 24 on Lenovo G50-80 Laptop dipanjan Linux - Laptop and Netbook 3 07-07-2016 04:18 PM
Lenovo G50 Laptop microphone not working under Ubuntu 14.04.2 LTS wbernd Ubuntu 2 07-29-2015 02:39 PM
Fedora 22 wifi unavailable Lenovo G50 laptop wbernd Fedora 7 07-26-2015 11:29 AM
Transparency not working with urxvt arpanetguru Slackware 23 02-04-2011 05:14 AM
URXVT transparency and refreshing. Josh000 Linux - Software 0 04-29-2010 06:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 07:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration