-   Ubuntu (
-   -   Upgrading to Ubuntu 10.04 and computer broke (

dpeterson3 05-03-2010 10:16 PM

Upgrading to Ubuntu 10.04 and computer broke
Hello all. I was upgrading our lab's dhcp server to Lucid and it totally died. I have it running on a Debian recovery cd right now. I ran into a bug in gtk which I seem to have fixed, but now I have more serious errors. If I boot without a CD, I get dumped into a busybox shell after the machine fails to boot. From the live CD, I tried dist-upgrading again and it dies trying to build and install rsyslog with a broken pipe error. I am at a loss as to what to do from here short of reinstalling (which is the last option as this server has a lot of custom configs on it)

thanks for the help in advance

Mr-Bisquit 05-03-2010 10:41 PM

Then mount the server and copy the files to some other media or mail them as a gzipped or bzipped2 tar package to a local account on another server.
You can then reinstall and import the files.
The computer isn't broken. If it was, then you wouldn't be running a live cd on it. The installation is botched.

dpeterson3 05-04-2010 07:57 AM

I know the computer itself is working just fine. I need help fixing the botched upgrade. The person who set the server up left and none of us left know how he did it, so which we don't even know which config files need to be saved. I know dpkg complains about a broken pipe during the installation of rsyslog and the machine wants to make virtual box modules, and I didn't think we had virtual box installed. It wants the kernel source, so I might give it the source and see if it is happier. I will post actual error messages when I can get back to the machine this afternoon.

Mr-Bisquit 05-04-2010 09:03 AM

You save all of them. Do this.
Vbox can be disabled. You can go ahead and let it build and then remove it.

Have you mounted the volumes and searched through them for vbox?

I suggest also that you go to the ubuntu forums- the official one- and post the messages there in the server section.
You should also post the messages to the mailing list which deal with ubuntu servers. Join it first.
This way, you will be able to get more help and a lot quicker.

dpeterson3 05-05-2010 06:40 PM

After playing for a while on the Debian rescue cd, I got the package situation under control. I removed the Virtualbox packages, got rsyslog to install properly and ubuntu-minimal installed correctly. As far as I can tell, the OS itseld is just fine. Everything is there and installed correctly. However, the system will still not boot. I get an error message

Mount: Mount /dev/sda1 on /root failed: No such device
at which point I am dumped into a busybox shell. I have been googling for hours and coming up with nothing. I tried running fsck and reconfiguring initrd, and still nothing. I have no idea what could be wrong at this point.

PS. 1 oddity, init's config file has raid devices listed, which doesn't make sense since this machine has only 1 hdd. However, I didn't set it up so there could have been a raid at some point. Also, I know LVM2 is being used.

javaunixsolaris 06-02-2010 07:03 PM

I have a similar problem, I also can't boot from the hard drive (Post Here). What my question is how do you manipulate the packages on a hard drive from which you didn't boot?

jag2000 06-10-2010 08:35 PM

im sure you can boot with ubuntu live Desktop and browse and save your config files to a usb flash drive that are most likely your dhcp pool. your static ip settings and whatever else its doing.

All times are GMT -5. The time now is 12:20 PM.