-   Ubuntu (
-   -   Upgrading KDE, now have broken packages (

jaygee02 06-11-2007 07:41 PM

Upgrading KDE, now have broken packages
Tried to do an apt-get install kde earlier, on way to upgrading from 6.10 to Feisty 7.04, but Juk couldn't install because it needed a version of libgstreamer different to what I have, but it won't let me update it. Apt-get -f install gives me this:

dpkg: regarding .../libgstreamer0.10-0_0.10.12-0ubuntu2_amd64.deb containing libgstreamer0.10-0:
libgstreamer0.10-0 breaks libgstreamer-plugins-base0.10-0 (<< 0.10.11cvs20070110-0ubuntu5)
libgstreamer-plugins-base0.10-0 (version 0.10.10-1ubuntu1) is installed.
dpkg: error processing /var/cache/apt/archives/libgstreamer0.10-0_0.10.12-0ubuntu2_amd64.deb (--unpack):
installing libgstreamer0.10-0 would break libgstreamer-plugins-base0.10-0, and
deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

How do I fix this? I can't uninstall juk without removing kde-multimedia and if I try to do that it wants to remove kde.

jaygee02 06-11-2007 07:50 PM

Um scratch that, for some reason installing it in synaptic seemed to fix everything... why couldn't apt-get do that?

All times are GMT -5. The time now is 03:51 PM.