LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 10-17-2006, 09:22 PM   #1
dfwcomputer
Member
 
Registered: Mar 2006
Posts: 47

Rep: Reputation: 15
Updated To Edgy | Gnome won't start


hi all,

i recently upgraded my ubuntu dapper machine to edgy and when it boots it comes up with "Failed to start graphical environment" you can then display the error log which says;

P^[^E^HU.UTF-8

does this mean anything to anyone?

any help greatly appreciated
 
Old 10-17-2006, 09:54 PM   #2
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
Did you have the ubuntu-desktop package installed? It's necessary for dist-upgrade's.
Did you have any binary drivers for video cards? Maybe XGL/Beryl?
 
Old 10-17-2006, 10:12 PM   #3
dfwcomputer
Member
 
Registered: Mar 2006
Posts: 47

Original Poster
Rep: Reputation: 15
yes ubuntu-desktop was installed and i have been searching and have found the problem i think.There seems to be an issue with the new version of libc6.So i have reverted my sources.list back to dapper and am trying

sudo aptitude install libc6=2.3.6-0ubuntu20

i'll see how that goes.

form what i have found it seems to break the locale some how.
 
Old 10-17-2006, 11:21 PM   #4
dfwcomputer
Member
 
Registered: Mar 2006
Posts: 47

Original Poster
Rep: Reputation: 15
This is the error i got after the upgrade;

Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en",
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package mktemp.
(Reading database ... 72676 files and directories currently installed.)
Unpacking mktemp (from .../archives/mktemp_1.5-2_i386.deb) ...
Replacing files in old package debianutils ...
Setting up mktemp (1.5-2) ...
(Reading database ... 72680 files and directories currently installed.)
Preparing to replace debianutils 2.15.2 (using .../debianutils_2.16.1_i386.deb) ...
Unpacking replacement debianutils ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en",
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Setting up debianutils (2.16.1) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en",
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
I found this problem on the ubuntu forum.Some people have had success using one of the following,

Quote:
Fix 1

Try re-adding the dapper lines to your sources.list, and then after an aptitude update, do

sudo aptitude install libc6=2.3.6-0ubuntu20

worked for me!

And some learning: in order to find the version above, try

apt-cache policy libc6

EDIT:

Alternatively, try

sudo aptitude install libc6/dapper

Of course, after doing any of the above, you should not do an aptitude upgrade, because then you'll get back the newer packages.

To stop that, try

sudo aptitude hold libc6

That will keep the current version of libc6, while upgrading everything else when you do aptitude upgrade. Some packages will depend on the newer libc6, and so will refuse to upgrade. To cancel the hold, just do

sudo aptitude install libc6.

Quote:
Fix 2

unset LC_ALL LANGUAGE LANG
Quote:
Fix 3

sudo dpkg-reconfigure locales
And here is the link to the forum thread for further reference
http://www.ubuntuforums.org/showthread.php?t=196703
 
Old 10-20-2006, 07:38 AM   #5
alek66
Member
 
Registered: Apr 2004
Location: Argentina
Distribution: netBSD/Linux
Posts: 256

Rep: Reputation: 30
Quote:
Originally Posted by Redeye2
Did you have the ubuntu-desktop package installed? It's necessary for dist-upgrade's.
Did you have any binary drivers for video cards? Maybe XGL/Beryl?
That thing happended to me, I tried to install beryl on dapper, after some packets missing, I upgraded to edgy, and then nothing ever worked.
 
Old 10-20-2006, 10:49 AM   #6
Redeye2
Member
 
Registered: Feb 2004
Posts: 489

Rep: Reputation: Disabled
The problem with Beryl/Compiz and XGL/AIGLX from different repos, is that they overwrite sometimes critical files and it's pretty much impossible to downgrade them all. Once Ubuntu gets native accelerated effects (7.04), it'll be a lot easier. Just enable it through some configuration and that's it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome login problem in ubuntu edgy eft ivangetov Linux - Software 6 06-12-2007 03:28 PM
I updated, now kde won't start Ian18 Linux - Newbie 15 01-23-2006 12:59 PM
updated Kernel via Redhat's up2date; now X won't start Daninchina Linux - Newbie 9 02-01-2005 12:52 AM
updated kernel with up2date and now gnome is gone ampersand Linux - General 6 12-20-2004 08:53 PM
updated kde now can't start x h00ligan Linux - Software 6 03-09-2004 08:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration