LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 11-11-2020, 11:29 AM   #1
williepabon
Member
 
Registered: May 2007
Location: Florida, USA
Distribution: Ubuntu
Posts: 96

Rep: Reputation: 0
Exclamation Unable to get grub menu to show


Hi!:

Recently upgraded from Ubuntu 18.04 to 20.04. Everything has been working OK except that I'm not able to make the grub menu to appear. I've tried hitting ESC, SHIFT keys when booting without success. Is there now a new way in Ubuntu 20.04 to make the grub menu to show? Following, the information about my system:

Code:
williepabon@williepabon-Macmini:~$ uname -a
Linux williepabon-Macmini 5.4.0-52-generic #57-Ubuntu SMP Thu Oct 15 10:57:00 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
williepabon@williepabon-Macmini:~$
williepabon@williepabon-Macmini:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal
Thanks for the help.
 
Old 11-11-2020, 03:45 PM   #2
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,218
Blog Entries: 3

Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Question

So computer starts but doesn't show the main grub screen to select likely Ubuntu and/or rescue mode? Instead just boots straight to your operating system?

From a terminal you could try:
Code:
sudo update-grub
then reboot.

Otherwise checking your /etc directories for all the proper grub settings?
 
Old 11-11-2020, 04:00 PM   #3
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 5,216

Rep: Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992
post the contents of /etc/default/grub
 
Old 11-11-2020, 10:00 PM   #4
williepabon
Member
 
Registered: May 2007
Location: Florida, USA
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 0
colorpurple21859:

Thanks for answering. Following, the information requested:

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Hope it helps.
 
Old 11-12-2020, 12:47 AM   #5
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,218
Blog Entries: 3

Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
What happened when you ran update-grub?

Add: I don't have a box to play with, for testing but I know your settings like GRUB_TIMEOUT=0 can be set in seconds to say 15, (e.g.:)
Code:
sudo vi /etc/default/grub
then update-grub but quiet splash may have something to say there lol

Example https://ostechnix.com/configure-grub...-ubuntu-16-04/

Last edited by jamison20000e; 11-12-2020 at 06:13 PM. Reason: Forgot su
 
Old 11-12-2020, 04:32 AM   #6
kareempharmacist
Member
 
Registered: Jan 2012
Location: Cairo, Egypt
Distribution: MX Linux
Posts: 317

Rep: Reputation: 39
it is much easier to use nano instead of vi to edit /etc/default/grub
Code:
sudo nano /etc/default/grub
 
Old 11-12-2020, 06:14 AM   #7
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 5,216

Rep: Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992
set
Code:
GRUB_TIMEOUT=
to 5, that is more than enough to see menu before it boots. Then run
Code:
sudo update-grub

Last edited by colorpurple21859; 11-12-2020 at 06:20 AM.
 
Old 11-12-2020, 07:13 PM   #8
williepabon
Member
 
Registered: May 2007
Location: Florida, USA
Distribution: Ubuntu
Posts: 96

Original Poster
Rep: Reputation: 0
colorpurple21859:

Quote:
set
Code:

GRUB_TIMEOUT=

to 5, that is more than enough to see menu before it boots. Then run
Code:

sudo update-grub
I've tried your suggestion above, but still the menu doesn't show. Still looking for other possibilities to try. Thanks.
 
Old 11-12-2020, 08:19 PM   #9
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,218
Blog Entries: 3

Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
My grub default config only shows quiet not quiet splash
 
Old 11-12-2020, 08:28 PM   #10
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,218
Blog Entries: 3

Rep: Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393Reputation: 1393
Add: but, also didn't dive into that link I gave or
Code:
man grub
or do I have: GRUB_TIMEOUT_STYLE=menu, &c...

Last edited by jamison20000e; 11-12-2020 at 08:30 PM. Reason: Missed an escape
 
Old 11-12-2020, 09:19 PM   #11
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 5,216

Rep: Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992Reputation: 992
change this
Code:
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
to this
Code:
GRUB_DEFAULT=0
#GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
and this
Code:
#GRUB_GFXMODE=640x480
to this
Code:
GRUB_GFXMODE=1024x768

Code:
sudo update-grub

Last edited by colorpurple21859; 11-12-2020 at 09:37 PM.
 
1 members found this post helpful.
Old 01-28-2021, 07:39 AM   #12
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu
Posts: 131
Blog Entries: 1

Rep: Reputation: 19
F9 did it for me

after install a few months ago(20.04) i had a similar issue, Ubuntu on the same drive as Windows,i hit F9 repeatedly at startup, and bingo ,i had the choice to boot to sata-1, grub appeared and voilą, i am not sure if this is related to your problem, i am not an expert, but if it could help.
 
Old 02-02-2021, 09:30 AM   #13
vmelkon
Member
 
Registered: Feb 2007
Location: Canada
Distribution: Kubuntu 20.10
Posts: 297

Rep: Reputation: 44
Quote:
Originally Posted by nutronix View Post
after install a few months ago(20.04) i had a similar issue, Ubuntu on the same drive as Windows,i hit F9 repeatedly at startup, and bingo ,i had the choice to boot to sata-1, grub appeared and voilą, i am not sure if this is related to your problem, i am not an expert, but if it could help.
That's the way I prefer it. In my case, it is F11. It depends on the BIOS.
I have Windows and Linux on separate HDD.
To install Linux, I disconnect the Windows HDD and plug in only the Linux HDD and I install Linux onto it.
Once finished, I shutdown, I plug both HDDs.
I just don't want Linux touching the Windows HDD MBR.

~~~~vmelkon
 
  


Reply

Tags
grub 2, ubuntu 20.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] installed second hard drive - can't get grub menu to show both. littlejoe5 Linux - Laptop and Netbook 6 11-24-2018 01:44 PM
Infinite Grub Loop: GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB... beeblequix MEPIS 2 11-02-2013 11:56 PM
[SOLVED] problem creating KDE menu items that actually show up in the menu SharpyWarpy Linux - Desktop 3 07-03-2012 09:28 PM
GRUB2 - FreeBSD-8.0 does not show up in triple boot menu, dual boot menu it does.. wiliweld *BSD 7 05-03-2010 02:05 PM
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc. dissolved soul Ubuntu 2 01-13-2007 01:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 05:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration