-   Ubuntu (
-   -   UEFI & windows 8 (

business_kid 12-10-2012 02:57 PM

UEFI & windows 8
Does Ubuntu support booting under secure boot? I'm reading conflicting things. Anyone going dusl booting with windows 8?

I have this new laptop w/windows 8, I can't get a bootloader running and have to boot with an install cd.

The computer and my nerves would be much better without windows 8. It is dreadful - unimaginably bad. I've seen m$ shoot themselves in the foot before, but not in the pillocks. I have a 17.3" screen and it thinks it's on a mobile phone. The only worse thing I have met is grub2 in it's various incarnations.

I'd be very happy to go "Legacy OS" and forget windows 8 altogether but nobody can show me how that's done. I've compiled grub2 from source twice, and tried the SuSE package. The Fedora package is honest enough to say "grub2 doesn't work; use grub-efi-0.97" and _that_ can't do stuff and complains that nothing looks as it should be. The best I got from grub2 was a similar complaint. The laptop is a Samsung-350V with AMI bios.

custangro 12-10-2012 03:06 PM

Are you opposed to turning off UEFI all together?

business_kid 12-11-2012 03:30 AM

No. uefi secure mode can go. I'm not reformatting atm, though. Who in their right mind would ever want to use windows 8? If I badly need windows, I have vista64 on another box, and that will surely do. I never thought I'd hear myself praising vista, but beside windows 8 it's wonderful. Beside linux, it's pure <expletive deleted>

I read somewhere that
1. ubuntu-12.10 handles UEFI Secure Boot
2. That BIOS prevent the use of chainloaders like grub altogether
3. Everyone's working on it, which makes me shudder.
4. I have read gigabytes on grub2 which would be properly titled "What you don't want to know about grub2." I learned nothing that I wanted to know.

The nearest I can go to turning off is a "secure boot & Legacy OS" option. Slackware uses lilo, and there is elilo, but I haven't investigated that yet. This week perhaps. My experience with grub2 is that it's 356 scripts which call scripts and rely on files that don't exist. My sda is formatted gpt and set up

sda1 - some small hidden data patrtition
sda2 - efi boot partition
sda3 - M$ reserved and otherwise unreadable
sda4 - drive C
sda5,6 - Manufacturer crap

I have shrunk sda4 and have space on disk for linux.
I can boot slackware by leaving an install dvd in the cdrom, which comes up with a "boot:" prompt. I then type
huge.s root=/dev/sda8 ro rdinit=ro
and I'm in. But that's a pain in the proverbial. And it means I have to burn a cd or dvd to change the kernel.

arubin 12-12-2012 04:45 AM

You might try and see if you can create a USB UEFI boot stick as described here.

This involves
formatting a USB stick with GPT so that it has a FAT32 partition type code EF00
create folders /EFI/BOOT/
download elilo-3.14-all.tar.gz, extract elilo-3.14-x86_64.efi and put it in EFI/BOOT/ as ./EFI/BOOT/BOOTX64.EFI

creating elilo.conf - see the page above for details but you might need




if you get that working you might see if it is possible to put this in your efi partition on the hard drive.


arubin 12-12-2012 04:48 AM

You might also look at the rEFInd boot manager but to get that booting slackware directly you will need to upgrade yhe kernel and recompile it with the efi-stub enabled.

tommcd 12-12-2012 04:48 AM

Disabling secure boot can be difficult from what I have read. Check out Jesse Smith's experience with a new computer that has secure boot:

According to the Ubuntu 12.10 release notes, only a few flavors of Ubuntu 12.10 support secure boot:

Due to time pressures, only some flavors released with 12.10 will install and boot on Secure Boot hardware:
Ubuntu desktop
Ubuntu server
We expect to enable all other flavors in 13.04.
More info on that here:

TobiSGD 12-12-2012 05:46 AM

Please post the exact maker/model (or a link to the manufacturer's site for that machine), I really would like to have a look on that.

business_kid 12-13-2012 03:53 AM

The model is a Samsung 350V.Link to laptop spec

Nothing is documented for this box, and that's what's slowing me down. I have collected some tools

Those packages are from rpms on suse's site. I'm going to rearrange slightly & install one big uefi_stuff package.
There's stuff you have to dump in /boot/efi. There's some UEFI index you have to add an entry to. Then if your BIOS writers were kind to you, there'll be a bootloader menu. If not, I dunno. Elilo only loads linux/unix. Apparently a lot can get stuck in as the .efi stuff if you're clever about it and your bios are OK. But the UEFI spec keeps changing and changing and what have I? i don't know. I'll stick those packages in and try following the docs in elilo, using slackware. I'm not hearing positive enough noises about ubuntu to make the switch.

The hugely irritating thing is that there is facility for a legacy os, but the world is silent on how to do that on a gpt disk. At this stage I really don't care about windows 8, but this is a warning to LXers not to buy laptops with windows 8 pre-installed.

After kernel 3.3, the kernel can masquerade as an efi application (done by adding junk in it's own rather roomy header) :-D. There's 3 boot options with secure boot disabled, & "Secure boot & legacy OS"set: Secure boot, cdrom & hard disk, apparently the BIOS/MBR option.

@arubin: I've already built kernel 3.6.10 at this stage with the secure boot thing enabled, and I can't use the usb boot because the @#$%! box doesn't support usb boot. But it has a hostname (RoseViolet) and I'm typing this from it under linux. I have the slackware dvd in the cdrom and I just type a line, and boot off that kernel for the moment.

@tommcd: Thanks for the distrowatch link and the update on Ubuntu. I developed a strong allergy to apt-* and found myself disliking and distrusting all 'update every night' distros like Fedora. I have posted here with bugs which were sorted by a fedora update which produced different errors but worked.

business_kid 12-13-2012 11:07 AM

Marking this one solved. It's not solved, but I'm taking it up on the hardware forum, as that's a better place for it. Thanks to All who contributed and made my task easier.

All times are GMT -5. The time now is 02:39 AM.