LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 06-06-2008, 02:42 PM   #1
djgizmo
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Rep: Reputation: 0
Ubuntu Server Gui error


Yes, I am a newb of linux, but used to use Solaris 7/8 back in 2000 for a little bit before career path took me completely away from that realm.

Issue: When type the command
Code:
startx
I receive an
Code:
error X: cannot stat /etc/X11/X (No such file or directory), aborting. ...Unable to connect to X Server.
I 'thought' I installed GNOME and GDM. I have started gdm, as if I try to start it again I receive the Warning GDM already running.

Any suggestions?

PS. I have tried google as well as the forum search feature and found nothing to assist me with this that I could tell.

Thanks!
 
Old 06-06-2008, 09:52 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
I had trouble getting X to work under Ubuntu Server 8.04 which is to say that I never got it to work. I installed Ubuntu Desktop 8.04 with no problems. You can add any software to the desktop edition that is on the server edition. I'd say install the desktop edition and save yourself some frustration.
 
Old 06-07-2008, 08:16 AM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Try
Code:
sudo aptitude update
sudo aptitude install xserver-xorg
After that try running "startx".
 
Old 06-11-2008, 11:37 AM   #4
djgizmo
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Tried that, did not work. It asked me to Apt-get install xinit, which I did, but then when I tried to startx, the gui started to load and gave in error stating I did not an xsession file in my home folder or something.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GUI for Ubuntu Server? cucolin@ Ubuntu 71 08-16-2013 09:23 PM
Error message when attempting to install GUI for Ubuntu Server 7.04 calebf Linux - Server 5 04-26-2009 12:23 AM
How to install GUI on Ubuntu server? Mountain Linux - Server 11 07-08-2008 10:52 PM
Can one switch GUI on/off in Ubuntu Server 6.06? (Want to learn Server, but...) Sandokan Ubuntu 3 08-16-2007 01:27 AM
can't start GUI on ubuntu 7.04 server uwa45 Ubuntu 7 08-01-2007 12:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration