-   Ubuntu (
-   -   Ubuntu install issues (

dsdonut 10-18-2012 12:52 PM

Ubuntu install issues
I'm pretty new to using Ubuntu. I'm much more experienced with RHEL/CentOS.

I'm trying to install Ubuntu server on some Dell M600 blades and I'm running into a couple of issues.

1. During boot, I lose video. This happens right after the grub menu. As soon as the grub menu goes away, the screen goes black. Once or twice I was able to get the video to stay just by hitting some keys while the grub menu was displayed. For some reason, I can't do that anymore.

2. The boot process hangs. The couple of times that I was able to see the screen, it stopped and said something about Busybox... enter help for a list of commands (something to that effect.) The prompt was (initramfs). At this point, if I type 'exit' and hit enter, it will finish booting and I'll get to the login screen.

Issue 2 is compounded by issue 1. I can't see what all is on the screen. In fact, I just have to guesstimate as to when it gets to the Busybox prompt (since I can't see anything on the screen.) At the blank screen, if I type 'exit' and hit enter, it will get me to the login.

I've tried booting to the live cd and running boot-repair. That didn't make any difference.

For issue 1, I've tried adding 'nomodeset' to grub, but that didn't fix the issue. It ended up just lowering the resolution once I got to the login screen.

It seems as if boot hangs at or around when it tries to mount the hard drives. These blades have RAID controllers, but I do not have any RAID set up. The installer sees both drives just fine. I've tried installing to either drive, same result. I've tried unmounting the / partition and running fsck. That came back with "fsck.ext4 unable to resolve UUID:<long uuid string>" Is that likely the issue? I'm not sure how to resolve that. I've tried editing grub to not pass the UUID to linux, but that had no effect.

Any other ideas?

edit: I've installed Ubuntu on other hardware and on virtual machines without this issue. I think it must be a hardware compatibility/driver issue.

otoomet 10-20-2012 01:44 AM

It sounds like a problem with kernel-bios-hardware not being really able to talk together. I would perhaps try different kernels and eventually some boot options, or replace disks.

I have a little similar issue with my primary computer (i5 + GMA graphics, and two AMD graphics cards). Initially it did not find one graphics card. Later, at boot it often refused to find the primary harddisk. I replaced the harddisk and that issue went away. X still often refuses to start at boot (as I boot about once a month, it is not a big issue). I run ubuntu, and get the kernel upgrades quite often, and my impression is that the stability depends on the kernel version with the newer ones in general working better.

All times are GMT -5. The time now is 07:37 PM.