LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 05-16-2009, 06:39 AM   #16
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15

i did #touch /forcefsck and rebooted. didn't seem to take very long.

i looked through the output of dmesg, found nothing that looked like a problem. I include a link to it below anyway

dmesg output

as of this moment, my system is running smartctl -t long -a -d ata /dev/sda.

i will post again when i get the results from that.

thanks
 
Old 05-16-2009, 11:58 AM   #17
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I just looked at the dmesg output you posted. The only problem/concern I noticed was
Code:
[    6.605101] acx: Loaded combined PCI/USB driver, firmware_ver=default
[    6.605168] acx: compiled to use 32bit I/O access. I/O timing issues might occur, such as non-working firmware upload. Report them
[    6.605660] ACPI: PCI Interrupt Link [APC1] enabled at IRQ 16
[    6.605725] acx_pci 0000:01:05.0: PCI INT A -> Link[APC1] -> GSI 16 (level, low) -> IRQ 16
[    6.605801] acx_pci 0000:01:05.0: setting latency timer to 64
[    6.605910] acx: found ACX100-based wireless network card at 0000:01:05.0, irq:16, phymem1:0xFD8FF000, phymem2:0xFD8E0000, mem1:0xf7c88000, mem1_size:4096, mem2:0xf7d00000, mem2_size:65536
[    6.606983] acx: loading firmware for acx100 chipset with radio ID 11
[    6.607047] acx_pci 0000:01:05.0: firmware: requesting acx/default/tiacx100c11
...
[    7.191078] acx: firmware image 'acx/default/tiacx100c11' was not provided. Check your hotplug scripts
[    7.191158] acx_pci 0000:01:05.0: firmware: requesting acx/default/tiacx100
...
[    7.561085] acx: loading radio image for radio 11
[    7.572029] acx_pci 0000:01:05.0: firmware: requesting acx/default/tiacx100r11
...
[    8.233022] acx: === chipset TNETW1100A, radio type 0x11 (RFMD), form factor 0x00 (unspecified), EEPROM version 0x04: uploaded firmware 'Rev 1.9.8.b' ===
[    8.233862] acx v0.3.36: net device wlan0, driver compiled against wireless extensions 22 and Linux 2.6.28-11-generic
...
[   16.524017] wlan0: changing radio power level to 18 dBm (41)
[   16.668213] ADDRCONF(NETDEV_UP): wlan0: link is not ready
...
[  190.272615] wlan0: auth FAILED: peer sent response code 1 (Unspecified failure), still waiting for authentication
All that suggests is that your WiFi driver was compiled for a 32-bit system, and you're running a 64-bit OS which (as the first line said) can cause timing problems.

Of course, if you're using your wireless connection, timing problems may be the source of your "hang."

By the way, from that dmesg output, it looks like you're running Ubuntu 9.04 on a AMD x86_64 system with a wired Ethernet port and a wireless connection. If you're using a local wireless router, try connecting to the router with a Ethernet cable, turn off the wireless connection, and see if the "hangs" stop. If that happens, see if you can recompile the wireless driver as a 64-bit driver (or find it in a x86_64 version in the repositories).
 
Old 05-16-2009, 03:07 PM   #18
tur third
Member
 
Registered: Jun 2005
Location: Surrey, UK
Distribution: Ubuntu 10.04, 10.10
Posts: 187

Rep: Reputation: 24
Not good news from me either. The change I suggested seems to have helped me, but I still have a problem.
 
Old 05-16-2009, 04:49 PM   #19
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
Ah yes. the wireless. i had meant to remove that before installing the software on the box. i've removed it now though. checked dmesg for that, and there is no longer any mention of it.

I've run also the smartctl -t long -a -d ata /dev/sda
after running this it said check back in 72 minutes for results, so i left it for about 3 hours before checking back. it appeared frozen at that time, and so after about 10 minutes i did a hard reset. after booting the output of smartctl -a -d ata /dev/sda is below.

Code:
smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Model Family:     Western Digital Raptor family
Device Model:     WDC WD1500ADFD-00NLR1
Serial Number:    WD-WMAP41112990
Firmware Version: 20.07P20
User Capacity:    150,039,945,216 bytes
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   7
ATA Standard is:  ATA/ATAPI-7 published, ANSI INCITS 397-2005
Local Time is:    Sat May 16 21:44:51 2009 BST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x82)	Offline data collection activity
					was completed without error.
					Auto Offline Data Collection: Enabled.
Self-test execution status:      ( 249)	Self-test routine in progress...
					90% of test remaining.
Total time to complete Offline 
data collection: 		 (4783) seconds.
Offline data collection
capabilities: 			 (0x7b) SMART execute Offline immediate.
					Auto Offline data collection on/off support.
					Suspend Offline collection upon new
					command.
					Offline surface scan supported.
					Self-test supported.
					Conveyance Self-test supported.
					Selective Self-test supported.
SMART capabilities:            (0x0003)	Saves SMART data before entering
					power-saving mode.
					Supports SMART auto save timer.
Error logging capability:        (0x01)	Error logging supported.
					General Purpose Logging supported.
Short self-test routine 
recommended polling time: 	 (   2) minutes.
Extended self-test routine
recommended polling time: 	 (  72) minutes.
Conveyance self-test routine
recommended polling time: 	 (   5) minutes.
SCT capabilities: 	       (0x103f)	SCT Status supported.
					SCT Feature Control supported.
					SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   200   200   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0007   170   159   021    Pre-fail  Always       -       4508
  4 Start_Stop_Count        0x0032   099   099   040    Old_age   Always       -       1643
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000a   200   200   051    Old_age   Always       -       0
  9 Power_On_Hours          0x0032   093   093   000    Old_age   Always       -       5386
 10 Spin_Retry_Count        0x0012   100   100   051    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0012   100   100   051    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       1551
194 Temperature_Celsius     0x0022   125   107   000    Old_age   Always       -       22
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0012   200   200   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0012   200   200   000    Old_age   Always       -       0
199 UDMA_CRC_Error_Count    0x000a   200   253   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x0008   200   200   051    Old_age   Offline      -       0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]


SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

I'm not sure how to interpret these results exactly, though i can guess at some. also i don't think the self test that i started has actually changed anything.
 
Old 05-16-2009, 04:59 PM   #20
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
is it likely to be an issue with the disk, or with some other hardware in the system?
 
Old 05-16-2009, 05:09 PM   #21
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Hey, coal-fire-ice: I just realized you weren't the OP for this thread, and actually read the post you made when you hi-jacked it. From that post, where the "hang" is on a headless ssh processor, my first thought would be that you've left the default "power-management" settings enabled, and that the "hang" is the system waiting for someone to unlock a (non-existent) locked screen.

Have you checked the power management settings?
 
Old 05-16-2009, 06:42 PM   #22
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
Yea. i figured i had a similar problem.

How do you find the power-management settings?
and surely i shouldn't have to log in/unlock the system before it will broadcast http on apache, or allow incoming ssh connections.
at least thats what i would have thought.

Thanks for all the help so far by the way.
 
Old 05-17-2009, 07:49 AM   #23
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
i set the system to beep every 5 minutes via cron so i could tell if it was still up.
since doing that its been up for quite some time (13 hours).
could it be that this beep has kept the system awake, when being logged in over ssh and actively typing commands doesn't?
or perhaps it was that the wireless card was causing all the problems.
i guess all i can do is wait and find out.
 
Old 05-17-2009, 08:28 AM   #24
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
To find the power management settings, open the "System Settings" menu item, clink on the "Advanced" tab, and the power management settings should be at the bottom, in the "System" section.
 
Old 05-17-2009, 08:37 AM   #25
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
ah.

the problem with that is that the xserver isn't running so there are no menus. and without a monitor (which i unfortunately do not have) i can't run the xserver.

do the power management settings still apply if xserver isn't running

and are there config files that i can modify?
 
Old 05-17-2009, 02:25 PM   #26
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Hum. Well, I'm not sure, but perhaps this file (/usr/share/PolicyKit/policy/org.freedesktop.hal.power-management.policy) might be a place to start.

I thought you could run a ssh connection to an X-server? (Hey, I mostly work from a laptop, and I've never even tried to make a ssh connection.)

Anyhow, I fairly sure I've seen posts about using X over ssh.
 
Old 05-17-2009, 02:36 PM   #27
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
this is true, but x over ssh doesn't require the xserver to be running on the machine itself, but on the one you view the machine from. and unfortunately setting up an xserver in windows is easier said than done. at least it was last time i looked into it. i'll have a look into the power management and see if anything looks like it needs a change
 
Old 05-17-2009, 02:44 PM   #28
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
I've looked at that file, it seems to be a definition of possible options, not a config file itself

i also looked at /etc/hal/fdi/policy...
which seemed to be a config file, but only contained options regarding removable drives.

tbh though, the machine hasn't frozen again since i booted it last (now over 20 hours), it seems to me that the problem may well have been the wireless card.

although thats an odd thing come to think about it. my system should have been fine with the standard 32bit drivers because it shouldn't be using the 64bit kernel as i installed the x86 version.
though it is true the processor is an amd64 something. odd

Last edited by coal-fire-ice; 05-17-2009 at 02:45 PM. Reason: detail wrong
 
Old 05-18-2009, 05:45 PM   #29
luiz 55
LQ Newbie
 
Registered: Dec 2008
Location: Brazil
Posts: 18

Original Poster
Rep: Reputation: 0
I'm sorry, I've been away this weekend, so I didn't look at the thread. I'm using wireless (USB adapter) as well. I'll try using my desktop without it to confirm if it's because of the driver. I didn't wait more than a few minutes to consider a "hang", but I guess it's not supposed to happen anyway. I also don't think it's related with the power management but I'm not sure.
 
Old 05-18-2009, 06:16 PM   #30
coal-fire-ice
Member
 
Registered: Nov 2004
Location: SE England
Distribution: Debian, SUSE, Ubuntu, Slackware
Posts: 147

Rep: Reputation: 15
my computer froze again.
could be what i was doing to it though.
it froze resampling photograph number three thousand and something of 4 and a half thousand.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
random udev hangs infinity42 Linux - Software 0 05-27-2005 04:24 PM
RHAS 2.1 hangs at random wongksp Red Hat 3 10-13-2004 06:40 AM
mandrake 10 install hangs at random michaeltweak Mandriva 3 08-14-2004 03:12 PM
Random hangs during bootup leecming Linux - Newbie 1 06-09-2004 10:28 AM
Random Hangs bdc79 Linux - General 3 05-24-2004 07:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 03:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration