-   Ubuntu (
-   -   Ubuntu 8.04 Realtek 8187 on Tishiba A215-S7414 (

LynDawg 07-01-2008 10:31 PM

Ubuntu 8.04 Realtek 8187 on Tishiba A215-S7414
I've posted a similar thread in Ubuntu forums and have gotten some advice, but so far, no good. Here's the scoop:
  • this is a dual boot with Vista
  • I am able to connect to the Internet with wire only on the Ubuntu side
  • Network manager gives me no option for wireless
  • iwconfig sez no wireless extensions for eth0 or l0
  • I found somewhere that the RTL8185 driver works, so I used the ndis GUI to create a driver - no luck

So, if anybody has any suggestions, please let me know. If you need output from the various *config commands, let me know. I would really like to be wrieless soon for Linux.

Thanks in advance,


markackerman8@gmail. 07-04-2008 07:36 PM

RTL 8187B USB Wireless problems Toshiba A210, helppp Please!
I am a total newbie and trying to get away from MS, Yeah!!!!

I tried to install it with something called ndiswrapper,and a windows XP driver for Linux, with no success.

It is recognized in the hardware as a USB device, so at least that's a start.

Is there anywhere an explanation of very basic step by step instructions to help me in this critical phase,


JeanBrownHarrel 07-04-2008 11:11 PM

Here is how to fix this problem...
go to this website and follow the instructions there.

You have to extract it and then using a command line as root, change to the directory and use the command "chmod a+rwx" with the file name, one by one, to make all the files executable. Then you go to type "./makedrv" and it will compile all the drivers for you. Then you type "./wlan0up" and hit enter and the interface will be recognized by the system as a real wireless card. I go into the System<Administration menu and click on the Network menu item and I click on unlock and type in the root password or administrative password and then I highlight the wireless connection menu item, and then click on properties, and then click on network name and using the drop-down menu, I select the network/router name as the ESSID name and then I go down to connection settings and click on configuration using the drop-down menu, I select automatic configuration (DHCP) and then I click OK and then I uncheck and recheck the box next to wireless connection and a small box will appear saying changing the interface configuration. Keep checking with your web browser for an internet connection by typing a web address in the address bar such as and seeing if a web site comes up. If it does then you are online. If not, then between checking and rechecking the box next to the highlighted wireless connection menu item, type "./wlan0dhcp" in the terminal as root and see if it gets an IP address for your computer. If it does then it is connected to the wireless router. Between all this it should work. If you reboot all you have to do is open a root terminal and type the command to change to the directory where the wireless driver was compiled and type the command "./wlan0up" and hit enter and your wireless internet connection should be up and running and you should be able to surf the internet, as it is already configured. If you go to another place such as a public library with wireless internet, then you repeat all the steps to connect to the internet. You will not have to recompile the drivers by typing "./makedrv" unless you install a newer kernel.

The MODIFIED wireless drivers come in 2 forms...the original modified one that works only with 2.6.22 kernels and a newer one by jadams which works with 2.6.24 kernels.

I am typing this on my Toshiba A215-7437 laptop with the Realtek 8187b wireless card which is right now working successfully, using the modified jadams/realtek driver with Ubuntu 8.04-i386 on my laptop as its only operating system. I could not stand Windoze Vista and removed it from my laptop as it is slow as molasses and had me tearing my hair out in frustation.

Hope this helps. I tried Ndiswrapper. It was a miserable failure and did not live up to the hype. I tried the Win 98 driver as well as all other Windoze drivers and it never worked and never even detected the Realtek wireless card at all. It said it did not exist. So much for that useless trash called "Ndiswrapper". Don't even bother with it as it is a useless, worthless program that never works.

markackerman8@gmail. 07-05-2008 06:43 PM

hello GBH,

thanks over time you must have spent making that post. Optimism once again!

my first question is this, he said to make all the files executable, is that all of these files, and did so in which order do I install them?

* Parent Directory
* 2.6.24.patch
* FAQ.html
* rtl8187b-modified-dist.tar.gz
* rtl8187b-modified-jadams-2-1-2008.tar.gz
* rtl8187b-unmodified-realtek.tar.gz

I will try the modified-dist.GZ file first, and then the .patch file, here I go again, and thanks in advance!!


JeanBrownHarrel 07-05-2008 07:13 PM

Thank you...
First, determine what kernel you have by typing "uname -a" in a terminal window, either normal or root terminal, and then you will decide which modified driver you will use.

The original modified driver by Johnny Cuervo is for 2.6.22 kernels only and will not work with any kernels greater than 2.6.22...such as 2.6.24. The modified driver by jadams will work with 2.6.24 kernels...I know this for a fact as I am typing this on my laptop which is running on a 2.6.24 Ubuntu kernel, the 32-bit one.

First, you download the modified driver, and then you extract it. Then you enter the directory where it was extracted to and check the list of files and using the command line or the file manager Nautilus, you change the files to allow them to be executable. If you don't, and you then type "./makedrv" in a root terminal while you are in the directory where they are located, it will say "Permission denied".

Anyway, you then wait for the command "./makedrv" to finish and then you start doing the rest of what I mentioned. Namely, typing "./wlan0up" and then using the Network menu item under the System<Administration menu. Eventually it will work.

When "./makedrv" is running...when it finishes, look for any final error messages such as "Error 1" or Error 2. If you see any of that at the end of its compiling then it means the compiling failed for some reason.

Otherwise you will see warnings about missing pointers or something about something incompatible but don't worry. As long as you don't see the error messages about "Error 1" or "Error 2" you are ok.

Anymore questions, let me know.

The original Realtek driver for Linux does not compile for some reason. Don't know why. Use only the modified drivers or maybe even the patch. I don't know about the patch. I used the original modified driver or the jadams modified driver successfully. I must try the patch someday.

JeanBrownHarrel 07-05-2008 07:22 PM

Thank you...
Double-posted because my high-speed internet got real slow and didn't want to post this as my connection was barely functioning due to my internet service provider.

Hope all this helps. It works fine for me.

BobNutfield 07-06-2008 04:21 PM

I found that the drivers from the post above did not work well for me and others have reports difficulties when upgrading a kernel. For me, the best solution was ndiswrapper with the Win98 windows drivers. It was very easy to set up and there is only one minor modification to the driver necessary to get it working. Also, there is a neat little GUI for loading the driver available for Ubuntu via Synaptic. If you are interested in this solution, I will post the directions and links to the solutions.


BobNutfield 07-06-2008 04:24 PM


Originally Posted by markackerman8@gmail. (Post 3204435)
I am a total newbie and trying to get away from MS, Yeah!!!!

I tried to install it with something called ndiswrapper,and a windows XP driver for Linux, with no success.

It is recognized in the hardware as a USB device, so at least that's a start.

Is there anywhere an explanation of very basic step by step instructions to help me in this critical phase,


As mentioned in my post above you must first make a simple modification to the Win98 driver. If you post back the results of:


i will be able to tell you whether this solution will work for you.


JeanBrownHarrel 07-06-2008 06:33 PM

All I can tell you...
is that the MODIFIED realtek drivers work and the windoze drivers don't work and neither does that accursed, worthless, good-for-nothing Ndiswrapper.

I have tried Ndiswrapper several times and never could get it working.

I gave up on it and trashed it and tried the modified realtek drivers which, for me, work FLAWLESSLY!!!

I am typing this on my Toshiba A215-7437 laptop with Ubuntu 8.04-i386 with a 2.6.24 kernel with the jadams modified realtek driver and it works flawlessly.

Ndiswrapper does not work...plain and simple and the modified drivers DO work. This is ALL that I know.

BobNutfield 07-06-2008 06:57 PM

Well, all I can say is that I am glad that it worked for you....that's the main goal: to get it working.

I have a Toshiba A210 with the Realtek 8187B usb chipset, and those drivers only partially worked for me. While it did connect, the signal strength was so low that I had to be within 20 feet of the router to get any kind of usable connection. I installed ndiswrapper, and with information found from googling, I installed the Win98 driver, modified it by adding one additional line to the .inf file, and it works beautifully. I also put a script in rc.d local so that it would be up and connected as soon as I booted up. I also have Slackware 12.1 installed as a second distro on this laptop and this method worked just as flawlessly for Slack as it did for Ubuntu. I have helped quite a number of others get this chipset working with this method.

As I understand it, there is a prototype driver being tested for an upcoming kernel release (do not know when) so I am sure that sometime in the near future there will be a native driver for Realtek 8187b.


JeanBrownHarrel 07-06-2008 07:07 PM

I tried Ndiswrapper and...
added the one line to the Windoze 98 driver and installed the Windoze 98 driver and it still did NOT work and did NOT even detect the Realtek 8187b wireless card. Ndiswrapper said that it did NOT exist. I tried several other Windoze drivers with the same result.

Ndiswrapper does NOT work at least NOT for me. I have sworn off that trashy, useless program and stuck to the modified realtek drivers which for sure, DO work.

I am using the jadams modified realtek driver with a 2.6.24 kernel under Ubuntu 8.04, the 32-bit version and the driver works flawlessly.

Other than having to manually start it when I boot up Linux, and the winmodem does not work and I will someday bypass it with a hardware modem, everything is working flawlessly.

Hope this helps.

LynDawg 07-07-2008 01:02 AM

Damage Control
I gave up on this Realtek, and bought a Belkin N Expresscard wireless. Using the NDIS GUI in Ubuntu, it saw the hardware, but I never can get anything wireless to show-up in my Network box. So this brings me to my big concern: in my attempts to follow advice from the forums on RTL8187b and manually setting things up thru terminal commands, have I hosed things up real good?

I'm no Linux Guru, just a Winders dude trying to set myself free from the Windows Borg, using the hardware I have. I'm probably taking the Belkin back to Best Buy tomorrow since no one has answered any of my posts about getting IT to work. Frustrated in Indiana...

Thanks in advance,


markackerman8@gmail. 07-07-2008 01:22 AM

OK Jean,

Man my frustration is mounting, grrrrrr

I hope you r online
as I am i week old in linux, please respond to my questions as such, I am in MORAN state,

first I think I should remove my first driver that isn't functional as far as being recognized by "Network", BUT I GET
"couldn't delete /etc/ndiswrapper/net8187b: Inappropriate ioctl for device", Do I need to get rid of this first if so HOWWW??

Secondly, w.r.t. "one by one, to make all the files executable"

Do I make all the 6 "shell script" files executable in the "/home/ack/Desktop/rtl8187b-modified-jadams-2-1-2008.tar/rtl8187b-modified" dolder??? only

as well as, any "shell script" in the 3 subfolders?
as well as any "makefiles" files in the 3 subfolders?

and what and how do I do anything with the .patch file?

and to make things worse ubuntu isnt extracting any subfolder files in this jadams folder though it does in the other modified, what kind of glitch is this? arghhhh

back at it, and thanks in advance,

JeanBrownHarrel 07-07-2008 01:59 AM

First, extract the tar.gz or tar.bz2 file...
by highlighting it with your mouse curser and then right-clicking on it and selecting "extract here" and left-click it so it will extract it in the home directory.

Then you double-click on the directory/folder and it will show the contents in the window and then you highlight all the files, not the directories/folders in it, and right-click them and click on properties and then go to the one that says permissions and check the one that says the file(s) can be executable until you see a checkmark in the box next to the item at the bottom that says "allow executing file as program" and then close the properties box.

Then open up a ROOT terminal and type "cd rtl8187b-modified" and hit enter.

Then you type "ls" to get a listing of the files in the directory/folder. Then you type "./makedrv" and hit enter and watch the compiling start.

Wait until you see it has stopped and you have a command line again as, for example:


This is what my command line looks like above here.

Then you type "./wlan0up" and hit enter. Then you follow all the instructions in my previous posting. I use a network monitor applet on my top panel. I right-clicked on it and selected properties and then erased "lo" which is the loopback interface, and I typed "wlan0" in place of "lo" and then I clicked on close to close it and it will show the applet with a red square on it before you type "./wlan0up" and hit enter. After you type "./wlan0up" and hit enter, then it will show its normal self with another symbol next to it like some kind of signal-strength measurement or something.

You have to type the commands in the directory where the files are.

The original modified-driver by Johnny Cuervo works with a 2.6.22 kernel and the jadams-modified driver works with a 2.6.24 kernel. I don't know if it works also with a 2.6.25 or a 2.6.26 kernel. I have never tried.

Hope all this helps.

As for ndiswrapper, if necessary, re-install Ubuntu Linux from scratch to get a clean re-install and you will not have to worry about anything from ndiswrapper and you can start from scratch with these modified drivers.

Hope all this helps.

JeanBrownHarrel 07-07-2008 02:16 AM

quote "as well as, any "shell script" in the 3 subfolders?
as well as any "makefiles" files in the 3 subfolders?

and what and how do I do anything with the .patch file?

and to make things worse ubuntu isnt extracting any subfolder files in this jadams folder though it does in the other modified, what kind of glitch is this? arghhhh"

Only make the files in the main directory executable and don't worry about any subdirectories/subfolders. As long as you use a root terminal, "makedrv" will take care of the rest of things. Just make sure that the following files are changed to be executable...either with a command line in the root terminal or by using the file manager to highlight and click on them with your mouse...

"makedrv release_note wlan0down ifcfg-wlan0 README.FIRST wlan0rmv
install ReadMe.txt wlan0dhcp wlan0up"

These are the files I make executable so they can be executed in a root terminal. The ones called "release_note" and "README.FIRST" and "ReadMe.txt" are probably not needed to be executable, so you can experiment with them to see what happens.

You don't need to make anything in the 3 subdirectories executable. Don't worry about them.

As for the .patch file...I would guess that it was intended for the original modified driver before the jadams modified driver came out or else it was intended to be used with the original modified driver or with the jadams modified driver if the jadams modified driver gave any problems. I will have to check it out.

Also, I noticed that if I extracted the original modified driver and then the jadams modified driver, that the jadams modified driver was extracted to the same directory/folder as the original modified driver. So I just deleted the directory/folder where they were extracted to and started over. Extract one or the other but not both unless you put one of them in a different directory/folder such as "/usr/src/" or long as they are in different directories you can separately extract them and compile both of them separately and try them out to see what happens.

Hope this helps.

The MODIFIED realtek drivers really do work and I could never get the ndiswrapper program to work with the windoze drivers so I gave up on ndiswrapper and trashed it and went with the modified realtek drivers. The original realtek drivers from realtek do not compile for some godawful reason and I don't know what that is. I just know that the original unmodified realtek driver(s) do not work nor do they compile. Maybe you can figure it out. Anyway, the programmers who modified the original realtek driver from realtek managed to get it working or else I am not typing this on this website and I am just hallucinating.

Hope this helps.

Jean Brown Harrell

All times are GMT -5. The time now is 12:11 PM.