-   Ubuntu (
-   -   Ubuntu 8.03a3 New Install: GRUB Error 21 after new dual-HDD, dual-boot install (

tvdxer 01-29-2008 12:36 AM

Ubuntu 8.03a3 New Install: GRUB Error 21 after new dual-HDD, dual-boot install
I recently picked up an old Western Digital 80 GB EIDE hard drive, as my 60 GB was running out, and there was definitely no room left to play with Linux and other operating systems. I installed the drive as a slave on my first EIDE cable with success, Windows and my BIOS both recognize it (though Partition Magic doesn't), as did the Ubuntu installer when I set up the Linux partition.

Then I went to install Ubuntu - a success until I rebooted and this dreaded message came up:

GRUB Loading Stage1.5

GRUB loading, please wait...
Error 21

This happens each time I reboot.

FWIW, this is how the drives are partitioned, according to the "alternate installer"'s partition manager:

SCSI1 (0,0,0) (sda) - 60.0 GB ST360021A

#1 primary 30.4 GB B K ntfs /media/sda1
#2 logical 12.6 GB K fat32 /media/sda5
#6 logical 14.2 GB K fat32 /media/sda6
pri/log 2.9 GB FREE SPACE

SCSI2 (0,1,0) (sdb) - 80.0 GB ATA WD800B-00JH

#2 primary 22.0 GB B K ext3 /media/sdb2
#6 logical 1.2 GB F swap swap
logical 35.8 GB FREE SPACE
#5 logical 21.0 GB K fat32 /media/sdb5


Before the second installation I set the mount point of /sdb2 to / (root). This is where the Ubuntu files are.

The free space is for other OSes. I want to install QNX, Solaris, and at least one other distro.

sdb5 was created in Windows and was intentionally placed at the end of the drive.


(For some reason it treats the ATA drives as though they were SCSI)

This is really obnoxious, so if anybody could help it would be greatly appreciated.

Also, let me say I tried re-installing it, making sure /dev/sdb1 (the ext3 partition to which I installed Ubuntu) had the mount point set to /, with the same problem. Also, now that I remember, the GRUB setup showed only Win XP when it listed the OS's on my drives. I must have figured it would assume Ubuntu does not need to be listed or something.

Thanks for any help. I have Knoppix and PuppyOS (which I'm typing on on my sister's laptop, which itself has a corrupt NTFS filesystem).

EDIT: Forgot that I installed over System Commander. But I still need help!

tvdxer 01-29-2008 01:08 PM

Problem solved by changing the master drive to "User" and "LBA" and the slave to "Auto" in the BIOS.

All times are GMT -5. The time now is 11:49 AM.