LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 10-31-2020, 01:10 PM   #1
Yankee26
LQ Newbie
 
Registered: Apr 2010
Posts: 1

Rep: Reputation: 0
Ubuntu 20.04 LTS How to install HP Deskjet 3633 using hplip-3.20.9.run


I am running hplip-3.20.9.run i Terminal and it requests adding dependencies. It tries to add the dependencies but ends up stating to manually add them. Is there a way to automatically add them in one command?

I run "sh hplip-3.20.9.run"
It tries to automatically install
.....
INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))
warning: Missing REQUIRED dependency: python-dbus (Python DBus - Python bindings for DBus)
warning: Missing REQUIRED dependency: libavahi-dev (libavahi-dev)
.....

Thanks for your help,
Bob
 
Old 11-01-2020, 12:26 AM   #2
berndbausch
LQ Addict
 
Registered: Nov 2013
Location: Tokyo
Distribution: A few
Posts: 6,117

Rep: Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900Reputation: 1900
Quote:
Originally Posted by Yankee26 View Post
I am running hplip-3.20.9.run i Terminal and it requests adding dependencies. It tries to add the dependencies but ends up stating to manually add them. Is there a way to automatically add them in one command?
To add them automatically, add this line to the run script:
Code:
apt install -y pyqt5 python-dbus libavahi-dev
I have not checked if these packages exist for Ubuntu 20, except for python-dbus.

Of course, you could also execute that command manually prior to installing the printer software.

I don't know why the script fails to perform that installation. Are you executing it as root? You need to be root to install software. Or are your Ubuntu repos configured correctly? Or does that computer have internet access?

Last edited by berndbausch; 11-01-2020 at 12:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu 18.04.5 LTS Released with Linux Kernel 5.4 LTS from Ubuntu 20.04 LTS LXer Syndicated Linux News 0 08-14-2020 09:28 AM
[SOLVED] Upgrade hplip-3.9.4b to hplip-3.9.12 (32-bit and 64-bit) tronayne Slackware 8 02-28-2011 12:12 AM
[SOLVED] hplip on ubuntu 9.10 for hp deskjet F2480 Series lefu Linux - Newbie 5 05-21-2010 04:08 AM
hplip / HP Deskjet D4160 install help soylentgreen Slackware 7 05-27-2007 07:31 PM
HP Deskjet 5550 (usb) - HPLIP can't run in Debian sarge ch_music Linux - Hardware 4 02-12-2005 09:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 11:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration