-   Ubuntu (
-   -   ubuntu 12.04 crashing (

gjhxyz 11-01-2012 05:29 AM

ubuntu 12.04 crashing
I installed 12.04 21 October and it worked after a fashion in particular problems with evolution. I got round this by installing thunderbird. After installing updates for a couple of days the system freezes afterbooting. I was having a space problem which I fixed. The problem now is that the system will boot but I cannot get any program to work. I get the normal screen but cannot do anything but shut down using the off switch on the portable. When I go in using the advances option at boot I am told I can use the system with limited graphics... the yes no questions freeze the system before I bring up ubuntu. What I can do is get into the system using commands but I am at a loss to know what commands I could use to make sure the system does not crash after boot. Any suggestions would be welome because I am already fed up having to reort to W7....
thankk you

otoomet 11-01-2012 06:23 AM

So updates broke your system?

Do you have any idea what was updated? It sounds a bit like kernel/graphics conflict.

Have you tried to boot with a previous kernel?

gjhxyz 11-02-2012 03:56 AM

Yes, have tried all options and on the prereleases but basically they all seem to react with the same messages with the same final result result. Is there a way to get at the log file?

otoomet 11-02-2012 04:01 AM

So you cannot use the debug/failsafe modes either? If you cannot boot the computer with the current install, you should use a portable media (like a live/rescue distro), mount the disk, and then you can access the logs and all the stuff there.

As a side note -- your description of the problem is rather hard to understand. Please try to explain better what do you mean with "normal screen", why cannot you do anything but shut down the computer etc. Tell us also a bit about your hardware (in particular, graphics card).

Steve W 11-02-2012 05:30 AM

Just a heads-up, Mr "gjhxyz", that I appear to have a similar problem to you about Ubuntu 12.04 breaking after recent updates have run. I have started a thread as well on this forum describing my particular problem, but it may be in both our interests to monitor each others' threads, in case a suggestion made on one is useful to the other person.

Good luck - here's to getting our systems working again!

gjhxyz 11-02-2012 12:36 PM

My hadware is an HP G50-133US notebook PC
Intel graphics media accelerator with up to 1277MB total video memory.

What I mean by a normal screen is the system appears to boot normaly and I see the usual screen.
If I move the arrow around I can get a desciption of an icon. Once.

All functions other than one ICON description are frozen. Another thing I have noticed the screen before the final screen after password and enter the small round dotd thats used to appear to move do not appear to rotate.

I have been able to get into the raw black sudo-i sceen but do not know what to do next.
Hope this helps.

otoomet 11-02-2012 12:42 PM

How do you get into the "black sudo-i screen"? Boot in recovery mode?

If yes, do something like this:

# cd /var/log
# tail -20 Xorg.0.log

-- this should give the last messages of the X11 log file

# tail -20 syslog

-- this should give you system messages

# tail -20 kern.log

-- kernel messages.

Instead of "tail -20", you may use "more" to inspect the complete log file.

gjhxyz 11-03-2012 04:48 AM

ubuntu 12.10 crashing after upgrade from 12.04
Sorry if I misled anyone but the upgrade is to 12.10...

Doesn't change the problem I have tried to get at the logs but to no avail. The sytem replies no such file or diretory. I suspect this due to the access shows ~ # read only mode. The other problem is that in the menus where I am asked for example the question yes? or No? I cannot take the option that is not highlighted because the mouse or the arrows do not work. I have tried all of the actions proposed in the advanced section without sucess. If I have to access the files remotely can someone give an explicite way as to how to do it?

Steve W 11-03-2012 11:00 AM

Gjhxyz, see my post on your issue over at my thread.

With regard to your access while in the shell screen (the "DOS window"), if you do "ls" it will list the directories available at that point. What does it say?

Also with regard to those pesky Yes/No options that cannot be selected, try the tab key to move between them, and pressing Enter to select.

otoomet 11-03-2012 02:08 PM

gjhxyz, I still not quite understand what do you do. Are you in recovery (non-graphical) mode? Perhaps you can put here a few commands you enter, and the output of these? Even a photo of screen would do if you cannot copy-paste or get a screenshot.

What you told us about "no such file.." suggests the computer cannot mount the root file system.

gjhxyz 11-04-2012 12:55 PM

12-04 upgrade to 12.10
I think your analysis is spot on, after struggling to get some kind of information I eventually got the ls command to come back with Desktop as the only file loaded. All my attempts to get at my system files have failed. The hardware works perfectly with an image CD of 12.10 but I assume if I install it will rub out the current system? I can also run 12.10 as a guest but have not been able to persuade the system to let me open files.
any suggestions? Apppreciate the time you have spent on this.

Steve W 11-04-2012 01:13 PM

When I want to gain access to system files on a system that won't let me access them, I live boot in with Linux Mint 12 LXDE. This uses PCManFM as its file manager, and you can select an option "Open current folder as Root". This lets you open any folder on the system, and access the files within.

This will mean downloading Mint 12 LXDE and making up a live boot disc or USB stick for it, but its one way of getting access to those files without reinstalling, if you wanted to look at them and maybe change the settings in one or two.

gjhxyz 11-04-2012 04:01 PM

Thanks Steve I will try this tomorrow.
who say's I am a guy?

otoomet 11-05-2012 01:06 AM

gjhxyz, Steve W -- Mint 12 LXDE is simply the latest version of Mint? In fact, you can use all kind of recovery/live distros (including ubuntu 12.10). However, to use the "Open current folder as Root" function needs the disks to be mounted. I think the modern live distros find the existing disks/partitions and offer you to mount them. Not tried, however.

Steve W 11-05-2012 06:38 AM


Mint 12 LXDE is simply the latest version of Mint
No, Mint 13 is out now; Mint 12 is just the one that I've used. I've had mixed experiences using live CDs/USB sticks to get access to data on PCs. Knoppix 5.1.1, which I used to use some years ago, not only mounted all available devices on bootup, but also put an icon for each on the desktop.

Other live distros I have used don't seem to recognise or allow access to other directories on my system. I don't know whether this is because their "live" modes are meant to be just try-out modes for the distro, and you aren't meant to play around with other partitions with them. Ubuntu 12.04, for example, when running as a Live distro will not let me access my own /home partition on my PC, stating that I "do not have access". And I don't think, in live mode, it lets you log on as Root either. In contrast, Linux Mint 12, using PCManFM, does let you open a directory as Root, which seems simpler to me, and why I recommended it.

All times are GMT -5. The time now is 07:11 PM.