LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-22-2009, 07:25 PM   #1
L-user
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Rep: Reputation: 0
tried to change gdm now system is fscked.. need advice


had a leetle too much spare time at work this week and decided to try and change the butt-ugly login on ubuntu 9.10.

I followed the instructions here how-to-downgrade-gnome-display-manager-2-28-to-2-20-in-ubuntu-9-10

and neglected to do step 2, stopping gdm first.

Now, gdm fails and I can't even bring up a console. The monitor complains about an invalid mode (in what should be console mode!)

Hitting escape doesn't even stop grub from starting up whatever graphics is hosing this up. I do see text for a second before it goes black.

I can mount the root file system using the install disk but I'm not sure what to try.

It would be really lame to have to re-install. I would really love some advice on how to approach fixing this.
 
Old 12-22-2009, 07:40 PM   #2
Vinter
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Aptosid
Posts: 148

Rep: Reputation: 19
Just start the system with parameter "single" at the GRUB prompt. (Just pressing "down" when you see the GRUB message appear should stop it from auto-booting.) This should give you a root-only console where you can apt-get install gdm to upgrade it again. As for changing the apperance - both Ubuntu and GDM are "butt-ugly" to me, so I can't help you there

Otherwise, just get yourself a Damn Small Linux onto some ancient 64MB stick and edit your GRUB settings in /boot.

Last edited by Vinter; 12-22-2009 at 07:41 PM.
 
1 members found this post helpful.
Old 12-22-2009, 08:17 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,997

Rep: Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219
Just come up in "Recovery" mode. The ncurses menu you (now) get to offers a dpkg option to repair packages. Do your dirty work, then simply resume the boot.
Ensures you have network connectivety, which a lot of init scripts don't in single mode.
 
1 members found this post helpful.
Old 12-22-2009, 10:37 PM   #4
L-user
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
This 9.10 install disk doesn't seem to have a recovery mode option on it. Is there a secret to booting into it?

Why on earth would they remove that from the live disk?

I never actually see a grub menu when it boots. Do I just start hitting the "down arrow" button or something?

anything I can change in grub's menu.lst to make the menu come up? I'm not in front of that box at the moment but I'm wondering if maybe the "hiddenmenu" option is uncommented, making it boot right into oblivion automatically.
 
Old 12-22-2009, 10:49 PM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,997

Rep: Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219
Sorry - I thought you were booting the installed system. It may have hiddenmenu set - just hit <Esc> when the screen switches out of the POST messages. Should get you the grub menu.
 
Old 12-23-2009, 06:14 AM   #6
L-user
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Ok thank you for the suggestions and help guys. I'll give it a go this morning.
 
Old 12-24-2009, 03:25 PM   #7
L-user
LQ Newbie
 
Registered: Dec 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, in the highly unlikely event someone out there has the same combination of bad luck and stupidity as I do, this is what I had to do to get sorted out.

Since the system would not boot into graphic OR character mode, I had to boot the installation CD then choose the "try Ubuntu without changing stuff" option, then mounted my root device (in this case /dev/sda1) on /mnt/root. I kept getting some error "failed to load module i810", which seems to be related to X, not a kernel module. Even hitting escape (or shift) would not bring up the grub menu for some reason.

Then I manually edited /mnt/root/boot/grub/grub.cfg and appended the word "single" to the default boot option commandline, to force it to boot single user mode. The file warns dangerous consequences and potential alien invasion for manually editing the file, but it had to be done since update-grub won't work in that situation. (wtf, a simple config file like menu.lst wasn't convoluted enough??)

Once I booted into single user with networking, I uninstalled gdm, reinstalled gdm (2.28.. I'll deal with the butt ugly login with a working system), then had to dpkg-reconfigure xorg, because Xwindows was still boogered up. Took me about 5 reboots to figure this sequence out but finally got the system working again.

Its not easy being me..

Last edited by L-user; 12-24-2009 at 03:30 PM. Reason: had to remove random "duuuuh"s
 
Old 12-24-2009, 05:14 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,997

Rep: Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219Reputation: 2219
Thanks for the follow-up - good to see you kept a sense of humour.
My advice was based on grub, not grub2 which I refuse to use. Sorry about that. Will have to find a machine I don't care about so I can install it and get used to it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change gdm in fedora serendi Linux - Desktop 2 10-06-2008 05:49 AM
change KDM to GDM... nenyo Linux - Software 2 02-14-2005 12:53 AM
change X resolution to 91 dpi, system boots gdm justa_bassplayr Debian 5 12-07-2004 01:27 PM
how do u change the gdm bosewicht Arch 2 06-15-2004 08:53 PM
how to change gdm to kdm? NeoAnderson Linux - General 4 08-26-2002 08:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 07:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration