LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 05-06-2007, 06:27 AM   #1
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
system > preferences > sessions | startup programs not working since edgy


This has been an ongoing trial - in edgy I couldn't get adesklets to load except to the root window (which was then covered by the wallpaper) using the startup programs bit in the session manager.

Now, with feisty, I have entered beryl manager and emerald to the startup sessions and yet they do not start.
 
Old 05-20-2007, 03:39 AM   #2
Easilydistrac
LQ Newbie
 
Registered: May 2007
Distribution: Ubuntu Feisty Fawn
Posts: 4

Rep: Reputation: 0
I'm having the same problem, every time I add a program to the startup menu, it disappears the next time I open the session menu, and the program never starts when I boot up.

When I run Sessions in terminal and try to add a program (in this case Gaim) it gives me this:
Quote:
** (gnome-session-properties:6486): WARNING **: Could not save /home/easilydistrac/.config/autostart/gaim.desktop file
I must honestly say that I have no idea what to do.

Last edited by Easilydistrac; 05-20-2007 at 03:46 AM.
 
Old 05-20-2007, 04:04 AM   #3
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Original Poster
Rep: Reputation: 198Reputation: 198
Well, in my case the entry remains... I suspect there is a conflict with "remember settings" on logout but it is unconfirmed.
 
Old 05-20-2007, 10:14 PM   #4
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
I have a number of applications starting from Sessions including Gaim, Firestarter, Perl and Bash scripts. My ~/.config/autostart directory has some text files created by the Sessions GUI, including this one for Gaim. All were marked as executable.

[Desktop Entry]
Name=No name
Encoding=UTF-8
Version=1.0
Name[en_US]=Gaim
Exec=gaim
X-GNOME-Autostart-enabled=true
 
Old 05-21-2007, 12:08 AM   #5
Patrick K
Member
 
Registered: Apr 2007
Distribution: Feisty (Ubuntu Studio)/Edgy
Posts: 69

Rep: Reputation: 16
Have you tried listing the programs in /ect/rc.local? Programs listed there run at boot time.
 
Old 05-22-2007, 05:08 PM   #6
Easilydistrac
LQ Newbie
 
Registered: May 2007
Distribution: Ubuntu Feisty Fawn
Posts: 4

Rep: Reputation: 0
How should I list the commands in the rc.local file?
I tried simply using the boot commands, but it didn't work.
 
Old 05-22-2007, 05:35 PM   #7
Patrick K
Member
 
Registered: Apr 2007
Distribution: Feisty (Ubuntu Studio)/Edgy
Posts: 69

Rep: Reputation: 16
I'm not real clear but think you just give the command with any arguments. Make sure it is above the "Exit" line already there. AFAIK, rc.local is the last file run upon booting. I've not used it myself but did look into it when trying to troubleshoot another problem. You might try googling for more info.
 
Old 05-22-2007, 05:41 PM   #8
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Assuming you have single user systems, you're sure doing things the hard way. True /etc/rc.local is where to place system startup commands. rc.local is a bash shell file which will be called during boot. It has to exit properly as its called like a function. The file has some comments in it relating to its use. If you use the sessions GUI you won't have to worry about any of this. In that case the programs are started with X after the boot is complete. They are only started for that user and by this time the connection to the Internet is complete as required by some applications like firestarter. You don't have to worry about permissions for example. A copy of my rc.local follows. The bit I added is for starting bluetooth on my system.

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#Start Bluetooth for Palm E2
modprobe l2cap
modprobe rfcomm
mknod /dev/rfcomm0 c 216 0
sdptool add --channel=10 OPUSH
rfcomm bind /dev/rfcomm0 00:07:E0:6F:85E 10

exit 0
 
Old 05-23-2007, 05:33 AM   #9
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Original Poster
Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by Patrick K
Have you tried listing the programs in /ect/rc.local? Programs listed there run at boot time.
I don't want them to run at boot - I want them to run after login.
 
Old 05-23-2007, 02:58 PM   #10
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Quote:
Originally Posted by Simon Bridge
I don't want them to run at boot - I want them to run after login.
Ubuntu provides for what you want with System-> Preferences-> Sessions-> Startup Programs tab. You may add your startup applications here. This where I start firestarter, gaim and a Perl script for registering a dynamic DNS. With the new button you get a popup where you can enter a meaningful label and the command to start the application. For example the command I used to start firestarter was "sudo firestarter --start-hidden". In this case sudo will prompt with a password window during startup.
 
Old 05-24-2007, 03:59 PM   #11
Easilydistrac
LQ Newbie
 
Registered: May 2007
Distribution: Ubuntu Feisty Fawn
Posts: 4

Rep: Reputation: 0
Uh, fragos, both Simon and i are aware of the Sessions menu and the Startup Programs function. The problem is that these things aren't working properly.
 
Old 05-24-2007, 04:26 PM   #12
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Quote:
Originally Posted by Easilydistrac
Uh, fragos, both Simon and i are aware of the Sessions menu and the Startup Programs function. The problem is that these things aren't working properly.
All I can say is that they work correctly for me and others. My advice would be to remove all the changes you may have made to try and get this working and carefully start again.
 
Old 06-01-2007, 09:37 AM   #13
Doytch
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
I just registered because I had this same problem.

However, I also managed to fix it quite simply

I was getting the same error if I ran the session properties from terminal.

Code:
** (gnome-session-properties:9230): WARNING **: Could not save /home/mark/.config/autostart/beagled.desktop file
I figured it's probably a permissions problem, so I just loaded up a root session of Nautilus, allowed others to read & write, and create & delete files in /home/[username]/.config/autostart/

This fixed the problem, and changes in the Session Manager now stick instead of reverting.

 
Old 06-01-2007, 03:28 PM   #14
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
By default my system allowed me to make those changes. In your home directory the owner should have RW permissions. Although that could be "broken" from the command line.
 
Old 06-02-2007, 06:29 AM   #15
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Original Poster
Rep: Reputation: 198Reputation: 198
fragos: already tried changing everything back and redoing... no dice. Even had a chance to do a complete clean install and it still wouldn't stick. Note, in my case, the actual settings will keep displaying, just the process doesn't always start.
 
  


Reply

Tags
help


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing Sessions Startup programs from a different user account phrozenfearz Ubuntu 3 03-14-2007 07:16 PM
System Preferences Problems Neko_D Linux - Newbie 5 10-08-2006 02:12 AM
Autostart programs at system startup thort Linux - Newbie 5 02-13-2006 02:10 PM
Window manager preferences for remote vnc sessions? dkw Linux - Newbie 1 12-25-2004 08:47 PM
RedHat>Preferences>Session>Startup" --console equivalent? rohan208 Linux - Newbie 3 05-07-2004 10:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 04:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration