LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   system-config-kickstart not working in Ubuntu 14.04 (https://www.linuxquestions.org/questions/ubuntu-63/system-config-kickstart-not-working-in-ubuntu-14-04-a-4175502357/)

vikas027 04-20-2014 07:32 AM

system-config-kickstart not working in Ubuntu 14.04
 
Hello Everyone,

I am trying to run system-config-kickstart on a new Ubuntu 14.04 desktop x86_64 OS.

I ran the below commands (just after installing it) and tried to make it work in vain.

Code:

root@vikas:~# apt-get update
root@vikas:~# apt-get install system-config-kickstart
root@vikas:~# apt-get install libnomeui*
root@vikas:~# system-config-kickstart
Xlib:  extension "RANDR" missing on display "localhost:10.0".
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/system-config-kickstart.py", line 92, in <module>
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 131, in __init__
    self.X_class = xconfig.xconfig(xml, self.kickstartData)
  File "/usr/share/system-config-kickstart/xconfig.py", line 80, in __init__
    self.fill_driver_list()
  File "/usr/share/system-config-kickstart/xconfig.py", line 115, in fill_driver_list
    raise RuntimeError, (_("Could not read video driver database"))
RuntimeError: Could not read video driver database
root@vikas:~#

Please help me out. Once this is done, I will install it through my CentOS 6.4 kickstart server.

Regards.

vikas027 04-25-2014 11:10 AM

Hello Everyone,

So this is a bug as per below links
https://bugs.launchpad.net/ubuntu/+s...t/+bug/1236315
https://bugs.launchpad.net/ubuntu/+s...t/+bug/1260107

The below commands made my day.
Code:

# apt-get remove hwdata
# wget ftp://mirror.ovh.net/mirrors/ftp.debian.org/debian/pool/main/h/hwdata/hwdata_0.234-1_all.deb
# dpkg -i  hwdata_0.234-1_all.deb
# apt-get install system-config-kickstart


matukajos 05-13-2014 04:28 AM

Thanks, it works!
 
Hi,
Just registered here to say thanks a lot! This has helped me make kickstart work and I'm sure a lote more poeple too.

itnet7 01-21-2015 12:52 AM

I was attempting to use Ubuntu 14.10 to run system-config-kickstart, and had the same problem. I removed the included version of hwdata, and attempted to use the latest version that was part of debian main. hwdata_0.267-1_all.deb. I went to remove this file using dpkg -r hwdata, and it wouldn't remove. It's because it was a dependency of the system-config-kickstart that I installed so that I could test to see of the newer version would work.

So, essentially, the post by vikas027 worked for me on Ubuntu 14.10. Thanks vikas027!!

fitz123 10-02-2015 06:02 AM

Linux fitz123-laptop 3.19.0-23-generic #24-Ubuntu SMP Tue Jul 7 18:52:55 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
VERSION="15.04 (Vivid Vervet)"

Confirmed, there's still issue and purposed solution still works!


All times are GMT -5. The time now is 03:14 PM.