-   Ubuntu (
-   -   Switching Desktops ? (

KezzerDrix 04-11-2005 01:50 PM

Switching Desktops ?
I went from mandrake that couldn't seem to keep up on updates and dependency hell. To trying to install Gentoo, HA, HA, only if you have a month of Sundays, to bad to because their repository is awesome and up to date programs, such as america's army, mythtv, unreal 2k4, etc, etc can simply be "emerge" to the system. I wish debian/ubuntu were as up to date. But I can simply download the items from the sites and install them.

It is just easier to apt-get/emerge.

The question I have is that I am used to KDE and want to use KDE. Kubuntu gives me wierd graphical glitches. So I installed ubuntu and everything works, I then downloaded KDE 3.4 now how do I switch to it as my default?


onelung02 04-11-2005 02:31 PM



then just choose which one you want for defualt and restard X.


Ninja Cow 04-12-2005 01:21 AM


Originally posted by onelung02


then just choose which one you want for defualt and restard X.



I believe xwmconfig is Slack-specific. That's okay, though, since switching desktop environments without the handy command (xwmconfig) is simple.


The easiest way is to create an .xinitrc file with the command used to start KDE.

nano .xinitrc

In the file, add:

exec startkde

This will work for any DE or WM. My .xinitrc file looks something like this on my Debian box:

exec gnome-session
#exec icewm
#exec xscreensaver & fluxbox
#exec startkde

Notice how I comment-out KDE, IceWM, and Fluxbox. If I ever get the urge to use KDE, IceWM, or Fluxbox, I just uncomment the desired DE/WM. Also, take a look at my xscreensaver & fluxbox line. Notice how I add "xscreensaver &" prior to launching Fluxbox. What I'm doing is loading another process or application prior to launching Fluxbox. You can use this method to load any of your favorite programs when using startx. For example...

exec xchat & gaim & xmms & fluxbox

...will load xchat, gaim, xmms, and finally Fluxbox.

Or, in your case...

exec xchat & gaim & xmms & startkde

...will load xchat, gaim, xmms, and finally KDE.

Good luck. :)

**Edit** You may need to edit /etc/inittab and set your runlevel to 3, as well as disable gdm. Do this:

nano /etc/inittab

And edit:

# The default runlevel.

Change it to...

# The default runlevel.

Navigate to /etc/rc3.d

Rename S13gdm to something like disabledS13gdm:

mv S13gdm disabledS13gdm

masonm 04-12-2005 11:18 AM

gdm allows you to select your session type at log in and set the default. Just pick it from the session menu.

All times are GMT -5. The time now is 01:35 PM.