-   Ubuntu (
-   -   sudo apt-get update problem (

cola 05-24-2010 02:24 PM

sudo apt-get update problem

E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Couldn't lock list directory..are you root?

AlucardZero 05-24-2010 02:45 PM

a) a program is already running and has locked it
b) you didn't sudo it

tommcd 05-25-2010 10:17 AM

Make sure that when you run:

sudo apt-get update
sudo apt-get dist-upgrade

that no other package manager is running. So make sure that Update Manager, Synaptic, and the Ubuntu Software Store are not running when you try to update / upgrade from the terminal ....

cola 05-30-2010 10:38 PM

It's fixed.

AlucardZero 05-31-2010 10:37 AM

It's polite to post how you fixed it.

cola 05-31-2010 10:48 AM


Originally Posted by AlucardZero (Post 3987486)
It's polite to post how you fixed it.

Another apt was running in background.
It's stopped and everything is done.

zeeshanayub 10-22-2014 12:26 PM

sudo apt-get dist-upgrade and apt-get update command not working
i run command apt-get update
show error 404
please help me
and not working any software install command

knudfl 10-22-2014 02:26 PM

Post #7. See #2

No, of course you cannot use "apt-get update".

Not until you have changed those unstable <url>'s in /etc/apt/sources.list
... Or just wait to another day when the
links are working again.

Please stop asking again .... in your four? similar threads.


jeremy 10-23-2014 11:03 AM


You've posted about the same issue multiple times, including hijacking other members' threads. Please refrain from this in the future. Thanks.


All times are GMT -5. The time now is 08:16 AM.