LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 04-10-2005, 10:33 PM   #1
patisawsome
Member
 
Registered: Oct 2004
Posts: 52

Rep: Reputation: 15
Screen Resolution


I have just installed 5.04 on my Dell 2350 and I can't change my screen resolution. I click on change resolution and there is only one choice of resolution. Does any body have any solutions for this problem? Thanks alot in advance.
 
Old 04-10-2005, 11:00 PM   #2
njk77
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
You could try the following 3-key combinations:

Ctrl-Alt +

or

Ctrl-Alt -

That might work.
 
Old 04-10-2005, 11:10 PM   #3
patisawsome
Member
 
Registered: Oct 2004
Posts: 52

Original Poster
Rep: Reputation: 15
I tryed that but it didnt work. Does any one else have any ideas?
 
Old 04-11-2005, 12:06 AM   #4
Chuckinator
Member
 
Registered: Feb 2005
Distribution: Gentoo
Posts: 34

Rep: Reputation: 15
Try typing the following in a console:
Code:
sudo dpkg-reconfigure xserver-xorg
That will reconfigure your X.org windows server. You may be able to configure it so that it supports more screen resolutions.
 
Old 04-11-2005, 12:21 AM   #5
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
Have you tried to reconfigure your xserver? If not, here is how.

Open up a control terminal cut and paste the commands below one at a time.

Code:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
then

Code:
sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
These commands backup your original xorg.conf file, and tell Xserver that is has not been configured yet.

Then enter

Code:
sudo dpkg-reconfigure xserver-xorg
Go through the process until you get to your screen resolution settings, and choose your desired resolution. Make sure your video card can support what you put in otherwise you will end up at the command line upon reboot. Once done you should reboot (or restart X if you prefer) and whatever the highest resolution you chose, should be loaded. If not go in and select it via your control panel.

If you find yourself at the command line.....don't panic. Simply type

Code:
cp /etc/X11/xorg.conf.custom /etc/X11/xorg.conf
and reboot

Hope this helps!!
 
Old 04-11-2005, 11:52 AM   #6
retiem
Member
 
Registered: Jul 2003
Location: Frankfurt, Germany
Distribution: Mint, Ubuntu, Knoppix, RHEL
Posts: 65

Rep: Reputation: 15
patisawsome:
have found a workaround for this "screen resolution" issue?
-----------------------
I just installed Kubuntu 5.04 and have the exact same problem! There is no way the system would let me change the screen resolution from the lousy 640x480 it chose during installation. I have tried Ctrl Alt +/- with no effect, I have tried running "sudo dpkg-reconfigure xserver-xorg" with no effect! I have tried manually editing /etc/X11/xorg with no effect either! WTF???? This is certainly a turn down. I came into my office this morning, burn kubuntu's freshly downloaded .iso and wiped my old linux distribution to finally install the so awaited for kubuntu, just to run into this kind of "bug?" What is this KDE people?

On the other hand, the system won't let me switch the default init level to 3. WTF??!! I have tried editting /etc/inittab, but it just ignores any changes. It always boots in "init 2" mode. Please don't tell me this is another "bug?"

Any thoughts anyone?
Regards.

P.S. My box is an hp PIV with an hp 1502 LCD Monitor
 
Old 04-11-2005, 07:38 PM   #7
patisawsome
Member
 
Registered: Oct 2004
Posts: 52

Original Poster
Rep: Reputation: 15
I tried reconfiguring X and it never gave me the option of setting the screen resolution. Is there some other way of changing the screen resolution? Thanks you for your help in advance.
 
Old 04-11-2005, 08:08 PM   #8
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 25, 26, RHL 5.2
Posts: 560

Rep: Reputation: 56
Whenever I have problems with screen resolution I look at the monitor frequency settings. My understanding is that only certain frequencies will support higher resolutions. When you get those set correctly then you should be able to change your resolution.

Bill
 
Old 04-12-2005, 08:54 AM   #9
retiem
Member
 
Registered: Jul 2003
Location: Frankfurt, Germany
Distribution: Mint, Ubuntu, Knoppix, RHEL
Posts: 65

Rep: Reputation: 15
OK. I fixed the problem! After calming down and thinking a bit, I did realize it had to be a hardware detection/configuration problem. Here is how I managed to solve it:
I booted with the "Live CD Release Candidate" I had previously downloaded... boom! my screen resolution was just fine this time. I looked into /etc/X11/xorg.conf and noticed that the Section "Monitor" did have the HorizSync and the VertRefresh parameters defined! So, I booted back into my installed Kubuntu, editted my xorg.conf, added these parameters and everything worked fine.
So, the release candidate beats the final release! (?) Should not be that way...
Just wanted to share with you...
regards.
 
Old 04-12-2005, 06:39 PM   #10
patisawsome
Member
 
Registered: Oct 2004
Posts: 52

Original Poster
Rep: Reputation: 15
I booted up my Ubuntu live cd and the screen resolution was fine. Is there some way I can copy the xorg.conf from the live cd and transfer it to my desktops .conf file?Or is there some way I can change it to allow me to have a better resolution? Thankyou in advance for your time.
 
Old 04-12-2005, 07:12 PM   #11
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
You can copy the configuration in the live cd to a floppy disk or a usb drive and then copy it to your hard drive installation.
 
Old 04-13-2005, 07:09 PM   #12
patisawsome
Member
 
Registered: Oct 2004
Posts: 52

Original Poster
Rep: Reputation: 15
I copied my xorg.conf fiel onto a usb drive and put in my desktop computer and it worked perfectly. Thankyou so much for your help. You guys have helped me so much.

Patrick
----------
 
Old 04-14-2005, 11:11 PM   #13
mstrymn
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
This must be a gap in auto-detection for monitors. I had this problem and just compared Ubuntu's xorg.conf to my Slax xorg.conf, the monitor refresh rates and specs aren't defined by default. I found a temporary fix, it should work but don't blame me if your monitor explodes (mine is like a generic CRT, be wary of these specs LCD users).....

If you feel like being safe, I would recomend download Slax live cd and checking it's generated xorg.conf and using their monitor specs.



1- Open root terminal and type "sudo gedit"

2- Find xorg.conf file in /ect/x11, open and find (monitor model may vary):
------------------------------------------------------------------
Section "Monitor"
Identifier "DELL P780"
Option "DPMS"
EndSection
-------------------------------------------------------------------

3- add this (you can put the correct numbers for your monitor, these numbers are from a generic monitor and should work):
-------------------------------------------------------------------
HorizSync 31.5 - 150.0
VertRefresh 40-75
-------------------------------------------------------------------

so it looks like this:
-------------------------------------------------------------------
Section "Monitor"
Identifier "DELL P780"
Option "DPMS"
HorizSync 31.5 - 150.0
VertRefresh 40-75
EndSection
-------------------------------------------------------------------

4- Save and reboot. You should now have more options in System->Preferences->Screen Resolutions

5- *Hopefully* ENJOY!

Bryan Helmig
 
Old 04-17-2005, 02:38 AM   #14
spaceuser
Member
 
Registered: Oct 2004
Location: Sweden
Distribution: Debian | Ubuntu | Mint | Android
Posts: 37

Rep: Reputation: 15
I find it strange though that the Ubuntu team in the latest version have removed any screen resolution other than 640 x 480 in 60 Hz in my comp. In the previous version there was no problem at all with the screen resolution.

I tried the Live CD as someone suggested above, but resulted in the same manner.

I use the ASUS P4P800VM motherboard which uses the Intel 865G chipset, w integrated graphics, network and sound.

I would apreciate if anyone could clarify why they seem to have removed support for my kind of hardware, when it was there in the previous version (both Live and install CD versions). Is it better for me to downgrade my system?

TIA

Last edited by spaceuser; 04-17-2005 at 02:40 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 02:33 AM
Screen lock changes screen resolution ohzo Linux - Laptop and Netbook 0 06-23-2004 12:13 PM
Unable to configure screen resolution for 15.2" LCD screen in Fedore Core 1 schu Linux - Newbie 3 01-02-2004 06:39 PM
screen freezes after making changes to the screen resolution with Xconfigurator sharathkv Linux - Newbie 1 08-01-2003 06:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration