-   Ubuntu (
-   -   Qemu with kqemu support problem (

luke-indul 05-31-2006 12:58 PM

Qemu with kqemu support problem
the problem:
I`ve compiled the Qemu and Kqemu accelerator on my Ubuntu Breezy with gcc-3.4 and there is no '-kernel-kqemu' option when I try to start qemu.

qemu: invalid option -- '-kernel-kqemu'
Qemu works fine, but I can't start it witk kqemu support. When I type ./configure before compiling Qemu there is "kqemu support yes", but after compilation it doesn't work.
Does anybody used Qemu with Kqemu on Ubuntu Breezy and know why it doesn't work??

On my frinds Gentoo it works just fine...

uteck 05-31-2006 01:28 PM

This thread may help,
I think I used the solution inthere were you change the permissions on the kqemu module.
as root, try this;
/sbin/modprobe kqemu
mknod /dev/kqemu c 250 0
chmod 666 /dev/kqemu

luke-indul 05-31-2006 02:35 PM


/sbin/modprobe kqemu
mknod /dev/kqemu c 250 0
chmod 666 /dev/kqemu
That's not that, I've tried this, but the result was the same as earlier.
I've loaded the Kqemu module

QEMU Accelerator Module version 1.3.0, Copyright (c) 2005-2006 Fabrice Bellard
This is a proprietary product. Read the LICENSE file for more information
Redistribution of this module is prohibited without authorization
KQEMU installed, max_locked_mem=253284kB.

About the link you posted uteck, I've tried few of how-to's, but nothing works for me. Qemu works, but without kqemu acceleration :(

All times are GMT -5. The time now is 06:55 AM.