-   Ubuntu (
-   -   Problems with Intel 965GM Express Chipset (

Shuk 05-24-2007 02:12 PM

Problems with Intel 965GM Express Chipset

I got a new laptop and want to run Ubuntu Feisty on it. Unfortunately I have some problems with the Intel® 965GM Express Chipset. I can't run the highest resolution (1440x900). I tried to configure xorg.conf but that didn't help.

I found these instructions and tried to follow them:

But when I execute "make menuconfig" and go to Device Driver -> Character devices -> /dev/agpgart (AGP Support), I can't enable it!

I think as a result of the disabled agpgart I get this message:

GARTInit: Unable to open /dev/agpgart (No such file or directory)
Unfortunately I am quite a noob in terms of using Linux and have no idea how to fix that problem and install the correct driver for my system.

Would be great if someone could help me and point out the steps I have to do.


binary_y2k2 05-25-2007 09:32 AM

make sure the modules drm, intel_agp and agpgart are loaded. I.e:

sudo modprobe drm
sudo modprobe intel_agp
sudo modprobe agpgart

Shuk 05-25-2007 10:39 AM

thanks for your answer!

Unfortunately I can't load agpgart for whatever reasons. As I've written in the first post it is not enabled in the Kernel. Neither as module nor as "Kernel-part". And I can't enable it! I downloaded a vanilla Kernel, disabled all components but still can't enable agpgart in the Kernel. Any ideas why I can't?

It's really an annoying thing to have the driver but are not able to use it :(

Still hope that someone can help me.

binary_y2k2 05-26-2007 03:01 AM

What do you mean you can't enable it? what happens if you try?

Shuk 05-26-2007 08:05 AM

Well, for the other entries you just hit space or one of the defined keys to change the status (M, *, or empty). But for agpgart the entry looks like [---] and when I hit space it changes nothing. So for whatever reasons it is disabled and I can't enable it in the Kernel. I thought that I maybe have to enable something in the Bios to be able to change the status of agpgart in the Kernel but unfortunately I can't find a related option in my Bios.

Any ideas?

binary_y2k2 05-26-2007 08:46 AM

What kernel version are you trying to compile and where did you get it from?
The BIOS has nothing to do with what modules you decide to compile into a kernel. I could, for instance, compile a PowerPC (Mac) kernel on a X86 PC.

Shuk 05-26-2007 09:16 AM

The Kernel that came with Ubuntu and I tried to compile is 2.6.20. I also downloaded 2.6.21 but it is also disabled there. It's really weird since I read that usually the Kernel supports agpgart by default?

Honestly, I have no idea what to do. But there should be a way to enable agpgart, right?

binary_y2k2 05-26-2007 09:39 AM

agpgart is enabled in the default kernel, so you could just copy the config over to the source dir and compile from that.

root@box:/usr/src/linux-source-2.6.20# cp /boot/config-2.6.20-15-generic .config
root@box:/usr/src/linux-source-2.6.20# make oldconfig

Then continue the compile as normal

Shuk 05-30-2007 03:49 PM

After some more testing and trying to get it work I think it is a problem with the 64-bit version of Ubuntu.

I installed the 32-bit version and after updating the xserver-xorg-video-intel driver everything worked fine. Also the agpgart option is enabled in the Kernel of the 32-bit version.

After installing the 64-bit version again, I encountered the same problems as before:
- agpgart is not an option in the kernel
- I don't get the intel graphics to work

So there MUST be a difference between the 64- and 32-bit version in view of the intel graphics. I have a brand new Thinkpad T61 with new Santa Rosa platform and the newest intel chipset (Intel® 965GM Express Chipset). Maybe the architecture of my pc is not supported yet? I have no idea actually. In my opinion there should be a way to get the intel graphics working for 64-bit as well, but I don't have any more ideas at the moment.

If someone out there has a solution, please let me know!

All times are GMT -5. The time now is 04:20 PM.