-   Ubuntu (
-   -   Opera Java Plugin Install (

karuptdata 09-26-2005 12:45 PM

Opera Java Plugin Install
Hello i have been trying to install a java plugin for opera with no success.....Does anyone have any idea on how to get this accomplished..

NoXiS 09-26-2005 12:48 PM


Opera looks for plugins in the mozilla plugins folder as well as its own locations.

If you have Mozilla (or probably firefox) set up with the Java plugin it will work with Opera.

This is how I would do it presuming you have one of the other two browsers installed.

karuptdata 09-26-2005 01:02 PM

Hmmm interesting i made a symbolic link like this ln -s /usr/java/jre1.5.0_04/plugin/i386/ns7/ ./ in the usr/lib/mozilla/plugins is that what needed to be done??

chemdawg 09-26-2005 01:29 PM

Not so fast! I have Java working with a couple other browsers, including firefox, and it just won't work with Opera. Every time I go to verify the java path, it says it's invalid. Can't figure out why. Here's the other posts on this topic:

hope this helps

BTW - still don't have mine working - if you find out how to fix please post solution!

karuptdata 09-26-2005 01:34 PM

One more issue i have flash installed but it doesnt seem to work....any ideas on this one??

chemdawg 09-26-2005 02:10 PM

hmm - did you verify that the flash plugins are in the /opera/plugins folder?

NoXiS 09-26-2005 06:34 PM

I was using the Java plugin with Opera fine before I had to reinstall over the weekend due to repository dependancy issues... damn libqt3 I think it was...

Opera was using the plugin installed in /usr/lib/mozilla/plugins as far as I can remember.

The trouble I'm having now is getting Java installed again, which I'll have to do soon. The installer I downloaded from sun had some dependancy problem I'll have to look into.

I'm going to try to get it on and will let you all know what happens soon.

@KaruptData: Your command to create the link in the mozilla folder looks fine to me, which is somewhat concerning. :rolleyes:

NoXiS 09-27-2005 06:43 AM

Right, I Reinstalled Java and created a symlink in /usr/lib/mozilla/plugins pointing to /usr/lib/jdk1.5.0_05/jre/plugin/i386/ns7/

Opera detected the plugin and I thought all was sorted - BUT I had to enable the option in Opera to use Java. This is found in Tools->Quick Preferences->Enable Java.

Maybe you just haven't selected this option... just maybe :-)

chemdawg 09-27-2005 09:57 AM

I have enabled it - but Opera isn't detecting the plug-in for some reason. Well, I am going to have to reinstall soon so maybe it'll get sorted out then!

gasykel 09-29-2005 08:46 AM

Java Plugin install assumes Java JRE install
I guess you're using the last 8.5 or almost last Opera browser. As mentionned in its help, what you need to do is downloading and installing Java sun JRE ( Then Tools/Preferences/Advanced will lead you to Java setting -among others-. You just have to enable Java and set in Java Options path to : /usr/java/jre1.5.0_04/lib/i386/ or something like (use browse to find where JRE libraries are).
That'all and it does work for me flawlessly.
P.S.: I assume your OS is linux or *nix.

chemdawg 09-29-2005 05:58 PM

Actually what you said is exactly what I did. When I point the java path to the correct directory where i installed the java plugin, or to the mozilla plugins folder (containing a working java), it says "Java path is invalid", when I know darn good and well it's the right path!

gasykel 09-30-2005 02:42 AM

Well, pointing java path to mozilla plugins folder did not make it. I tried it too in vain. I don't reallly understand what you mean by "the directory where I installed the java plugin". If you take a look again at online opera help, you'll find out - and they mentionned it over and over again - that java plugin is embedded within the browser itself. All you got to do -actually I guess you did - is pointing to an installed jre library. If you have trouble doing that, possible explanation is that:
1) Mandrake has some incompatibility with the newest jre libs install.
2) Mandriva installation force the jre library to be located a dedicated directory of its own.
Whatever the cause might be I think you'd rather scan mandriva-java forums. In my experience I doubt that there were big differences between redhat distros (mine) and Mandrake ones.
Another work-around is to step back to a lesser version of jre.....You may meet Mandriva requirement....

chemdawg 09-30-2005 09:32 AM

when i installed the latest java from sun, it goes in this path: /usr/java/jre1.5.0_04/plugin/i386/

when i open opera and enable java, then go to "java options" and then try to set the java path to the above directory, it says that it's invalid. Obviously its an opera problem because all my other browsers (mozilla and firefox 1.0.7) work just fine with java. That is why i tried to point the above java path to the mozilla plugins folder - it has a sym link to the java path there. still nothing. i've read about people whos java works fine so i dont' know what to do.

gasykel 09-30-2005 07:03 PM

Hey why do you insist in pointing to this false path ? Definitely in your case, as I stated earlier, you have to point to :
and nothing else.
Opera 8.x has nothing to do with ns plugin or whatsoever. Forget all that. Don't think in terms of classical browser plugin. You do not need to link to a file...
Hope this will fix permanently your setting.

chemdawg 10-01-2005 08:50 AM

wow, it did - i pointed it to that exact place and it worked! I'm glad you helped, because I wouldn't ever have guessed that path!

thanks again

All times are GMT -5. The time now is 07:17 PM.