-   Ubuntu (
-   -   On Ctrl+Alt+F1 shows 1st console , but on Ctrl+Alt+F7 doesnt go back to GUI, startx (

deskt0plinux 03-28-2012 06:50 AM

On Ctrl+Alt+F1 shows 1st console , but on Ctrl+Alt+F7 doesnt go back to GUI, startx
I might be doing it wrong, but isn't Ctrl+Alt+F1 / F7 supposed to allow switching between console (F1) and GUI (F7) ?

Everytime I go to console, when I try to come back I get a blank screen. The desktop is running, X is running, but I cant connect to it, so to speak.

When I try Ctrl+Alt+Backspace from the live CD that doesnt work too.
Neither does Ctrl+Alt+F11

Effectively I have only one option - reboot.

Also, I'd be glad is someone could tell me the command for starting an X session.
Or, if an X session is running, to kill it completely and restart and reconnect/enable it visually.

Thanks a ton in advance, this has been troubling me for some time.

catkin 03-28-2012 07:04 AM

The GUI isn't necessarily on vt7. It is on the first unused vt so try vt6, vt5 ...

ozanbaba 03-28-2012 07:11 AM

I would start trying from vt2.

eSelix 03-28-2012 08:02 AM

You can also switch VTs (next/previous) with ALT + Left/Right Arrow.

Lehjr 05-21-2012 09:11 AM

try Ctrl+Alt+F8. It might be related to this bug:

deskt0plinux 05-22-2012 02:56 AM

Well, it seems my motherboard is at fault
I'm using a Pentium 4 generic 865 chipset motherboard without any graphics card.
The system isnt OpenGL compliant and none but lightweight games run on it - even Gamemaker doesnt work.

I think that is probably the issue.

Anyway, thanks for all the responses!

EDIT: I forgot to mention that I tried everything from Ctrl+Alt+F1 to Ctrl+Alt+F12, tried everything from "kill -9 " for the X process, deleting the .X0-lock file and everything else the system suggested to try out - several times over, with multiple versions of Ubuntu - 8.04 t0 11.04. Same story. Seems quite unfixable to me.

All times are GMT -5. The time now is 02:27 PM.