-   Ubuntu (
-   -   nvidia installer (

tyfobpo 10-07-2006 06:02 PM

nvidia installer
finally got nvidia installer to start, but got error. this is from the installer log file:
i put the file on my site and am providing link to it, since it contained to much text for me to paste.

fragos 10-07-2006 06:51 PM

System-> Administration-> Synaptic Package Manager

Search for nvidia-glx and install/Apply it or nvidia-glx-legacy depending on how old your card is. The description will let you know which to use.

Micro420 10-07-2006 07:35 PM

I see what you did. You downloaded the Nvidia drivers from the Nvidia website. The error is here:


ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
      frequently when this kernel module was built against the wrong or
      improperly configured kernel sources, with a version of gcc that differs
      from the one used to build the target kernel, or if a driver such as
      rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
      obtaining ownership of the NVIDIA graphics device(s).

The EASIEST way to install the Nvidia driver is to do what fragos suggested. Install the nvidia-glx through apt-get or the Synaptics Package Manager. I'm not sure if you hosed your system or not. I remember trying to do some Nvidia installation after trying to manually install the drivers and I couldn't get the Nvidia drivers to load, even when I installed the nvidia-glx package. I had to reinstall the whole Ubuntu base system and start fresh. I then immediately installed nvidia-glx and it worked right away.

tyfobpo 10-07-2006 07:46 PM

yeah i did the nvidia-glx like he said, it installed, then i restarted x server w/ ctl alt backspace. now iunno how to test if things are working right or not? and if after i do test em, their not, reinstalling then doin what he said first shuld work? cuz i was wondering same thing, if all the manual stuff i tried first will have messed it up. first i need t see if its all working, and dont know how to do this ubuntu.

tyfobpo 10-07-2006 07:49 PM

just tried doing glxinfo and got this:


tyfobpo@tyfobpo-desktop:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

  visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None

fragos 10-07-2006 08:36 PM

Doesn't sound promising. You could try the following command:

cat /etc/X11/xorg.conf|grep Driver

A few lines will be displayed and the last line should be:

Driver "nvidia"

If the driver didn't install it will say "nv" or "vesa"

Micro420 10-07-2006 08:46 PM

Try what Fragos mentioned.

If the Nvidia driver is working, when you boot into KDE/Gnome, you will immediately see the Nvidia logo. plus when you run glxgears, you will see the gears turning.

If nothing else works, I say reinstall your base system and do the nvidia-glx package installation from the start.

tyfobpo 10-07-2006 09:00 PM

yeah, i did cat /etc/X11/xorg.conf|grep Driver and got vesa at the end. im just going to reinstall base system, and see what i get when i try after that.

tyfobpo 10-07-2006 09:48 PM

redid the system, did what u guys said, and i still get vesa =\

tyfobpo@tyfobpo-desktop:~$ cat /etc/X11/xorg.conf|grep Driver
        Driver          "kbd"
        Driver          "mouse"
  Driver        "wacom"
  Driver        "wacom"
  Driver        "wacom"
        Driver          "vesa"

Micro420 10-07-2006 11:04 PM

Uff! Are you using Kubuntu or Ubuntu? I'm just curious.

What kind of video card do you have Nvidia what series?

fragos 10-07-2006 11:27 PM

It's clear Linux doesn't recognize your video card try:

lspci|grep VGA

In my case I get the following line:

0000:01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

Publish yours and we see where that takes us.

tyfobpo 10-07-2006 11:28 PM

NVIDIA GeForce 6150 LE. Its a PCI Express Integrated card.

and im running ubuntu. got from here:

i downloaded the desktop cd version

tyfobpo 10-08-2006 02:49 AM

any other ideas on how to fix the probem?

tyfobpo 10-08-2006 05:23 AM

ok, i got the drivers working. now i installed ut2004. when the installer finished, it asked if i wanted to start, so i said yes. game booted, ran fine. then after, i tried to run the game again from the sorcut it made, and it didnt open. so i tried from a command line and got thise error:


tyfobpo@tyfobpo-desktop:~$ ut2004
Can't find 'ini:Engine.Engine.GameEngine' in configuration file


Exiting due to error

Micro420 10-08-2006 12:41 PM

THat sounds more like a UT2004 error than the Nvidia drivers.

Run the game manually at the directory instead of the shortcut. For example,

cd /home/username/ut2004

That's what I do for mine and it works.

All times are GMT -5. The time now is 03:07 AM.