-   Ubuntu (
-   -   No sound from headphones:( in 6.10 (

sagar.1986 02-09-2007 03:17 AM

No sound from headphones:( in 6.10
I am facing a strange problem. I get the sounds from speakers but not from audio jack. When i insert my headphones, the sound doesnot stop from the speakers. How can this be possible?

GrueMaster 02-10-2007 01:14 AM

Sigh. What version of alsa is it? Type "cat /proc/asound/version" to find out. What system are you running on (make/model). What type of sound card (built-in, usb, pci)? If you could post more information, I might be able to help (or point you in the right direction at least).

Just from the basic message, I'd almost guess that you are running a version of alsa that is older than 1.0.12 final, on an Intel 945 motherboard. Reason I say that is there was a problem withthe headphones on earlier drivers (which I fixed).

sagar.1986 02-10-2007 01:28 PM

Here is the output of cat /proc/asound/version:
Advanced Linux Sound Architecture Driver Version 1.0.12rc1 (Thu Jun 22 13:55:50 2006 UTC).

My laptop is Compaq Pressario V3029AU
Actually, headphone had worked when i had installed Suse before, so i guess it is the problem with the drivers.
$ lspci |grep -i audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

I am not sure which drivers are giving this type of problem

tmchardy 02-16-2007 04:59 PM

The Compaq Presario 3000, 6000, and HP dv6000 using the nVidia MCP51 chipset all seem to have similar issues. My answer is "specific" to FC6, but you may be able to do the same things to get it fixed:

Pre 1.0.13 (i.e. 1.0.12): Does not work. You get speaker, but no headphone or mic.

1.0.13: Adding the "disable_msi=1" line to your /etc/modprobe.conf file gives you separate controls for onboard vs. jacks. However, this will work. You'll just have to turn your speakers off and your headphones on in the mixer. See my post here as to how I got this working:

1.0.14(rc2): Speakers work. Plugging in Headphone works (mutes the onboard speakers too). However, "muting" the speakers doesn't work (works only when headphones are plugged in) and the microphone doesn't work at all.

Given a different Distro, 1.0.13 may be your best bet. However, I'm stuck as Fedora has not released kmdl files for 1.0.13 with the latest kernels. I'm currently stuck being unable to upgrade my kernel because the latest alsa is not working. :(

Note, the afore mentioned thread was getting my headphones to work under 1.0.13. I am now on this thread trying to solve my 1.0.14/upgrade woes:

GrueMaster 02-16-2007 05:11 PM

This is a Conexant audio issue. I have been writing a driver for this.

I just submitted a patch to alsa that will fix this. The patch can be found here. Instructions are here. You will need alsa-driver-1.0.14rc2 to start with.

There is still a little work to do, but testers are reporting that it works well.

ShadowHywind 02-16-2007 06:49 PM

hay Thanks for the patch, Looks like this patch might be what we are looking for. But when i did it i had a slight major issue with it. if i get sound from speakers+head i have to mute/unmute the master control. When i unplug headphones. I have to mute/unmute the master control to get sound out of speakers. Then if i plug my headphones in, i have to mute/unmute again, just to get headphones working and not from the speakers.

also when i run patch -p1 <conexant-<test patch>.patch what patch should that be exactly, I used conexant-latest.patch. But no idea where that conexant-latest.patch came from. So any ideas would be great.

On the plus side. My mic's seam to be working, but will test that out more later. I am running on a HP dv6040us, Kubuntu 6.10.

tmchardy 02-18-2007 07:27 PM

I couldn't get this patch to give me any result other than what the default 1.0.14rc2 gave me. :( I was pretty sure I followed the instructions right. :( (BTW - INSTRUCTIONS!!! What a novel idea! lol. I actually didn't mind playing with this for an hour with a bit of direction on what to do. :) Wish more people would provide those.) Anyways, I'll send you a PM with my dmesg and codec info. Back to 1.0.13. Can't be without that mic.

All times are GMT -5. The time now is 06:48 AM.