-   Ubuntu (
-   -   no ibus (

Pedroski 06-09-2012 07:43 AM

no ibus
1 Attachment(s)
Hi, I have a new installation of Ubuntu 12.04 I'm having trouble with ibus.

This morning it was working fine. This afternoon, on reboot, it is not present in the top bar of my screen. I tried running im-config, and checked the radio button 'ibus'

I also tried system settings > Language. Normally, one should be able to choose the input method there, but that function does not work, please see screenshot. Where it says 'keyboard input method system' no amount of clicking will elicit a response.

Any tips out there? I need my Chinese input!

Randicus Draco Albus 06-09-2012 08:21 AM

Try opening Ibus preferences. It should be somewhere in the Settings or Preferences menu, whichever Ubuntu uses.
In IBus/Preferences/General, enable Show icon on system tray.
That should work.

Pedroski 06-09-2012 08:32 AM

Thanks, but no that is not possible. Ibus is not accessible, so I can't adjust the preferences that way.

What I've done is uninstall everything connected with ibus, then reinstalled. Some older language choices were removed. Now it works again. I think the people at Ubuntu have changed things, but forgot to mention it. Now I can choose Sunpinyin. pinyin has gone. Probably there was a clash of libraries or whatever, I'm no expert. Languages has also disappeared from System Settings. Anyway, it works again. Time for bed, see if it works tomorrow morning!!

Randicus Draco Albus 06-09-2012 09:07 AM

If the Ibus preferences dialogue does not have an entry in the settings menu, it is probably another problem with the monster called Unity. Yet another reason to not use Ubuntu.

Pedroski 06-09-2012 12:51 PM

I only installed Ubuntu because Fedora 17 has too many problems. But the ibus always worked!

All times are GMT -5. The time now is 03:52 PM.