-   Ubuntu (
-   -   No Audio with Flash Player (

netjack 06-16-2007 03:16 PM

No Audio with Flash Player
I've just freshly installed ubuntu 7.04 (Feisty Fawn) - did all updates and then went to install the flash player by Adobe. However, I get the following problem: just picture no sound, i.e. for instance on, I can see all videos, but I don't get any sound.

My sound is set to ALSA (as it should) - MP3 playback and system sounds are fine (I can hear them).
about:plugins in firefox tells me that flash is there (Shockwave Flash 9.0 r60).

I would be very grateful for any hint (posts in Italian and German ubuntu forums had no reaction yet :confused: ).

SteveSch 06-16-2007 07:25 PM


You might run alsamixer and turn up the PCM volume. I hope that helps.


dinojerm 06-16-2007 10:45 PM

Another thing to check is your /etc/iceweasel/iceweaselrc file. It should contain the following line


netjack 06-17-2007 02:23 AM

I do not have iceweasel, but firefox, hence /etc/firefox/firefoxrc. But it contains:

Still no sound when playing flash videos. PCM is up of course. Another strange thing happens: Whenever I have played back some flash video, I must close that instance of Firefox, because it won't let me go to any other URL - it will just pretend to be loading for some short second, but pages are white. If I restart Firefox, I can surf the web again.

It seems I am the only one around with that problem...

pappy_mcfae 06-17-2007 02:41 AM

From my experience.
I had much the same problem with Slackware. What I found that cured the problem completely was compiling and upgrading to a 2.6.x version of the kernel. Since I don't work with Ubuntu, I don't know what kernel version comes with it.

There are numerous articles on the 'net about how to compile a kernel. However, Ubuntu is going to require special techniques due to its lack of a root user account. I STRONGLY suggest that you check with the Ubuntu forums for their method of kernel compilation.

Give that a try.

Hope it works. It did for me on three different machines.

Blessed be!

netjack 06-17-2007 04:25 AM

Whew, compiling the kernel is not one of the task I would expect a beginner would be comfortable with. After all, we're talking about "humanity" and "easyness" (ubuntu principles) here.

Anywhere, I tried to figure out the technical reasons behind the lack of sound. Googling around, it seems that the Adobe Flash Player audio I/O works through ALSA and that would mean that everytime the user does something else with audio *and* is watching a flash movie with sound, the flash audio won't be available. In an other forum they were complaining that the ALSA choice would make 90% of user complaint "I have no audio".

In my case however I am not listening to anything else - just the flash audio does not work.

This is my first approach to ubuntu. Up to now I have tried fedora and openSuSE and I must say ubuntu has way to go if it really wants to be that "human". I prefer both over ubuntu. Although I really liked snayptic install management.

IndyGunFreak 06-17-2007 07:22 AM

Are you on a laptop by chance?(I know it shouldn't matter, but I'm curious).

I have zero problems with Flash on my desktop, but my laptop does this on occasion. One time, I was trying to use Flash(on youtube I believe), and sound wasn't working. Thinking something had happened to my sound, I inadvertently left the webpage open, and went to my music folder in /home, and double clicked an mp3. Oddly, as soon as it opened up in Audacious, the Flash video's sound immediately began to play. It worked from that point on for quite some time. Then mysteriously did it again, so I clicked an mp3, and immediately the flash video's sound worked again.

I know it makes no sense, and I have no explanation for why it does this, but it does every so often. I'm not really experienced with Laptops, and I thought maybe by default my laptop was booting with the sound muted(although all of my mixers show sound all the way up). It usually seems to work fine, until I restart. Sometimes it will still work fine after I restart. Also, I installed Debian Etch on my laptop the other day, and the first time I booted Youtube, it did the same thing, so I don't think its Ubuntu related(and another reason I think its starting with the sound hardware disabled for some reason).

Anyone know why this might be?


Caballero del norte 06-17-2007 12:05 PM

no audio ć flash
I have noticed at times after "upgrading" that I have completely lost sound.

Amazingly enough, the answer for me twice was simply to go into the Volume Applet (you may have it installed on your Gnome panel), open Volume Control, and make sure that everything is turned on and that the volumes are turned up.

It seems that some installations/upgrades will default these settings back to "off" or "zero".

Good luck.:)

billdevlp 06-17-2007 12:48 PM

No sound in Flashplayer9
hello: I have AMD64 version of UBUNTU 7.04 and MEPIS 6.5 installed and had no sound in the Flashplayer9 either when I used the Wheel in Comcast cable connection. Now I described my setup I do not know it will help but this what I did : down loaded the 32bit support libraries using the command "apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2".
I think the last part of this command is important "linux32 lib32asound2" for the sound. I got this from the UBUNTU Discussion forum. I hope it will help somebody.

Best Regards

netjack 06-17-2007 03:29 PM

I tried

apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2
but it won't find any one of them ("Impossible to find xxxxx", where xxxx is any of the proposed libs).

tboerner 06-17-2007 04:25 PM


actually the solution is very simple: You have to tell firefox what audio system to use and this is done via /etc/firefox/firefoxrc where it should *not* read "none" but "FIREFOX_DSP="aoss" (or artsd if you prefer) when alsa is used as with feisty is the case. aoss works perfectly with me without changing anything else.

Hope that helps.

netjack 06-18-2007 12:05 AM


neither of the two suggestions worked for me. I also have frequent Firefox crashes (just kills itself and closes abruptly).

I have enough of this. Switching to openSuSE now. Thanks to all!

pappy_mcfae 06-18-2007 12:59 AM


Originally Posted by netjack
Whew, compiling the kernel is not one of the task I would expect a beginner would be comfortable with. After all, we're talking about "humanity" and "easyness" (ubuntu principles) here.

Be that as it may, sometimes we have to do things we don't want to do. As I said, from my experience, Flash simply wouldn't work under my 2.4.x kernel. Once I set up and compiled a 2.6.x kernel, it was as if by magic...suddenly, I had sound coming from Flash applications, both those at Youtube, and music from Myspace.

Plus, compiling a kernel isn't the most difficult thing one can do under Linux. As a matter of fact, you may not even have to do anything other than just compile the default kernel set up for your 2.6.x version. Getting my wireless networking to operate properly took much more time to do than compiling the kernel. As a matter of fact, I needed to move up to 2.6.x in order for my wireless networking to work at all. That is how I stumbled upon the fact that the 2.6.x kernel made Flash work properly.

There may be other means to get things rolling, but you shouldn't shrink from kernel compilation just because of fear. The truth of the matter is, in the world of Linux, many times, one has to do seemingly complex things in order to get things working properly. That's the nature of Linux.

Blessed be!

IndyGunFreak 06-18-2007 05:27 AM


Originally Posted by netjack

neither of the two suggestions worked for me. I also have frequent Firefox crashes (just kills itself and closes abruptly).

I have enough of this. Switching to openSuSE now. Thanks to all!

Was your system completely up to date? When I first installed Feisty, I had numerous problems with Firefox randomly closing, crashing for no obvious reason. It got so frustrated with it, I switched to Opera, which worked(and works) flawlessly. When I upgraded to Firefox, the problem stopped. I'm now using, and it hasn't been a problem since the first upgrade.

OpenSuse is a decent distro, I don't like RPM though, and to me, Suse is slow...

Good luck with it..


netjack 06-18-2007 06:12 AM

Hmm,maybe I'm getting closer to the problem here:

I installed openSuSE 10.2. It comes with Firefox 2.0 and an older version of Flashplayer (don't recall which one). Audio as for e.g. on worked fine.
After I've updated both Firefox to 2.0.4 and Flashplayer I have the same problem I had with when using ubuntu. I need to find a way to downgrade the flashplayer, maybe this is the cause.

Will post here with new insights. Thanks to all.

All times are GMT -5. The time now is 05:13 PM.