-   Ubuntu (
-   -   NAM is not working (

Nemi 03-04-2010 06:26 AM

NAM is not working

I have installed Ns-2.33 on ubuntu 9.1 ,Ns 2 has been installed successfully but i think NAM is not working.when i run a script(.tcl) then i get following error message....

nemi@nemi-desktop:~/Desktop$ nam:
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
bind Li..."

Plesse help me to sort out this problem



knudfl 03-05-2010 11:10 AM

Nam error : [code omitted because of length]

1) Possible reason: Compiling ns-allinone-2.3x with a wrong version of tcl.
Solution : apt-get remove tcl*
( tcl8.4 can be reinstalled after the ns2 / nam build.)
EDIT : Please see post # 4 ... and
...............About the patch 'tk-8.4-lastevent.patch'

2) May be use ns-allinone-2.34 instead.

More info : LQ Search → "Tag Name" = ns2
.. and ..

Nemi 03-06-2010 12:14 AM

Thanks friend .
I removed NS-2 2.33 and then i installed 2.34 sucessfully and it is working well.

dexter.9835416074 03-19-2010 08:58 AM

ya i had the same problem. if you do not want to reinstall, do this:

Download the tk-8.4-lastevent.patch from ,

place it in ur tk8.4.18 directory and go to the same directory and execute,

patch -p0 < ./tk-8.4-lastevent.patch

now reinstall tk. if it still does not work , reinstall the whole thing.

though this solution was for fedora, it worked for my ubuntu also.

All times are GMT -5. The time now is 02:30 AM.