-   Ubuntu (
-   -   mounting samba share on ubuntu 12.10 server on to ubuntu 12.10 desktop (

brainard 03-10-2013 04:44 PM

mounting samba share on ubuntu 12.10 server on to ubuntu 12.10 desktop

This is my first post and I'm a bit of a Linux n00b. I'm having trouble auto mounting a shared file located on Ubuntu 12.10 server. I'm trying to mount the file on Ubuntu 12.10 desktop. I've been working on this off and on almost all week and have implemented every fix I could find online.

The error messages is:
If I click on the mounted shared file located on the "side bar" on the desktop nothing happens. Nothing opens and no messages are displayed. However, if I go through network browser and click on the file I can access the it without any restrictions - I can copy, paste, save, whatever. Also I have a windows xp computer on the network that can access the shared files without any problems at all.

When I run sudo mount -a I get the error message:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

If I try to click on the shared file in the network browser I get the the error:
mount: only root can mount // on /media/samba_share

I've checked the manual and as many websites as I could find that reference those errors. And have implemented all of the fixes I found. But I'm still getting the same two error messages.

Currently the applicable section of the fstab file looks like this:
# Samba share cifs - omgdocuments
// /media/samba_share cifs credentials=/home/desktop001/.smbcredentials,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

The ~/.smbcredentials file looks like this:
username=name of the user on the server
password=password of the user on the server

I have made the dir /media/samba_share and have set the permissions 0777. Also at one point this weekend I made sure the file was owned by the user and then, out of frustration, I gave the user root access.

Normally I would just access the file via network browser, but this is for work and the person using the computer isn't smart enough to click on a few files to access her work. So I really need to find a way to make it simple to access the network files. Either auto mounting the file or I'm open to any and all recommendations. (Is is possible to just put a link to the "network borwser" file on the desktop?)

I'm a little worried that I've tired to implement to many "fixes" and have messed up some other setting that's causing these errors. Sorry if my terminology is incorrect or if I didn't make the issue clear. If you have any questions please ask and I will do my best to answer. Thank you very much for your help. :)

camorri 03-12-2013 09:00 AM


I have made the dir /media/samba_share and have set the permissions 0777
What user owns samba_share ? If its owned by root, that may be your problem. I usually mount samba shares in the a /home dir. You can try chown to some group, and add the user to that group.

brainard 03-14-2013 02:04 PM

Hello camorri,

Thank you very much for the quick reply. I had already made sure the owner of the share was the group and user that was trying to mount the share. I even created a new group and user and gave ownership to them. That was one of the first things I tried.

Because no data was saved on the desktop (everything is on the server) I ended up just removing the current install and reinstalling everything. It's working perfect now. I used the same setup I did before so I'm not sure what the problem was, however I'm sure it was just a stupid mistake. I must have overlooked something simple.

But thank you so much for the reply. I agree with what you said and will make share folders in /home/something from here on out. That will def prevent root access errors.

I'm new to posting - is there a way I can give you a +1 or something for your reply?

camorri 03-14-2013 02:35 PM

Glad its working for you now.


is there a way I can give you a +1 or something for your reply?
Clicking on "Did you find this post helpful?" adds to the posters reputation. I see you did, thank-you.

Since this is now resolved, we ask the original poster to mark the thread 'Solved'. You do that by using the Thread Tools at the top, there is a Solved button. Only the OP can mark a thread solved.

All times are GMT -5. The time now is 08:22 PM.