LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Lubuntu 12 /etc/fstab entry to mount cdrom (https://www.linuxquestions.org/questions/ubuntu-63/lubuntu-12-etc-fstab-entry-to-mount-cdrom-4175434022/)

zeelog 10-25-2012 09:41 AM

Lubuntu 12 /etc/fstab entry to mount cdrom
 
Usually I have no troble with this, but Lubuntu
doesn't like my entry in /etc/fstab for mounting
my DVD/cdrom drive.
/dev/cdrom /media/my_cd udf,iso9660 user,noauto 0 0
I have made a directory in /media called my_cd.
/dev/cdrom is a link to /dev/sr0
I can't use /dev/sr0 Lubuntu doesn't like it.
Right now Lubuntu says I have the wrong file system.
auto doesn't work either.
Does anyone have a /etc/fstab entry that works for
mounting a DVD/cdrom in Lubuntu 12 ?

malekmustaq 10-26-2012 02:50 AM

Quote:

Originally Posted by zeelog (Post 4814618)
Usually I have no troble with this, but Lubuntu
doesn't like my entry in /etc/fstab for mounting
my DVD/cdrom drive.
/dev/cdrom /media/my_cd udf,iso9660 user,noauto 0 0
I have made a directory in /media called my_cd.
/dev/cdrom is a link to /dev/sr0
I can't use /dev/sr0 Lubuntu doesn't like it.
Right now Lubuntu says I have the wrong file system.
auto doesn't work either.
Does anyone have a /etc/fstab entry that works for
mounting a DVD/cdrom in Lubuntu 12 ?

zeelog,

It is just a matter of rule as defined in your distro. Check how it is written in your /etc/udev/rules.d/70-persistent:

$ cat /etc/udev/rules.d/70-persistent* | grep cd

You'd better write a rule your self using the "sr0" and let the /etc/fstab mount is automatically. (That's what I did to some distros I came to run recently.) That's a no-big-deal problem. You can solve it over a cup of coffeee.

Udev rule writing is very easy. Just a short read here, and here.

Goodluck.

m.m.

tommcd 10-27-2012 05:42 AM

Quote:

Originally Posted by zeelog (Post 4814618)
Usually I have no troble with this, but Lubuntu
doesn't like my entry in /etc/fstab for mounting
my DVD/cdrom drive.
/dev/cdrom /media/my_cd udf,iso9660 user,noauto 0 0
...

Why do you need a line in /etc/fstab to mount CDs or DVDs?
My fstab is the default provided by the Lubuntu install (except for the noatime option I have added for my ext3 partitions).
It has no entry at all for the optical drive:
Code:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=fcc7ba28-d277-41c2-a998-0621d6b699dd /              ext4    errors=remount-ro 0      1
# /data was on /dev/sdb5 during installation
UUID=1c82c3df-d1de-4d0a-a20c-2321803b4410 /data          ext3    defaults,noatime        0      2
# /data2 was on /dev/sdb1 during installation
UUID=628b326a-b0ef-4cd6-93a1-6b46de3ba2bd /data2          ext3    defaults,noatime        0      2
# swap was on /dev/sda3 during installation
UUID=e8af6412-1db5-4b93-93f7-515bad1f7561 none            swap    sw              0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0      0

Any optical disc with data on it will usually automount without problems. If it does not, I can mount or unmount it using the file manager.


All times are GMT -5. The time now is 01:27 PM.