LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Logitech quickcam fusion won't work (https://www.linuxquestions.org/questions/ubuntu-63/logitech-quickcam-fusion-wont-work-464279/)

berraf 07-15-2006 08:17 AM

Logitech quickcam fusion won't work
 
I've searched around to find out how to make my webcamera work. But no luck.

lsusb gives this
Bus 001 Device 004: ID 046d:08c1 Logitech, Inc.

I use ubuntu 6.06 but any kind of help would be kind.
I installed "canorama" which say: Could not connect to device /dev/video0

unSpawn 07-16-2006 06:34 AM

If lsusb returns a line it's got the module loaded I guess...
Is the videodev kernel module loaded?
Are there any USB-related messages in dmesg or syslog?

berraf 07-25-2006 09:28 AM

Silly question but what is videodev? Where do I find it?
I've compiled whit all options under "Multimedia options" and all options under "Video capture devices"
This is what lsmod says:

snd_pcm_oss 33344 -
snd_mixer_oss 13760 -
lp 8164 -
ipv6 186048 -
ohci_hcd 28580 -
ehci_hcd 36040 -
8250_pnp 8224 -
8250 15956 -
serial_core 14432 -
via_agp 7424 -
usblp 10304 -
parport_pc 22756 -
parport 28104 -
uhci_hcd 24620 -
usbcore 112544 -
snd_via82xx 20084 -
snd_ac97_codec 80032 -
snd_ac97_bus 1728 -
snd_pcm 66024 -
snd_timer 17060 -
snd_page_alloc 7272 -
snd_mpu401_uart 5280 -
snd_rawmidi 17024 -
snd_seq_device 5900 -
snd 39428 -
soundcore 6336 -
eepro100 24656 -
mii 4096 -
nls_iso8859_1 3712 -
ntfs 88084 -
ide_scsi 12004 -
agpgart 26064 -

dmesg gives this:

usb 1-2.1: new full speed USB device using uhci_hcd and address 3
usb 1-2.1: ep0 maxpacket = 8
usb 1-2.1: default language 0x0409
usb 1-2.1: new device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-2.1: Product: deskjet 5600
usb 1-2.1: Manufacturer: hp
usb 1-2.1: SerialNumber: MY34U1M03X89
usb 1-2.1: uevent
usb 1-2.1: configuration #1 chosen from 1 choice
usb 1-2.1: adding 1-2.1:1.0 (config #1, interface 0)
usb 1-2.1:1.0: uevent
drivers/usb/core/inode.c: creating file '003'
hub 1-2:1.0: port 3, status 0101, change 0001, 12 Mb/s
hub 1-2:1.0: debounce: port 3: total 100ms stable 100ms status 0x101
usb 1-2.3: new full speed USB device using uhci_hcd and address 4
usb 1-2.3: skipped 1 descriptor after configuration
usb 1-2.3: skipped 8 descriptors after interface
usb 1-2.3: skipped 1 descriptor after endpoint
usb 1-2.3: skipped 15 descriptors after interface
usb 1-2.3: skipped 1 descriptor after endpoint
usb 1-2.3: skipped 4 descriptors after interface
usb 1-2.3: skipped 2 descriptors after interface
usb 1-2.3: skipped 1 descriptor after endpoint
usb 1-2.3: skipped 2 descriptors after interface
usb 1-2.3: skipped 1 descriptor after endpoint
usb 1-2.3: skipped 2 descriptors after interface
usb 1-2.3: skipped 1 descriptor after endpoint
usb 1-2.3: new device strings: Mfr=0, Product=0, SerialNumber=0
usb 1-2.3: uevent
usb 1-2.3: configuration #1 chosen from 1 choice
usb 1-2.3: adding 1-2.3:1.0 (config #1, interface 0)
usb 1-2.3:1.0: uevent
usb 1-2.3: adding 1-2.3:1.1 (config #1, interface 1)
usb 1-2.3:1.1: uevent
usb 1-2.3: adding 1-2.3:1.2 (config #1, interface 2)
usb 1-2.3:1.2: uevent
usb 1-2.3: adding 1-2.3:1.3 (config #1, interface 3)
usb 1-2.3:1.3: uevent
uhci_hcd 0000:00:07.3: suspend_rh (auto-stop)
drivers/usb/core/inode.c: creating file '004'
hub 1-2:1.0: state 7 ports 4 chg 0000 evt 0008
parport_pc: VIA parallel port: io=0x378, irq=7
usblp 1-2.1:1.0: usb_probe_interface
usblp 1-2.1:1.0: usb_probe_interface - got id
drivers/usb/core/file.c: looking for a minor, starting at 0
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x03F0 pid 0x6104
usbcore: registered new driver usblp

I really don't know what all this means

unSpawn 07-25-2006 09:54 AM

Silly question but what is videodev? Where do I find it? I've compiled whit all options under "Multimedia options" and all options under "Video capture devices"
Sorry. Videodev is the module you get when you say "yes" to kernel-compiling "Video for Linux" (V4L). Feeding the device ID (08c1) to The Linux-USB device overview website yields http://www.qbik.ch/usb/devices/showdev.php?id=3544 which refers to an experimental driver at http://linux-uvc.berlios.de/. You'll have to get the source with SVN.

shamimkhaliq 03-11-2009 08:53 PM

logitech quickcam fusion not working here neither
 
dmesg gives:
[ 58.329486] Linux video capture interface: v2.00
[ 58.555549] uvcvideo: Found UVC 1.00 device <unnamed> (046d:08c1)
[ 59.557825] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -110 (exp. 26).
[ 60.557141] uvcvideo: Failed to query (129) UVC control 1 (unit 0) : -110 (exp. 26).
[ 60.557154] uvcvideo: Failed to initialize the device (-5).
[ 60.557241] usbcore: registered new interface driver uvcvideo
[ 60.557247] USB Video Class driver (v0.1.0)

lsusb gives:
Bus 001 Device 002: ID 046d:08c1 Logitech, Inc.

and this means? i need to intialise the device?

i did the berlios thing. the microphone's working. i just can't webcam chat (everyone's loss ;-)

shamimkhaliq 03-12-2009 04:28 AM

UVC module fails to initialize webcam
 
i did this and it didn't work; skype still has no video devices found:


(x-posted from http://www.dellcommunity.com/support...hread.id=13835)

---
I did a clean install with the thin display/UVC webcam. now it won't work at all. Here's the relevant section of dmesg output:


[ 20.719793] uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:7670)
[ 20.720088] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
[ 20.720337] uvcvideo: Failed to query (129) UVC control 1 (unit 0) : -32 (exp. 26).
[ 20.720340] uvcvideo: Failed to initialize the device (-5).
[ 20.720371] usbcore: registered new interface driver uvcvideo
[ 20.720374] USB Video Class driver (v0.1.0)

---

Found more information on the problem here: http://developer.berlios.de/feature/...&group_id=5681

---

And fixed it by installing the latest UVC module from svn:

1. install prereqs if you don't have them

sudo aptitude install subversion build-essential

2. back up current module, just in case

sudo cp /lib/modules/2.6.24-16-generic/ubuntu/media/usbvideo/uvcvideo.ko /lib/modules/2.6.24-16-generic/ubuntu/media/usbvideo/uvcvideo.ko.bak


3. Check out latest source code

svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk


4. go to the 'trunk' directory

cd trunk


5. Edit Makefile

nano Makefile (or use gedit or whatever you like)

6. Change the line starting with INSTALL_MOD_DIR to this:

INSTALL_MOD_DIR := /lib/modules/$(KERNEL_VERSION)/ubuntu/media/usbvideo

7. Install it

make

sudo make install


8. Reboot


dmesg still gave me a "Failed to query" line, but everything works now! Tested in Cheese and Ekiga.


All times are GMT -5. The time now is 08:38 PM.